好股票网今日更新股票软件: 0 个 共有股票软件公式: 46454 个 总容量: 184.713 G | 共有文章: 7953

【实战看盘工具——斜率观测器】飞狐源码介绍

【实战看盘工具——斜率观测器】飞狐源码

指标源码如下:


INPUT: 起点(50,1,9999,1),终点(2,0,9999,1);

A1:=backset(barstatus=2,起点);
A2:=backset(barstatus=2,终点);
H1:VERTLINE(CROSS(A1 ,0.5 ) , 1),Color000fff;
H2:VERTLINE(CROSS(A2 ,0.5 ) , 1),Color00ff00;
{幅度:=(c-REF(c ,BARSLAST( CROSS(A1 ,0.5 )) ))/REF(c ,BARSLAST(
CROSS(A1 ,0.5 )) )*100;}
幅度:=(REF(c ,BARSLAST( CROSS(A2 ,0.5 )) )-REF(c ,BARSLAST( CROSS(A1
,0.5 )) ))/REF(c ,BARSLAST( CROSS(A1 ,0.5 )) )*100;
斜率:=ATAN(幅度/((起点-终点) ))*180/3.1416;
斜边:=SQRT(POW(幅度 ,2 )+POW(起点-终点 ,2 ) );
伸长:=SUM(幅度 ,0 );
震荡率:=伸长/斜边;
强势暴涨:=斜率>60 ;
B1:=REF(H ,BARSLAST(CROSS(起点+(起点-终点)/2 ,0.5 ) ) );
A5:=backset(barstatus=2,起点);
A6:=backset(barstatus=2,终点);
DRAWLINE(a5,C ,a6 AND CROSS(A2 ,0.5 ) ,C,0),Color000fff,linethick2;
DRAWTEXTABS(250,10,'斜率:'+NUMTOSTRN(斜率,2)),Color000fff,linethick5;

DRAWTEXT(斜率>=60 AND CROSS(A2 ,0.5 ),H*1.01 ,'强势暴涨' );
DRAWTEXT(斜率>=45 AND 斜率<60 AND CROSS(A2 ,0.5 ),H*1.01 ,'强势大涨' );
DRAWTEXT(斜率<=-40 AND CROSS(A2 ,0.5 ),H*1.01 ,'弱势暴跌' );
DRAWTEXT(斜率<=-20 AND 斜率>-40 AND CROSS(A2 ,0.5 ),H*1.01 ,'弱势大跌' );


 


【实战看盘工具——斜率观测器】飞狐源码

【实战看盘工具——斜率观测器】飞狐源码


相关说明
  • 好股票软件下载网欢迎用户将网页内容和下载地址转发到博客、微博、论坛等。
  • 发布的公式指标绝大部分是来源于各大论坛,谢谢各位老师的原创指标。
  • 判断公式指标好坏,请用户参考用户评论或者软件好评度
  • alg格式股票公式,仅仅可以用飞狐交易师股票软件引入使用;
  • fnc格式股票公式,可以用大智慧新一代高速行情分析系统股票软件使用,少部分可以用分析家股票软件引入使用;
  • exp格式股票公式,仅可以用大智慧经典版股票软件引入使用;
  • tnctni格式股票公式,仅可以用通达信新引入使用,例如可以用通达信股票软件引入使用;
  • tne格式公式,仅可以用通达信公式编辑器5.0版导入,高版本兼容低版本;
  • hxf格式股票公式,仅可以用同花顺股票软件引入使用。
  • 如果引入公式的时候,发现公式名称栏空白,调整电脑时间到1997年,能出现公式名称并正常显示,可能是公式使用期限已过。
  • 如果您发现下载链接错误,请点击报告错误谢谢!

软件下载

找到您需要的资源啦!?
本站所有软件高速免费下载,记得下次再来哦,好股票网是您下载的首选!
  • 软件大小:0 Bytes
  • 下载次数:0
  • 更新时间:2017-09-18 11:14:00
不能下载请报告错误,谢谢!