好股票网今日更新股票软件: 1 个 共有股票软件公式: 46438 个 总容量: 184.677 G | 共有文章: 7953

大智慧MACD面积副图源码 贴图介绍

请教,如何把圆圈中红柱前的4个数值在数值栏显示出来,谢谢

大智慧MACD面积副图源码 贴图

DIFF:EMA(CLOSE,12) - EMA(CLOSE,26),LAYER0;
DEA:EMA(DIFF,9),LAYER0;
MACD:2*(DIFF-DEA),LINETHICK0;
绿柱面积:10*IF (MACD<0,SUM(MACD,BARSLAST(MACD>0)),0),LINETHICK0,Color00ff00,PRECIS2;
红柱面积:10*IF (MACD>0,SUM(MACD,BARSLAST(MACD<0)),0),LINETHICK0,colorred,PRECIS2;
DRAWTEXT(ref(MACD,1)>0 and MACD<=0 ,HHV(MACD,4),''+ref(红柱面积,1)),PRECIS1,ALIGN1,VALIGN1,colorred;
DRAWTEXT(ref(MACD,1)<0 and MACD>=0 ,LLV(MACD,4),''+ref(abs(绿柱面积),1)),ALIGN1,Color00ff00,PRECIS1;
DRAWTEXT(BARSTATUS=2 AND MACD<0,LLV(MACD,8),''+abs(绿柱面积)),align2,Colorwhite{004A00},PRECIS0;
DRAWTEXT(BARSTATUS=2 AND MACD>0,HHV(MACD,4),''+abs(红柱面积)),align2,VALIGN1,colorred;
MACDhs:=IF(MACD>0 AND MACD>REF(MACD,1),MACD,0);
MACDhx:=IF(MACD>0 AND MACD<REF(MACD,1),MACD,0);
MACDlx:=IF(MACD<0 AND MACD<REF(MACD,1),MACD,0);
MACDls:=IF(MACD<0 AND MACD>REF(MACD,1),MACD,0);
STICKLINE(MACDhs>0,0,MACD,8,0),Color0000BB;
STICKLINE(MACDhs>0,0,MACD,7,0),Color0000CC;
STICKLINE(MACDhs>0,0,MACD,6,0),Color0000CC;
STICKLINE(MACDhs>0,0,MACD,5,0),Color0000DD;
STICKLINE(MACDhs>0,0,MACD,4,0),Color0033DD;
STICKLINE(MACDhs>0,0,MACD,3,0),Color3355EE;
STICKLINE(MACDhs>0,0,MACD,2,0),Color6677EE;
STICKLINE(MACDhs>0,0,MACD,1,0),Color8888FF;
STICKLINE(MACDhs>0,0,MACD,1,0),Color9999FF;
STICKLINE(MACDhx>0,0,MACD,8,0),Color0077BB;
STICKLINE(MACDhx>0,0,MACD,7,0),Color0088CC;
STICKLINE(MACDhx>0,0,MACD,6,0),Color0099CC;
STICKLINE(MACDhx>0,0,MACD,5,0),Color00AADD;
STICKLINE(MACDhx>0,0,MACD,4,0),Color11BBDD;
STICKLINE(MACDhx>0,0,MACD,3,0),Color22CCEE;
STICKLINE(MACDhx>0,0,MACD,2,0),Color33DDEE;
STICKLINE(MACDhx>0,0,MACD,1,0),Color44EEFF;
STICKLINE(MACDhx>0,0,MACD,1,0),Color55FFFF;

STICKLINE(MACDlx<0,MACD,0,8,0),COLOR007700;
STICKLINE(MACDlx<0,MACD,0,7,0),COLOR009900;
STICKLINE(MACDlx<0,MACD,0,6,0),COLOR00AA00;
STICKLINE(MACDlx<0,MACD,0,5,0),COLOR00BB00;
STICKLINE(MACDlx<0,MACD,0,4,0),COLOR11CC11;
STICKLINE(MACDlx<0,MACD,0,3,0),COLOR22DD22;
STICKLINE(MACDlx<0,MACD,0,2,0),COLOR33FF33;
STICKLINE(MACDlx<0,MACD,0,1,0),COLOR44FF44;
STICKLINE(MACDlx<0,MACD,0,1,0),COLOR55FF55;
STICKLINE(MACDls<0,MACD,0,8,0),ColorBB0000;
STICKLINE(MACDls<0,MACD,0,7,0),ColorCC0000;
STICKLINE(MACDls<0,MACD,0,6,0),ColorCC2200;
STICKLINE(MACDls<0,MACD,0,5,0),ColorDD4400;
STICKLINE(MACDls<0,MACD,0,4,0),ColorDD6611;
STICKLINE(MACDls<0,MACD,0,3,0),ColorEE8822;
STICKLINE(MACDls<0,MACD,0,2,0),ColorEEAA33;
STICKLINE(MACDls<0,MACD,0,1,0),ColorFFBB44;
STICKLINE(MACDls<0,MACD,0,1,0),Color55FF55;
{STICKLINE(MACDlx<0,MACD,0,8,0),ColorBB0000;
STICKLINE(MACDlx<0,MACD,0,7,0),ColorCC0000;
STICKLINE(MACDlx<0,MACD,0,6,0),ColorCC2200;
STICKLINE(MACDlx<0,MACD,0,5,0),ColorDD4400;
STICKLINE(MACDlx<0,MACD,0,4,0),ColorDD6611;
STICKLINE(MACDlx<0,MACD,0,3,0),ColorEE8822;
STICKLINE(MACDlx<0,MACD,0,2,0),ColorEEAA33;
STICKLINE(MACDlx<0,MACD,0,1,0),ColorFFBB44;
STICKLINE(MACDlx<0,MACD,0,1,0),ColorFFCC55;
STICKLINE(MACDls<0,MACD,0,8,0),Color007700;
STICKLINE(MACDls<0,MACD,0,7,0),Color009900;
STICKLINE(MACDls<0,MACD,0,6,0),Color00AA00;
STICKLINE(MACDls<0,MACD,0,5,0),Color00BB00;
STICKLINE(MACDls<0,MACD,0,4,0),Color11CC11;
STICKLINE(MACDls<0,MACD,0,3,0),Color22DD22;
STICKLINE(MACDls<0,MACD,0,2,0),Color33FF33;
STICKLINE(MACDls<0,MACD,0,1,0),Color44EF44;
 


相关说明
  • 好股票软件下载网欢迎用户将网页内容和下载地址转发到博客、微博、论坛等。
  • 发布的公式指标绝大部分是来源于各大论坛,谢谢各位老师的原创指标。
  • 判断公式指标好坏,请用户参考用户评论或者软件好评度
  • alg格式股票公式,仅仅可以用飞狐交易师股票软件引入使用;
  • fnc格式股票公式,可以用大智慧新一代高速行情分析系统股票软件使用,少部分可以用分析家股票软件引入使用;
  • exp格式股票公式,仅可以用大智慧经典版股票软件引入使用;
  • tnctni格式股票公式,仅可以用通达信新引入使用,例如可以用通达信股票软件引入使用;
  • tne格式公式,仅可以用通达信公式编辑器5.0版导入,高版本兼容低版本;
  • hxf格式股票公式,仅可以用同花顺股票软件引入使用。
  • 如果引入公式的时候,发现公式名称栏空白,调整电脑时间到1997年,能出现公式名称并正常显示,可能是公式使用期限已过。
  • 如果您发现下载链接错误,请点击报告错误谢谢!

软件下载

找到您需要的资源啦!?
本站所有软件高速免费下载,记得下次再来哦,好股票网是您下载的首选!
  • 软件大小:0 Bytes
  • 下载次数:0
  • 更新时间:2017-04-03 20:32:00
不能下载请报告错误,谢谢!