好股票网今日更新股票软件: 15 个 共有股票软件公式: 47813 个 总容量: 189.306 G | 共有文章: 7979

【实战看盘工具——斜率观测器】飞狐源码


公式名称:[B]【实战看盘工具——斜率观测器】飞狐源码[/B]
公式类型:飞狐股票公式
运行平台:Win7/Vista/WinXP/Win2003/
公式语言:简体中文
授权方式:共享版
公式大小:0 Bytes
更新时间:2017-09-18 11:14:00
公式简介:

【实战看盘工具——斜率观测器】飞狐源码

指标源码如下:


INPUT: 起点(50,1,9999,1),终点(2,0,9999,1);

A1:=backset(barstatus=2,起点);
A2:=backset(barstatus=2,终点);
H1:VERTLINE(CROSS(A1 ,0.5 ) , 1),Color000fff;
H2:VERTLINE(CROSS(A2 ,0.5 ) , 1),Color00ff00;
{幅度:=(c-REF(c ,BARSLAST( CROSS(A1 ,0.5 )) ))/REF(c ,BARSLAST(
CROSS(A1 ,0.5 )) )*100;}
幅度:=(REF(c ,BARSLAST( CROSS(A2 ,0.5 )) )-REF(c ,BARSLAST( CROSS(A1
,0.5 )) ))/REF(c ,BARSLAST( CROSS(A1 ,0.5 )) )*100;
斜率:=ATAN(幅度/((起点-终点) ))*180/3.1416;
斜边:=SQRT(POW(幅度 ,2 )+POW(起点-终点 ,2 ) );
伸长:=SUM(幅度 ,0 );
震荡率:=伸长/斜边;
强势暴涨:=斜率>60 ;
B1:=REF(H ,BARSLAST(CROSS(起点+(起点-终点)/2 ,0.5 ) ) );
A5:=backset(barstatus=2,起点);
A6:=backset(barstatus=2,终点);
DRAWLINE(a5,C ,a6 AND CROSS(A2 ,0.5 ) ,C,0),Color000fff,linethick2;
DRAWTEXTABS(250,10,'斜率:'+NUMTOSTRN(斜率,2)),Color000fff,linethick5;

DRAWTEXT(斜率>=60 AND CROSS(A2 ,0.5 ),H*1.01 ,'强势暴涨' );
DRAWTEXT(斜率>=45 AND 斜率<60 AND CROSS(A2 ,0.5 ),H*1.01 ,'强势大涨' );
DRAWTEXT(斜率<=-40 AND CROSS(A2 ,0.5 ),H*1.01 ,'弱势暴跌' );
DRAWTEXT(斜率<=-20 AND 斜率>-40 AND CROSS(A2 ,0.5 ),H*1.01 ,'弱势大跌' );


 


【实战看盘工具——斜率观测器】飞狐源码

【实战看盘工具——斜率观测器】飞狐源码


[url=http://www.goodgupiao.com/gupiaogongshi/46353.html][B]【实战看盘工具——斜率观测器】飞狐源码[/B][/url]

此公式暂不提供下载


软件下载

找到您需要的资源啦!?
本站所有软件高速免费下载,记得下次再来哦,好股票网是您下载的首选!
  • 软件大小:0 Bytes
  • 下载次数:0
  • 更新时间:2017-09-18 11:14:00
不能下载请报告错误,谢谢!