好股票网今日更新股票软件: 32 个 共有股票软件公式: 46504 个 总容量: 184.940 G | 共有文章: 7953

画线指标新编(源码 主图 飞狐 贴图)


公式名称:[B]画线指标新编(源码 主图 飞狐 贴图)[/B]
公式类型:飞狐股票公式
运行平台:Win7/Vista/WinXP/Win2003/
公式语言:简体中文
授权方式:共享版
公式大小:0 Bytes
更新时间:2017-01-23 20:42:00
公式简介:

DRAWGBK(c>0 , COLORRgb(0,0,0), COLORRGB(0,0,1),1);
KLINE(O,H,L,C,0);
input:N(10,1,88);
V1:=ISLASTBAR;
V2:=REF(HIGH,N)=HHV(HIGH,2*N+1);
V3:=FILTER(V2,N);
V4:=BACKSET(V3,N+1);
V5:=FILTER(V4,N);
V6:=V5 OR V1;
V7:=REF(LOW,N)=LLV(LOW,2*N+1);
V8:=FILTER(V7,N);
V9:=BACKSET(V8,N+1);
VA:=FILTER(V9,N);
VB:=VA AND NOT(V5);
VC:=BACKSET(V6,REF(BARSLAST(VB),1)+1);
VD:=VC>REF(VC,1);
VE:=BACKSET(VD,2);
VF:=VE>REF(VE,1);
V10:=BACKSET(VF AND COUNT(V6,REF(BARSLAST(VB),1)+2)=0,REF(BARSLAST(VB),1)+2);
V11:=V10>REF(V10,1);
V12:=BACKSET(V11 AND COUNT(V6,REF(BARSLAST(VB),1)+2)=0,REF(BARSLAST(VB),1)+2);
V13:=V12>REF(V12,1);
V14:=IF(V6,COUNT(VB,REF(BARSLAST(V6),1)+1),0);
V15:=IF(V14=1 AND V6,BARSLAST(VF),0);
V16:=IF(V6 AND REF(LOW,BARSLAST(VF))>=REF(LOW,BARSLAST(V11)),BARSLAST(V11),BARSLAST(VF));
V17:=IF(V14=2 AND V6,V16,0);
V18:=IF(V14>=3 AND V6,IF(V6 AND REF(LOW,V16)>=REF(LOW,BARSLAST(V13)),BARSLAST(V13),V16),0);
V19:=V15+V17+V18;
V1A:=BACKSET(V6,V19);
V1B:=V1A>REF(V1A,1);
V1C:=BACKSET(V1B,2);
V1D:=V1C>REF(V1C,1);
V1E:=V1D OR V1;
V1F:=BACKSET(V1E,REF(BARSLAST(V6),1)+1);
V20:=V1F>REF(V1F,1);
V21:=BACKSET(V20,2);
V22:=V21>REF(V21,1);
V23:=BACKSET(V22 AND COUNT(V1E,REF(BARSLAST(V6),1)+2)=0,REF(BARSLAST(V6),1)+2);
V24:=V23>REF(V23,1);
V25:=BACKSET(V24 AND COUNT(V1E,REF(BARSLAST(V6),1)+2)=0,REF(BARSLAST(V6),1)+2);
V26:=V25>REF(V25,1);
V27:=IF(V1E,COUNT(V5,REF(BARSLAST(V1E),1)+1),0);
V28:=IF(V27=1 AND V1E,BARSLAST(V22),0);
V29:=IF(V1E AND REF(HIGH,BARSLAST(V22))<=REF(HIGH,BARSLAST(V24)),BARSLAST(V24),BARSLAST(V22));
V2A:=IF(V27=2 AND V1E,V29,0);
V2B:=IF(V27>=3 AND V1E,IF(V1E AND REF(HIGH,V29)<=REF(HIGH,BARSLAST(V26)),BARSLAST(V26),V29),0);
V2C:=V28+V2A+V2B;
V2D:=BACKSET(V1E,V2C);
V2E:=V2D>REF(V2D,1);
V2F:=BACKSET(V2E,2);
V30:=V2F>REF(V2F,1);
DRAWLINE(V1D,LOW,V30,HIGH,0),linethick4,colorred;
DRAWLINE(V30,HIGH,V1D,LOW,0),linethick4,colorgreen;
DRAWLINE(REF(V1D,1),REF(L,1),V1D,L,0),LINETHICK2,,COLORBLUE;
DRAWLINE(REF(V30,1),REF(H,1),V30,H,0),LINETHICK2,,COLORBLUE;
{有好的建议请联系我qq:632939368}
V31:=BACKSET(V1,BARSLAST(V1D)+1);
V32:=V31>REF(V31,1);
V33:=BACKSET(V1,BARSLAST(V30)+1);
V34:=V33>REF(V33,1);
V35:=IF(BARSLAST(V32)<BARSLAST(V34),V32,V34);
V36:=IF(BARSLAST(V32)<BARSLAST(V34),LOW,HIGH);
DRAWLINE(V35,V36,V1,CLOSE,0),linethick2;
V37:=BACKSET(V1,BARSLAST(V1D)+1);
V38:=V37>REF(V37,1);
V39:=BACKSET(V38,REF(BARSLAST(V1D),1)+2);
V3A:=V39>REF(V39,1);
DRAWLINE(V3A,LOW,V38,LOW,1),linethick2;
V3B:=BACKSET(V1,BARSLAST(V30)+1);
V3C:=V3B>REF(V3B,1);
V3D:=BACKSET(V3C,REF(BARSLAST(V30),1)+2);
V3E:=V3D>REF(V3D,1);
DRAWLINE(V3E,HIGH,V3C,HIGH,1),linethick2;
前一低: REF(LOW,BARSLAST(V38)),colorccff99,LINEDOT,linethick2;
前一高: REF(HIGH,BARSLAST(V3C)),colorccff99,linethick2;
前二低: REF(LOW,BARSLAST(V3A)),colormagenta,LINEDOT,linethick2;
前二高: REF(HIGH,BARSLAST(V3E)),colormagenta,linethick2;


[url=http://www.goodgupiao.com/gupiaogongshi/44053.html][B]画线指标新编(源码 主图 飞狐 贴图)[/B][/url]

此公式暂不提供下载


软件下载

找到您需要的资源啦!?
本站所有软件高速免费下载,记得下次再来哦,好股票网是您下载的首选!
  • 软件大小:0 Bytes
  • 下载次数:0
  • 更新时间:2017-01-23 20:42:00
不能下载请报告错误,谢谢!