好股票网每日提供最新股票软件下载,如果您觉得不错,麻烦推荐给您的好友,谢谢!
您现在的位置:好股票网 >> 股票公式 >> 飞狐股票公式

切线“黄金分割” 均价线-(计算的模式 源码)

[下载地址]

好股票网经过测试可运行,该软件通过多款专业杀毒软件扫描

  • 360通过
  • 金山通过
  • 瑞星通过
  • 江民通过
  • 卡巴通过
  • 诺顿通过
  • 运行平台:Win7/Vista/WinXP/Win2003/
  • 公式语言:简体中文
  • 更新时间:2010-05-26 08:49:19
  • 公式评级:
  • 公式类型:飞狐股票公式
  • 授权方式:共享版
  • 公式大小:0 Bytes
  • 解压密码:goodgupiao
  • 下载统计:
  • 相关Tags:
已有次下载
推 荐88
不推荐0

切线“黄金分割” 均价线-(计算的模式 源码)介绍

好股票软件下载网(www.goodgupiao.com)提示:您正在下载的是:切线“黄金分割” 均价线-(计算的模式 源码)

此指标是以切线(黄金分割)均价线(MA EMA) 均价线角度 来统
计计算的模式。切线是以某以区间的高低点价位与均价线的比较及
结合量价进行研判进行买卖
INPUT:高(0,0,255),XS(0,0,1),调(0,0,2),F(0,0,255),F1(0,0,255),F2(0,0,255),角(0,0,1),角2(0,0,1);
TJA:=CLOSE>OPEN or CLOSE=OPEN and CLOSE>REF(CLOSE,1);
STICKLINE(TJA,LOW,HIGH,0,0),ColorE9;
STICKLINE(TJA,O,CLOSE,8,0),Color80;
STICKLINE(TJA,O,CLOSE,6,0),ColorA5;
STICKLINE(TJA,O,CLOSE,4,0),ColorC0;
STICKLINE(TJA,O,CLOSE,2,0),ColorE6;
STICKLINE(NOT(TJA),HIGH,LOW,0,0),Colorff00;
STICKLINE(NOT(TJA),CLOSE,OPEN,8,0),Color5000;
STICKLINE(NOT(TJA),CLOSE,OPEN,6,0),Color6600;
STICKLINE(NOT(TJA),CLOSE,OPEN,4,0),Color8000;
STICKLINE(NOT(TJA),CLOSE,OPEN,2,0),ColorA000;
QC:=REF(C,1);QO:=REF(O,1);QH:=REF(H,1);QL:=REF(L,1);
FUZ:=L+((H-L)/2);FUS:=O+((C-O)/2); FUSY:=C+((O-C)/2);SSFU:=(FUZ+IF(C>O,FUS,FUSY))/2;
FUZ1:=L+((H-L)*0.333);FUS1:=O+((C-O)*0.333);FUS1Y:=C+((O-C)*0.333);SSFU1:=(FUZ1+IF(C>O,FUS1,FUS1Y))/2;
FUZ2:=L+((H-L)*0.667);FUS2:=O+((C-O)*0.677);FUS2Y:=C+((O-C)*0.667);SSFU2:=(FUZ2+IF(C>O,FUS2,FUS2Y))/2;
B1:=Ql+((Qh-Ql)/2);B2:=QO+((QC-QO)/2);B3:=QC+((QO-QC)/2);
DB1:=QL+((QH-QL)*0.333);DB2:=QO+((QC-QO)*0.333);DB3:=QC+((QO-QC)*0.333);
EB1:=QL+((QH-QL)*0.667);EB2:=QO+((QC-QO)*0.667);EB3:=QC+((QO-QC)*0.667);
SYB1:=QH-((QH-QC)/2);SYB2:=QH-((QH-QO)/2);
SYB3:=IF(QC>QO,SYB1,SYB2);
XYB1:=QL+((QC-QL)/2);XYB2:=QL+((QO-QL)/2);
XYB3:=IF(QC<QO,XYB1,XYB2);
QFU:=(B1+IF(QC>QO,B2,B3))/2;
QDFU:=(DB1+IF(QC>QO,DB2,DB3))/2;
QEFU:=(EB1+IF(QC>QO,EB2,EB3))/2;
STICKLINE(C=C,SSFU2,SSFU2,4,0),COLOR00FF00,LINETHICK1;
STICKLINE(C=C,SSFU1,SSFU1,4,0),COLOR00FF00,LINETHICK1;
STICKLINE(C=C,SSFU,SSFU,6,0),COLOR00FFFF,LINETHICK1;
STICKLINE(C=C,IF(C>O,H-((H-C)/2),H-((H-O)/2)),IF(C>O,H-((H-C)/2),H-((H-O)/2)),1.3,0),COLORYELLOW,LINETHICK1;
STICKLINE(C=C,IF(C<O,L+((C-L)/2),L+((O-L)/2)),IF(C<O,L+((C-L)/2),L+((O-L)/2)),1.3,0),COLORYELLOW,LINETHICK1;
AJ:=AMOUNT/(VOL*100),COLORFFFFFF,LINETHICK0;
DRAWTEXT(C=C,AJ,'←'),COLORFFFFFF;
TT1:=ISLASTBAR=1 AND 角=0;
DRAWTEXTEX(TT1,0,10,17,' 前/现日振幅的1/2 【'+NUMTOSTR(QFU,2)+'】/【'+NUMTOSTR(SSFU,2)+'】'),Color00AAFF;
DRAWTEXTEX(TT1,0,10,30,' 前/现日振幅的:1/3 【'+NUMTOSTR(QDFU,2)+'】/【'+NUMTOSTR(SSFU1,2)+'】'),Color00FF00;
DRAWTEXTEX(TT1,0,10,47,' 前/现日振幅的:2/3 【'+NUMTOSTR(QEFU,2)+'】/【'+NUMTOSTR(SSFU2,2)+'】'),Color00FF00;
DRAWTEXTEX(TT1,0,10,60,' 前上影线幅度的1/2 【'+NUMTOSTR(SYB3,2)+'】'),ColorFFFFFF;
DRAWTEXTEX(TT1,0,10,73,' 前下影线幅度的1/2 【'+NUMTOSTR(XYB3,2)+'】'),ColorFFFFFF;
TTt:=ISLASTBAR=1;
TA1:=BARPOS=SYSPARAM(1);
TA2:=BARPOS=SYSPARAM(3);
T1:=datacount-barpos+0;
T2:=DATEDIFF(date,CURRENTDATE);
A1:=((H-L)/L)*100;
A2:=H-L;
MAI:=C*1.015;
MAII:=C*1.03;
DRAWTEXTEX(TTT AND 调=0,0,310,1,'▼明短线赢利[1.5%--3%:]'+'/'+NUMTOSTR(MAI[SYSPARAM(1)],2)+'--'+NUMTOSTR(MAII [SYSPARAM(1)],2)),Color00dd00;
DRAWTEXTEX(TTt,0,176,1,'【振幅:'+NUMTOSTR(A1[SYSPARAM(1)],2)+'% '+NUMTOSTR(A2[SYSPARAM(1)],2)+'元 】'+''),Colordddd00;
DRAWTEXTEX(TTT,0,1,1,'【代码:'+STKLABEL+' 名称:'+STKNAME+'】'),Color00FFFF;
as:=(o+h+l+c)/4;
BL: eMA(as,F),linethick1,Color208FFF;
BL1: MA(C,F1),linethick1,ColorFFFFFF;
BL2: MA(C,F2),linethick1,Color00FFFF;
PARTLINE(BL<REF(BL,1),BL),colorff0000,linethick2;
PARTLINE(BL1<REF(BL1,1),BL1),color00ff00,linethick1;
PARTLINE(BL2<REF(BL2,1),BL2),color00ff00,linethick1;
TT1:=ISLASTBAR=1 AND 角=1;TT2:=ISLASTBAR=1 AND 角2=1;
QMC:=REF(BL1,1);QMC1:=REF(BL1,2);
QMC2:=REF(BL2,1);QMC3:=REF(BL2,2);
CMC:=BL1-QMC;CMC1:=QMC-QMC1;CPJ:=(CMC+CMC1)/2;
CMD:=BL2-QMC2;CMD1:=QMC2-QMC3;DPJ:=(CMD+CMD1)/2;
Q1:=ATAN((BL1/REF(BL1,1)-1)*100)*180/3.1416;
Q2:=ATAN((QMC/REF(QMC,1)-1)*100)*180/3.1416;
Q3:=ATAN((QMC1/REF(QMC1,1)-1)*100)*180/3.1416;
AQ1:=ATAN((BL2/REF(BL2,1)-1)*100)*180/3.1416;
AQ2:=ATAN((QMC2/REF(QMC2,1)-1)*100)*180/3.1416;
AQ3:=ATAN((QMC3/REF(QMC3,1)-1)*100)*180/3.1416;
DRAWTEXTEX(TT1,0,75,16,'【任意均线角度】'+' '),COLORFFFFFF;
DRAWTEXTEX(TT1,0,2,30,' '+NUMTOSTR(F1,0)+''+'日=; ∠'+NUMTOSTR(Q1,2)+' 度'+'/ 前日=;∠'+NUMTOSTR(Q2,2)+' 度'+'/ 前2日=;∠'+NUMTOSTR(Q3,2)+' 度'+''),ColorFFffff;
DRAWTEXTEX(TT1,0,2,44,' '+NUMTOSTR(F1,0)+''+'日均值:'+NUMTOSTR(BL1,2)+' 元'+''+'/ 前日=: '+NUMTOSTR(QMC,2)+' 元'+'/ 前2日=: '+NUMTOSTR(QMC1,2)+' 元'),ColorFFffff;
DRAWTEXTEX(TT1,0,2,58,' '+NUMTOSTR(F1,0)+''+'日均线近三日的平均增(减)速;'+NUMTOSTR(CPJ,2)+' 元'+''),ColorFFffff;
DRAWTEXTEX(TT2,0,2,88,' '+NUMTOSTR(F2,0)+''+'日=; ∠'+NUMTOSTR(AQ1,2)+' 度'+'/ 前日=;∠'+NUMTOSTR(AQ2,2)+' 度'+'/ 前2日=;∠'+NUMTOSTR(AQ3,2)+' 度'+''),Color00ffff;
DRAWTEXTEX(TT2,0,2,102,' '+NUMTOSTR(F2,0)+''+'日均值:'+NUMTOSTR(BL2,2)+' 元'+''+'/ 前日=: '+NUMTOSTR(QMC2,2)+' 元'+'/ 前2日=: '+NUMTOSTR(QMC3,2)+' 元'),Color00ffff;
DRAWTEXTEX(TT2,0,2,116,' '+NUMTOSTR(F2,0)+''+'日均线近三日的平均增(减)速;'+NUMTOSTR(DPJ,2)+' 元'+''),Color00ffff;
BLT:=BARSTATUS=2;
DRAWTEXT(BLT AND BL>REF(BL,1),BL,'↑'+NUMTOSTR(f,0)+':'+NUMTOSTR(BL,2)),COLOR208fff;
DRAWTEXT(BLT AND BL<REF(BL,1),BL,'↓'+NUMTOSTR(f,0)+':'+NUMTOSTR(BL,2)),Color208FFF;
DRAWTEXT(BLT AND BL1>REF(BL1,1),BL1,'↑'+NUMTOSTR(f1,0)+':'+NUMTOSTR(BL1,2)),COLORFFffff;
DRAWTEXT(BLT AND BL1<REF(BL1,1),BL1,'↓'+NUMTOSTR(f1,0)+':'+NUMTOSTR(BL1,2)),ColorFFFDED;
DRAWTEXT(BLT AND BL2>REF(BL2,1),BL2,'↑'+NUMTOSTR(f2,0)+':'+NUMTOSTR(BL2,2)),COLOR00CCCC;
DRAWTEXT(BLT AND BL2<REF(BL2,1),BL2,'↓'+NUMTOSTR(f2,0)+':'+NUMTOSTR(BL2,2)),Color00CCCC;
B:=IF((SYSPARAM(1) = (BARSSINCE((C > 0)) + 1)),1,0);
B1:=(H<REF(L,1));
B2:=(L>REF(H,1));
STICKLINE(B1,o+(c-o)*0.25,O,5,0),colorcc0000;
STICKLINE(B1,o+(c-o)*0.25,O,3,0),colordd0000;
STICKLINE(B1,o+(c-o)*0.25,O,1,0),coloree0000;
STICKLINE(B2,O,o+(c-o)*0.25,6,0),color208AAA;
STICKLINE(B2,O,o+(c-o)*0.25,4,0),color208DDD;
STICKLINE(B2 ,O,o+(c-o)*0.25,2,0),color208FFF;
DRAWTEXT(((B > 0) AND B1),H,'↓缺口'),colorFFFFEE,pxdn10,ALIGN2;
DRAWTEXT(((B > 0) AND B2),L,'↑缺口'),color00FFEE,pxup20,ALIGN1;
//DRAWTEXTEX(TTT,0,2,61,'【创于09.08.02 草根】'),ColorFFFFFF;
X:=SYSPARAM(2);//最初
X1:=SYSPARAM(3);//最后
X2:=SYSPARAM(4);//最高
X3:=SYSPARAM(5);//最低
X4:=SYSPARAM(1);
YG:=REF(H,BARSLAST(TA1));YD:=REF(L,BARSLAST(TA1));
N:=((X1 - X) + 1);
ZG:=ref(H,高);
HH:=HHV(zg,1);
LL:=LLV(L,N);
GG:HH[X1],colorFF00FF;
DD1:LL[X1],colorff0000;
DD:=YD[X1],color005555,LINEDOT;
PARTLINE(YD,YD),LINETHICK1,COLOR00FF00;
//DRAWTEXT(TA2,YD,'K线低--'+NUMTOSTR(YD,2)),COLORFFFFFF,ALIGN2,PXDN5;
//DRAWTEXT(TA2,YG,'K线高--'+NUMTOSTR(YG,2)),COLORFFFFFF,ALIGN2,PXDN5;
DRAWTEXT(TTT ,DD1,'最低'+NUMTOSTR(DD1,2)),ALIGN1,colorFFEE00,,pxup25;
DRAWTEXT(TTT ,GG,' 最高'+NUMTOSTR(GG,2)),ALIGN1,colorffaaaa,,pxDN5;
Q:=(DD + ((GG - DD) * 0.191));
Q2:=(DD + ((GG - DD) * 0.382));
Q3:=(DD + ((GG - DD) * 0.50));
Q4:=(DD + ((GG - DD) * 0.618));
Q5:=(DD + ((GG - DD) * 0.809));
Y_1:=REF(Q,BARSLAST(TA1));
Y_2:=REF(Q2,BARSLAST(TA1));
Y_3:=REF(Q3,BARSLAST(TA1));
Y_4:=REF(Q4,BARSLAST(TA1));
Y_5:=REF(Q5,BARSLAST(TA1));
PARTLINE(Y_1,Y_1),LINEDOT,Color005555;
PARTLINE(Y_2,Y_2),LINEDOT,Color005555;
PARTLINE(Y_3,Y_3),LINEDOT,Colordddddd;
PARTLINE(Y_4,Y_4),LINEDOT,Color005555;
PARTLINE(Y_5,Y_5),LINEDOT,Color005555;
DRAWTEXT(TA2,Q,NUMTOSTR(Q,2)+' :--0.191'),COLOR00bbbb,ALIGN2,PXDN5;
DRAWTEXT(TA2,Q2,NUMTOSTR(Q2,2)+' :--0.382'),COLOR00bbbb,ALIGN2,PXUP22;
DRAWTEXT(TA2,Q3,'★:('+NUMTOSTR(Q3,2)+') ←*1/2'),COLORFFFFFF,ALIGN2,PXDN5;
DRAWTEXT(TA2,Q4,NUMTOSTR(Q4,2)+' :--0.618'),COLOR00bbbb,ALIGN2,PXDN5;
DRAWTEXT(TA2,Q5,NUMTOSTR(Q5,2)+' :--0.809'),COLOR00bbbb,ALIGN2,PXDN5;
JN1:=dd+(HH-dd)*0.875; JN7:=dd+(HH-dd)*0.85; JN9:=dd+(HH-dd)*0.72; JN12:=dd+(HH-dd)*0.28;
JN14:=dd+(HH-dd)*0.75; JN8:=dd+(HH-dd)*0.78; JN2:=dd+(HH-dd)*0.667;
JN6:=dd+(HH-dd)*0.125; JN10:=dd+(HH-dd)*0.25; JN13:=dd+(HH-dd)*0.15;
JN3:=dd+(HH-dd)*0.333; HJ6:=dd+(HH-dd)*0.55; HJ7:=dd+(HH-dd)*0.45;
HJ13:=dd+(HH-dd)*0.98; HJ14:=dd+(HH-dd)*0.93; JN11:=dd+(HH-dd)*0.22;
TT6:=ISLASTBAR=1 AND XS=1;
DRAWTEXT(TT6,JN1,''+'7/8﹡→('+NUMTOSTR(JN1,2)+' '+'← *'),ALIGN2,Coloraa88aa,pxUP8;
DRAWTEXT(TT6,JN14,''+'6/8﹡→('+NUMTOSTR(JN14,2)+' '+'← *'),ALIGN2,Coloraa88aa,pxUP8;
DRAWTEXT(TT6,JN7,''+'85%﹡→('+NUMTOSTR(JN7,2)+''+'-----'),ALIGN2,Color208bbb,pxUP8;
DRAWTEXT(TT6,JN8,''+'78%﹡→('+NUMTOSTR(JN8,2)+''+'← '),ALIGN2,Color9bbb00,pxUP8;
DRAWTEXT(TT6,JN9,''+'72%﹡→('+NUMTOSTR(JN9,2)+''+'← '),ALIGN2,Color9bbb00,pxUP8;
DRAWTEXT(TT6,JN2,''+'2/3﹡→('+NUMTOSTR(JN2,2)+' '+'←-- *'),ALIGN2,Color00FF00,pxUP8;
DRAWTEXT(TT6,JN3,''+'1/3﹡→('+NUMTOSTR(JN3,2)+' '+'←-- *'),ALIGN2,Color00FF00,pxUP8;
DRAWTEXT(TT6,HJ6,''+'55%﹡→('+NUMTOSTR(HJ6,2)+''+'←'),ALIGN2,ColorAAAAAA,pxUP8;
DRAWTEXT(TT6,HJ7,''+'45%﹡→('+NUMTOSTR(HJ7,2)+''+'←'),ALIGN2,ColorAAAAAA,pxUP8;
DRAWTEXT(TT6,JN10,''+'2/8﹡→('+NUMTOSTR(JN10,2)+' '+'← *'),ALIGN2,Coloraa88aa,pxUP8;
DRAWTEXT(TT6,JN6,''+'1/8﹡→('+NUMTOSTR(JN6,2)+' '+'← *'),ALIGN2,Coloraa88aa,pxUP8;
DRAWTEXT(TT6,HJ13,''+'98%﹡→('+NUMTOSTR(HJ13,2)+''+'← '),ALIGN2,Colorcccc00,pxUP8;
//DRAWTEXT(TT6,HJ9,''+'95%('+NUMTOSTR(HJ9,2)+''+'←'),ALIGN2,ColorFFFF00,pxDN2;
DRAWTEXT(TT6,HJ14,''+'93%﹡→('+NUMTOSTR(HJ14,2)+''+'← '),ALIGN2,Colorcccc00,pxUP8;
DRAWTEXT(TT6,JN13,''+'15%﹡→('+NUMTOSTR(JN13,2)+''+'-----'),ALIGN2,Color208EEE,pxUP8;
DRAWTEXT(TT6,JN12,''+'28%﹡→('+NUMTOSTR(JN12,2)+''+'← '),ALIGN2,Color9FFF00,pxUP8;
DRAWTEXT(TT6,JN11,''+'22%﹡→('+NUMTOSTR(JN11,2)+''+'← '),ALIGN2,Color9FFF00,pxUP8;
//DRAWTEXT(TT6,HJ10,''+'10%﹡→('+NUMTOSTR(HJ10,2)+''+'← '),ALIGN2,ColorFFFF00,pxUP8;
//DRAWTEXT(TT6,HJ12,''+'8%﹡→('+NUMTOSTR(HJ12,2)+''+'← '),ALIGN2,ColorFFFF00,pxUP8;
//DRAWTEXT(TT6,HJ15,''+'3%﹡→('+NUMTOSTR(HJ15,2)+''+'← '),ALIGN2,ColorFFFF00,pxUP8;
TT4:=ISLASTBAR=1 and 调=1;
TT5:=ISLASTBAR=1 and 调=2;
GHJS1:=YD+(HH-YD)*1.191; GJNS1:=YD+(HH-YD)*1.333;
GHJS2:=YD+(HH-YD)*1.382; GJNS2:=YD+(HH-YD)*1.25;
GHJS3:=YD+(HH-YD)*1.03; GJNS3:=YD+(HH-YD)*1.15;
GHJS4:=YD+(HH-YD)*1.08; GJNS4:=YD+(HH-YD)*1.125;
GHJS5:=YD+(HH-YD)*1.45; GJNS5:=YD+(HH-YD)*1.22;
GHJS6:=YD+(HH-YD)*1.50; GJNS6:=YD+(HH-YD)*1.28;
DRAWTEXT(TT4,GHJS3,''+'3%﹡→('+NUMTOSTR(GHJS3,2)+''+'← '),ALIGN2,ColorAAAA00,pxUP8;
DRAWTEXT(TT4,GHJS4,''+'8%﹡→('+NUMTOSTR(GHJS4,2)+''+'← '),ALIGN2,ColorAAAA00,pxUP8;
DRAWTEXT(TT4,GJNS4,''+'1/8﹡→('+NUMTOSTR(GJNS4,2)+' '+'← *'),ALIGN2,ColorFFAAAA,pxUP8;
DRAWTEXT(TT4,GJNS3,''+'15%﹡→('+NUMTOSTR(GJNS3,2)+' '+'← *'),ALIGN2,Color208EEE,pxUP8;
DRAWTEXT(TT4,GHJS1,''+'19.1%﹡→('+NUMTOSTR(GHJS1,2)+' '+'←- *'),ALIGN2,Color00BBBB,pxUP8;
DRAWTEXT(TT4,GJNS5,''+'22%﹡→('+NUMTOSTR(GJNS5,2)+''+'← '),ALIGN2,Color9AAA00,pxUP8;
DRAWTEXT(TT4,GJNS2,''+'2/8﹡→('+NUMTOSTR(GJNS2,2)+' '+'← *'),ALIGN2,ColorFFAAAA,pxUP8;
DRAWTEXT(TT4,GJNS6,''+'28%﹡→('+NUMTOSTR(GJNS6,2)+''+'← '),ALIGN2,Color9AAA00,pxUP8;
DRAWTEXT(TT4,GJNS1,''+'1/3﹡→('+NUMTOSTR(GJNS1,2)+' '+'←-- *'),ALIGN2,Color00DD00,pxUP8;
DRAWTEXT(TT4,GHJS2,''+'38.2%﹡→('+NUMTOSTR(GHJS2,2)+' '+'←- *'),ALIGN2,Color00BBBB,pxUP8;
DRAWTEXT(TT4,GHJS5,''+'45%﹡→('+NUMTOSTR(GHJS5,2)+' '+'← *'),ALIGN2,ColorBBBBBB,pxUP8;
DRAWTEXT(TT4,GHJS6,''+'50%﹡→('+NUMTOSTR(GHJS6,2)+''+'﹊﹊﹊﹊﹊﹊﹊﹊﹊﹊﹊﹊﹊'),ALIGN2,ColorDDDDDD,pxDN2;
GHJ1:=HH+(YD-HH)*1.191; GJN1:=HH+(YD-HH)*1.333;
GHJ2:=HH+(YD-HH)*1.382; GJN2:=HH+(YD-HH)*1.25;
GHJ3:=HH+(YD-HH)*1.03; GJN3:=HH+(YD-HH)*1.15;
GHJ4:=HH+(YD-HH)*1.08; GJN4:=HH+(YD-HH)*1.125;
GHJ5:=HH+(YD-HH)*1.45; GJN5:=HH+(YD-HH)*1.22;
GHJ6:=HH+(YD-HH)*1.50; GJN6:=HH+(YD-HH)*1.28;
GHJ7:=HH+(YD-HH)*1.55; GJN7:=HH+(YD-HH)*1.667;
GHJ8:=HH+(YD-HH)*1.618; GJN8:=HH+(YD-HH)*1.75;
GHJ9:=HH+(YD-HH)*1.809;
DRAWTEXT(TT5,GHJ3,''+'3%﹡→('+NUMTOSTR(GHJ3,2)+''+'← '),ALIGN2,ColorDDDD00,pxUP8;
DRAWTEXT(TT5,GHJ4,''+'8%﹡→('+NUMTOSTR(GHJ4,2)+''+'← '),ALIGN2,ColorDDDD00,pxUP8;
DRAWTEXT(TT5,GJN4,''+'1/8﹡→('+NUMTOSTR(GJN4,2)+' '+'← *'),ALIGN2,Color208FFF,pxUP8;
DRAWTEXT(TT5,GJN3,''+'15%﹡→('+NUMTOSTR(GJN3,2)+' '+'← *'),ALIGN2,Color208EEE,pxDN2;
DRAWTEXT(TT5,GHJ1,''+'19.1%﹡→('+NUMTOSTR(GHJ1,2)+' '+'←- *'),ALIGN2,Color00FFFF,pxUP8;
DRAWTEXT(TT5,GJN5,''+'22%﹡→('+NUMTOSTR(GJN5,2)+''+'← '),ALIGN2,ColorFFFF00,pxUP8;
DRAWTEXT(TT5,GJN2,''+'2/8﹡→('+NUMTOSTR(GJN2,2)+' '+'← *'),ALIGN2,Color208FFF,pxUP8;
DRAWTEXT(TT5,GJN8,''+'6/8﹡→('+NUMTOSTR(GJN8,2)+' '+'← *'),ALIGN2,Color208FFF,pxUP8;
DRAWTEXT(TT5,GJN6,''+'28%﹡→('+NUMTOSTR(GJN6,2)+''+'← '),ALIGN2,ColorFFFF00,pxUP8;
DRAWTEXT(TT5,GJN1,''+'1/3﹡→('+NUMTOSTR(GJN1,2)+' '+'←-- *'),ALIGN2,Color00FF00,pxUP8;
DRAWTEXT(TT5,GJN7,''+'2/3﹡→('+NUMTOSTR(GJN7,2)+' '+'←-- *'),ALIGN2,Color00FF00,pxUP8;
DRAWTEXT(TT5,GHJ2,''+'38.2%﹡→('+NUMTOSTR(GHJ2,2)+' '+'←- *'),ALIGN2,Color00FFFF,pxUP8;
DRAWTEXT(TT5,GHJ5,''+'45%﹡→('+NUMTOSTR(GHJ5,2)+' '+'← *'),ALIGN2,ColorffFFff,pxUP8;
DRAWTEXT(TT5,GHJ6,''+'50%﹡→('+NUMTOSTR(GHJ6,2)+''+' ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄'),ALIGN2,ColorfffFFF,pxDN2;
DRAWTEXT(TT5,GHJ7,''+'55%﹡→('+NUMTOSTR(GHJ7,2)+' '+'← *'),ALIGN2,ColorffFFff,pxUP8;
DRAWTEXT(TT5,GHJ8,''+'61.8%﹡→('+NUMTOSTR(GHJ8,2)+''+' ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄'),ALIGN2,Color00FFff,pxDN2;
DRAWTEXT(TT5,GHJ9,''+'80.9%﹡→('+NUMTOSTR(GHJ9,2)+''+' ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄'),ALIGN2,Color00FFff,pxDN2;
D1:=HH-dd;
D2:=D1/hh*100;
Dz2:=D1/dd*100;
D3:=HH-L;
D4:=D3/HH*100;
D5:=HH-c;
D6:=D5/HH*100;
D7:=H-dd;
D8:=D7/dd*100;
D9:=C-dd;
D10:=D9/dd*100;
GH1:=dd+(HH-dd)*1.55;
GH2:=dd+(HH-dd)*1.618;
GH3:=dd+(HH-dd)*1.667;
GH4:=dd+(HH-dd)*1.75;
GH5:=dd+(HH-dd)*1.809;
GH6:=dd+(HH-dd)*1.875;
DRAWTEXTEX(TT4,0,327,1,'【突破后空间】55%:('+NUMTOSTR(GH1,2)+' 元)--0.618:('+NUMTOSTR(GH2,2)+' 元)--2/3('+NUMTOSTR(GH3,2)+' 元)'),Coloraaaaaa;
DRAWTEXTEX(TT4,0,327,16,' 6/8:('+NUMTOSTR(GH4,2)+' 元)--0.809:('+NUMTOSTR(GH5,2)+' 元)--7/8('+NUMTOSTR(GH6,2)+' 元)'),Color00bb00;
STICKLINE(TA1,gg,dd,0,0),LINETHICK0,COLORFFAAAA;
DRAWTEXT((BARPOS = SYSPARAM(1)),dd,'▲'),ALIGN0,color00FFdd,pxdn5;
DRAWTEXT(TA1,SYSPARAM(4),'\n \n \n \n \n \n \n \n ★交易天:'+NUMTOSTR(T1[SYSPARAM(1)],0)+'(天) / '+'◆自然天:'+NUMTOSTR(T2[SYSPARAM(1)],0)+'(天) '),COLORbbbbbb,PXDN107,align2;
DRAWTEXT(TA1,SYSPARAM(4),' \n \n \n \n \n \n \n \n 阶段高('+NUMTOSTR(HH,2)+' 元)'+'\n ----至 ---'+ '\n K线低('+NUMTOSTR(YD,2)+' 元)'+''),COLOR00ee00,PXDN107,align2;
//DRAWTEXT(TA1,SYSPARAM(4),' \n \n \n \n \n \n \n \n ' +' \n \n \n 【创于09.08.02 草根】'),COLORFFFFFF,PXDN107,align2;
A:=SYSPARAM(1);
VERTLINE(BARPOS=A),pointdot,color996666,shift4;
VERTLINE(BARPOS=A),POINTDOT,color996666,shift7;
VERTLINE(BARPOS=A),POINTDOT,color996666,shift12;
VERTLINE(BARPOS=A),POINTDOT,color996666,shift20;
VERTLINE(BARPOS=A),POINTDOT,color996666,shift33;
VERTLINE(BARPOS=A),POINTDOT,color996666,shift54;
VERTLINE(BARPOS=A),POINTDOT,color996666,shift88;
VERTLINE(BARPOS=A),POINTDOT,color996666,shift143;
VERTLINE(BARPOS=A),POINTDOT,color996666,shift232;
DRAWTEXT(BARPOS=A,SYSPARAM(5),'天数'+NUMTOSTR(T1[SYSPARAM(1)],0)+' '),Color0095BC,align2,pxup50;
DRAWTEXT(BARPOS=A,SYSPARAM(5),'5'),Color0095BC,shift4,pxup50;
DRAWTEXT(BARPOS=A,SYSPARAM(5),'8'),Color0095BC,shift7,pxup50;
DRAWTEXT(BARPOS=A,SYSPARAM(5),'13'),Color0095BC,shift12,pxup50;
DRAWTEXT(BARPOS=A,SYSPARAM(5),'21'),Color0095BC,shift20,pxup50;
DRAWTEXT(BARPOS=A,SYSPARAM(5),'34'),Color0095BC,shift33,pxup50;
DRAWTEXT(BARPOS=A,SYSPARAM(5),'55'),Color0095BC,shift54,pxup50;
DRAWTEXT(BARPOS=A,SYSPARAM(5),'89'),Color0095BC,shift88,pxup50;
DRAWTEXT(BARPOS=A,SYSPARAM(5),'144'),Color0095BC,shift143,pxup50;
DRAWTEXT(BARPOS=A,SYSPARAM(5),'233'),Color0095BC,shift232,pxup50;
//添加到参数精灵
{
--------黄金线调整--------
峰顶 高 Param#1 手动调节任意波幅顶点(即交易天数);
回调 XS Param#2 调1时,计算K线低到任意顶点区间价位;
穿越 调 Param#3 调1-2时,计算上或下破点后区间价位;
--------均 价 线--------
均线 EMA Param#4 手动调节任意均线周期;
均线2 F1 Param#5 手动调节任意均线周期;
均线3 F2 Param#6 手动调节任意均线周期;
--------启用均线角度值--------
角=1 Param#7 对应均线2 F1; *角=0时是分位价
角2=1 Param#8 对应均线3 F2;
 


好股票软件下载网(www.goodgupiao.com)提醒您:股市有风险,投资需谨慎。
切线“黄金分割” 均价线-(计算的模式 源码)下载地址
相关说明
  • 好股票软件下载网欢迎用户将网页内容和下载地址转发到博客、微博、论坛等。
  • 发布的公式指标绝大部分是来源于各大论坛,谢谢各位老师的原创指标。
  • 判断公式指标好坏,请用户参考用户评论或者软件好评度
  • alg格式股票公式,仅仅可以用飞狐交易师股票软件引入使用;
  • fnc格式股票公式,可以用大智慧新一代高速行情分析系统股票软件使用,少部分可以用分析家股票软件引入使用;
  • exp格式股票公式,仅可以用大智慧经典版股票软件引入使用;
  • tnctni格式股票公式,仅可以用通达信新引入使用,例如可以用通达信股票软件引入使用;
  • tne格式公式,仅可以用通达信公式编辑器5.0版导入,高版本兼容低版本;
  • hxf格式股票公式,仅可以用同花顺股票软件引入使用。
  • 如果引入公式的时候,发现公式名称栏空白,调整电脑时间到1997年,能出现公式名称并正常显示,可能是公式使用期限已过。
  • 如果您发现下载链接错误,请点击报告错误谢谢!