好股票网每日提供最新股票软件下载,如果您觉得不错,麻烦推荐给您的好友,谢谢!
您现在的位置:好股票网 >> 股票公式 >> 通达信公式

持股待涨副图源码 通达信 贴图

[下载地址]

好股票网经过测试可运行,该软件通过多款专业杀毒软件扫描

  • 360通过
  • 金山通过
  • 瑞星通过
  • 江民通过
  • 卡巴通过
  • 诺顿通过
  • 运行平台:Win7/Vista/WinXP/Win2003/
  • 公式语言:简体中文
  • 更新时间:2018-01-14 20:11:00
  • 公式评级:
  • 公式类型:通达信公式
  • 授权方式:共享版
  • 公式大小:4.00 KB
  • 解压密码:goodgupiao
  • 下载统计:
  • 相关Tags:
已有次下载
推 荐0
不推荐0

持股待涨副图源码 通达信 贴图介绍

好股票软件下载网(www.goodgupiao.com)提示:您正在下载的是:持股待涨副图源码 通达信 贴图

{参数 D:34,90,72; N:1,100,26; P:5,60,14}
VAR1:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;
VAR2:=2*ABS(VAR1);
VAR3:=100-3*SMA((CLOSE-LLV(LOW,D))/(HHV(HIGH,D)-LLV(LOW,D))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,D))/(HHV(HIGH,D)-LLV(LOW,D))*100,20,1),15,1);
VAR4:=100-3*SMA((OPEN-LLV(LOW,D))/(HHV(HIGH,D)-LLV(LOW,D))*100,20,1)+2*SMA(SMA((OPEN-LLV(LOW,D))/(HHV(HIGH,D)-LLV(LOW,D))*100,20,1),15,1);
VAR5:=(HIGH+LOW+CLOSE)/3;
VAR6:=(VAR5-MA(VAR5,14))/(0.015*AVEDEV(VAR5,14));
VAR7:=(VAR5-MA(VAR5,89))/(0.015*AVEDEV(VAR5,89));
VAR8:=IF(VAR6>=150 AND VAR6<200 AND VAR7>=150 AND VAR7<200,10,0);
VAR9:=IF(VAR6<=-150 AND VAR6>-200 AND VAR7<=-150 AND VAR7>-200,-10,VAR8);
VARA:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;
VARB:=100-ABS(VARA);
VARC:=3*SMA((INDEXC-LLV(INDEXL,D))/(HHV(INDEXH,D)-LLV(INDEXL,D))*100,20,1)-2*SMA(SMA
((INDEXC-LLV(INDEXL,D))/(HHV(INDEXH,D)-LLV(INDEXL,75))*100,20,1),15,1);
VARD:=3*SMA((INDEXO-LLV(INDEXL,D))/(HHV(INDEXH,D)-LLV(INDEXL,D))*100,20,1)-2*SMA(SMA
((INDEXO-LLV(INDEXL,D))/(HHV(INDEXH,D)-LLV(INDEXL,75))*100,20,1),15,1);
VARE:=REF(LOW,1)*0.9;
VARF:=LOW*0.9;
VAR10:=(VARF*VOL+VARE*(CAPITAL-VOL))/CAPITAL;
VAR11:=EMA(VAR10,30);
VAR12:=VAR11-CLOSE;
VAR13:=REF(CLOSE,1);
VAR14:=SMA(MAX(CLOSE-VAR13,0),7,1)/SMA(ABS(CLOSE-VAR13),7,1)*100;
VAR15:=SMA(MAX(CLOSE-VAR13,0),13,1)/SMA(ABS(CLOSE-VAR13),13,1)*100;
VAR16:=BARSCOUNT(CLOSE);
VAR17:=SMA(MAX(CLOSE-REF(CLOSE,1),0),6,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),6,1)*100;
VAR18:=((-100)*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))+50)*2;
VAR19:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
VAR1A:=(SMA(VAR19,4,1)-50)*2;
VAR1B:=SMA(VAR1A,3,1);
VAR1C:=(INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14))*100;
VAR1D:=SMA(VAR1C,4,1);
VAR1E:=SMA(VAR1D,3,1);
VAR1F:=(HHV(HIGH,30)-CLOSE)/CLOSE*100;
VAR20:=IF(VAR17<=25 AND VAR18<-95 AND VAR1F>20 AND VAR1B<-30 AND VAR1E<30 AND VAR12>=-0.25 AND VAR14<22 AND VAR15<28 AND VAR16>50,80,0);
势能: VAR3,COLORFF00FF;
OX: IF(VARB<90,VARB,100),COLORFFCC66;
VAR21:=IF(VAR1>0,VAR1,0);
核能:= IF(VAR1<0,VAR2,0);
牛角: VAR20,COLORYELLOW;
预警: IF(VAR7>=200 AND VAR6>=150,15,IF(VAR7<=-200 AND VAR6<=-150,-15,VAR9))+60,COLOR00FF00;
VAR22:=100*(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34));
VAR23:=MA(VAR22,3);
VAR24:=EMA(AMOUNT/VOL/100,5);
VAR25:=EMA(AMOUNT/VOL/100,13);
VAR26:=VAR24-VAR25;
动能: IF(1000*VAR26/VAR24>0,1000*VAR26/VAR24,0),COLORRED,LINETHICK2;
动能抬头: (动能>2 AND REF(动能<=2,1))*15,COLORWHITE;
STICKLINE(VAR3>=REF(VAR4,1),VAR3,VAR4,8,1),COLORBLUE;
STICKLINE(VAR3<REF(VAR4,1),VAR3,VAR4,8,1),COLORRED;
VAR27:=CLOSE>MA(CLOSE,20) AND MA(CLOSE,20)>=REF(MA(CLOSE,20),1);
VAR28:=CLOSE<MA(CLOSE,20) AND MA(CLOSE,20)<REF(MA(CLOSE,20),1);
VAR29:=VAR21>50 AND 预警>60 AND OX=100;
VAR2A:=VAR21>48 AND 预警>60 AND OX<100;
VAR2B:=核能>38 AND 预警<55;
VAR2C:=牛角>50 AND OX<90;
VAR2D:=VAR3<REF(VAR4,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);
VAR2E:=VAR3>=REF(VAR4,1) AND CLOSE<REF(CLOSE,1) AND 预警=60 AND 牛角=0 AND 核能>=REF(核能,1) AND VARC<REF(VARD,1);
{DRAWTEXT(VAR27 AND COUNT(VAR27,30)=1,90,'持股待涨'),COLORFF00FF;
DRAWTEXT(VAR28 AND COUNT(VAR28,30)=1,10,'出局为佳'),COLOR00FF00;
DRAWTEXT(VAR29 AND COUNT(VAR29,30)=1,70,'上涨过急,需要调整'),COLORWHITE;
DRAWTEXT(VAR2A AND COUNT(VAR2A,30)=1,80,'拉升在即狂牛!'),COLORYELLOW;
DRAWTEXT(VAR2B AND COUNT(VAR2B,30)=1,20,'不必杀跌有反弹 '),COLORWHITE;
DRAWTEXT(VAR2C AND COUNT(VAR2C,30)=1,30,'角斗士,阶段底部 '),COLORYELLOW;
DRAWTEXT(VAR2D AND COUNT(VAR2D,30)=1,60,'大资金进场'),COLOR0099FF;
DRAWTEXT(VAR2E AND COUNT(VAR2E,30)=1,40,'高点回落'),COLORFFCC66;}
{准入:IF(VAR3<REF(VAR4,1),10,0);
C1:=C;
JC1:=(REF(C,3)+REF(C,5)+REF(C,7)+REF(C,13)+REF(C,21))/5;
参考价1:=SMA(JC1,3,1),COLORBLUE;
上升趋势:IF(C>参考价1,108,100),COLORYELLOW;
买:IF( IF(OX<100 OR 预警<60 OR 上升趋势>105,10,0) AND 准入, 10,0),LINETHICK0;
STICKLINE(买,-5,-11,3,0),COLORYELLOW;}
{吸筹}
LC:=REF(CLOSE,1);
止损价位:(LC*1.0035*97+0.2)/99.65,NODRAW;
RSI5:=SMA(MAX(CLOSE-LC,0),5,1)/SMA(ABS(CLOSE-LC),5,1)*100;
R:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
A:=SMA(R,3,1);
B:=SMA(A,3,1);
CCC:=(B/2+40)*1.1;
DDD:=SMA(CCC,3,1);
RR8:=MA(CLOSE,27);
RR9:=(CLOSE-RR8)/RR8*100;
RRA:=MA(RR9,2);
RRB:=BARSLAST(CROSS(-10,RRA)=1);
RRD:=RRA<-10 AND RRB>3;
TYP:=(HIGH + LOW + CLOSE)/3;
CCI:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14)),LINETHICK0;
组C_02:=REF(LOW,1);
组C_03:=SMA(ABS(LOW-组C_02),3,1)/SMA(MAX(LOW-组C_02,0),3,1)*100;
组C_04:=EMA(IF(CLOSE*1.3,组C_03*10,组C_03/10),3);
组C_05:=LLV(LOW,13);
组C_06:=HHV(组C_04,13);
组C_07:=IF(MA(CLOSE,34),1,0);
组C_08:=EMA(IF(LOW<=组C_05,(组C_04+组C_06*2)/2,0),3)/618*组C_07;
组C_09:=IF(组C_08>100,100,组C_08);
STICKLINE(CROSS(DDD,RSI5),110,100,3,0),COLORRED;{顶部红块}
STICKLINE(CROSS(80,RSI5),100,90,3,0),COLORGREEN;{顶部风险}
风险:CROSS(80,RSI5),NODRAW;
DRAWTEXT(CROSS(80,RSI5),80,'风险');
庄家吸筹:组C_09,LINETHICK0,COLORYELLOW;
吸筹后:=IF(REF(庄家吸筹,1)>庄家吸筹,10,0);
STICKLINE(组C_09>-120,0,IF(组C_09*1.5>65,58,组C_09*1.5),1.7,0),COLOR338FDD;
{STICKLINE(组C_09>-120,0,IF(组C_09*1.5>65,58,组C_09*1.5),1.7,0),COLOR00AAFF;}
{STICKLINE(组C_09>-120,0,组C_09*1.5,2.3,0),COLOR00BBFF;
STICKLINE(组C_09>-120,0,组C_09*1.5,2,0),COLOR00CCFF;
STICKLINE(组C_09>-120,0,组C_09*1.5,1.8,0),COLOR00DDFF;
STICKLINE(组C_09>-120,0,组C_09*1.5,1.5,0),COLOR00EEFF;
STICKLINE(组C_09>-120,0,组C_09*1.5,1,0),COLOR00FFFF;}
组A_01:=EMA((CLOSE-LLV(LOW,25))/(HHV(HIGH,25)-LLV(LOW,25))*100,5);
组A_02:=(HHV(HIGH,25)-LLV(LOW,25))/EMA((CLOSE-LLV(LOW,25)),5);
组A_03:=CROSS(组A_02,组A_01);
组A_04:=REF(组A_02,2)<REF(组A_02,1) AND 组A_02<REF(组A_02,1);
组A_05:=COUNT(组A_03,7)>0 AND 组A_04;
组A_06:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);
组A_07:=SMA(ABS(LOW-组A_06),13,1)/SMA(MAX(LOW-组A_06,0),10,1);
组A_08:=EMA(组A_07,10);
组A_09:=EMA(C,5);
组A_10:=LLV(LOW,33);
组A_11:=EMA(IF(LOW<=组A_10,组A_09,0),3)*40;
组A_12:=IF(组A_11>100,组A_11*0.312,组A_11);
高度:=(100*组A_12/组A_12)-1;
组A关注点:IF(组A_05 AND COUNT(组A_05,5)=1,10,0),LINETHICK0;
STICKLINE(组A关注点,-高度/5,高度/2,2,0),COLORRED;{底部大红柱}
买A2:=IF(组A_02>3,组A_02*1.5,0),LINETHICK2,COLORWHITE;
IF(买A2>40,买A2,DRAWNULL),COLORRED,LINETHICK2;
{TYP1:= (HIGH + LOW + CLOSE)/3;
TYP2:(TYP1-MA(TYP1,N))/(0.015*AVEDEV(TYP1,N))/5,COLORWHITE;}
EMA13:=EMA(C,13),DRAWNULL;
EMA21:=EMA(C,21),DRAWNULL;
EMA34:=EMA(C,34),DRAWNULL;
EMA60:=MA(C,60),DRAWNULL;
VAR2G:=(2*CLOSE+HIGH+LOW)/4;
VAR3G:=IF(YEAR>=2099 AND MONTH>2,0,1);
VAR4G:=LLV(LOW,5);
VAR5G:=HHV(HIGH,4);
小股民:=EMA((VAR2G-VAR4G)/(VAR5G-VAR4G)*100,4)*VAR3G;
庄家:=EMA(0.667*REF(小股民,1)+0.333*小股民,2)*VAR3G;
VAR9G:=CLOSE-REF(CLOSE,5);
VARAG:=EMA(EMA(VAR9G,5),5)/EMA(EMA(ABS(VAR9G),5),5);
VARCG:=EMA(EMA(VAR9G,20),20)/EMA(EMA(ABS(VAR9G),20),20);
卖出:=IF(VARAG>0 AND CROSS(VARCG,VARAG),90,100);
DRAWICON(卖出<0,H+0.05,2);
买线:=EMA(CLOSE,2);
卖线:=EMA(SLOPE(CLOSE,21)*20+CLOSE,42);
B1:=IF(CROSS(买线,卖线),L-0.02,DRAWNULL);
S1:=IF(CROSS(80,RSI)*30,H+0.02,DRAWNULL);
VC:=((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100+(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100+(CLOSE-MA (CLOSE,32))/MA(CLOSE,32)*100)/3;
S2:=IF(VC>20 AND FILTER(VC< REF(VC,1),5),H+0.02,DRAWNULL);
A0:=(L+H+C*2)/4;
A1:=EMA(A0,14);
A2:=EMA(A0,25);
A1X:=(A1-REF(A1,1))/REF(A1,1)*100,NODRAW;
A2X:=(A2-REF(A2,1))/REF(A2,1)*100,NODRAW;
看多:=IF(A1X>=0 AND BARSLAST(CROSS(A1X,0))>0,REF((C+O)/2,BARSLAST(CROSS(A1X,0))),DRAWNULL);
逃顶:=IF(A1X<0 AND BARSLAST(CROSS(0,A1X))>0,REF((C+O)/2,BARSLAST(CROSS(0,A1X))),DRAWNULL);
买入持股:=IF(A1X>=0,A1,DRAWNULL);
卖出空仓:=IF(A1X<0 AND A2X<0,A1,DRAWNULL);
MAI1:=IF(CROSS(B1,0),5,0);
MAI2:=IF(CROSS(买入持股,0),10,0);
STICKLINE(MAI1,-1,-9,1,0),COLORWHITE;
STICKLINE(MAI2,-11,-19,1,0),COLORYELLOW;
{DRAWTEXT(CURRBARSCOUNT=12,90,'0线下黄白,关注介入,大涨'),COLORWHITE; }
获利盘%:WINNER(CLOSE)*100,NODRAW,COLORWHITE;
狂牛:VAR2A AND COUNT(VAR2A,30)=1,NODRAW;
DRAWTEXT(VAR27 AND COUNT(VAR27,30)=1,90,'▲持股待涨'),COLORFF00FF;
DRAWTEXT(VAR28 AND COUNT(VAR28,30)=1,10,'▲出局为佳'),COLOR00FF00;
DRAWTEXT(VAR29 AND COUNT(VAR29,30)=1,70,'▲上涨过急,需要调整'),COLORWHITE;
DRAWTEXT(VAR2A AND COUNT(VAR2A,30)=1,80,'▲拉升在即狂牛!'),COLORYELLOW;
DRAWTEXT(VAR2B AND COUNT(VAR2B,30)=1,20,'▲不必杀跌有反弹 '),COLORWHITE;
DRAWTEXT(VAR2C AND COUNT(VAR2C,30)=1,30,'▲角斗士,阶段底部 '),COLORYELLOW;
DRAWTEXT(VAR2D AND COUNT(VAR2D,30)=1,60,'▲资金进场'),COLOR0099FF;
DRAWTEXT(VAR2E AND COUNT(VAR2E,30)=1,40,'▲高点回落'),COLORFFCC66;
准入:IF(VAR3<REF(VAR4,1),10,0);
C1:=C;
JC1:=(REF(C,3)+REF(C,5)+REF(C,7)+REF(C,13)+REF(C,21))/5;
参考价1:=SMA(JC1,3,1),COLORBLUE;
上升趋势:IF(C>参考价1,108,100),COLORYELLOW;
买:IF( IF(OX<100 OR 预警<60 OR 上升趋势>105,10,0) AND 准入, 10,0),LINETHICK0;
STICKLINE(买,-5,-11,3,0),COLORYELLOW;
DRAWICON(CROSS(势能,104),100,11);
DRAWTEXT(CROSS(动能,势能),动能,'▲观察');
DRAWICON(预警>REF(预警,1) AND REF(预警,1)<60,预警,1);
DRAWICON(REF(OX,1)<108 AND OX=108,108,1);
M8:=EMA(CLOSE,8);
M13:=EMA(M8,13);
DRAWICON(REF(上升趋势,1)<108 AND 上升趋势=108,上升趋势,1);
IF(上升趋势=108 AND M13>REF(M13,1),上升趋势,DRAWNULL),COLORMAGENTA,LINETHICK2;
DRAWICON(上升趋势=108 AND M13>REF(M13,1) AND REF(M13,1)<REF(M13,2),上升趋势,40);
A1Y:=EMA(CLOSE,7)-EMA(CLOSE,21);
B1Y:=EMA((0.668*REF(A1Y,1)+0.333*A1Y),1);
做多:=IF(A1Y>=B1Y,A1Y,B1Y),LINETHICK1,COLORRED;
做空:=IF(B1Y-A1Y,B1Y,A1Y),LINETHICK1,COLORGREEN;
距离:=做多-做空,NODRAW;
{DRAWICON(CROSS(做多,REF(做多,1)) AND 距离>=0.01 AND 势能<REF(势能,1),势能,1);
{DRAWICON(距离=0 AND 做空>=REF(做空,1) AND 势能<REF(势能,1),势能*1.02,2);};


持股待涨副图源码 通达信 贴图


好股票软件下载网(www.goodgupiao.com)提醒您:股市有风险,投资需谨慎。
持股待涨副图源码 通达信 贴图下载地址
相关说明
  • 好股票软件下载网欢迎用户将网页内容和下载地址转发到博客、微博、论坛等。
  • 发布的公式指标绝大部分是来源于各大论坛,谢谢各位老师的原创指标。
  • 判断公式指标好坏,请用户参考用户评论或者软件好评度
  • alg格式股票公式,仅仅可以用飞狐交易师股票软件引入使用;
  • fnc格式股票公式,可以用大智慧新一代高速行情分析系统股票软件使用,少部分可以用分析家股票软件引入使用;
  • exp格式股票公式,仅可以用大智慧经典版股票软件引入使用;
  • tnctni格式股票公式,仅可以用通达信新引入使用,例如可以用通达信股票软件引入使用;
  • tne格式公式,仅可以用通达信公式编辑器5.0版导入,高版本兼容低版本;
  • hxf格式股票公式,仅可以用同花顺股票软件引入使用。
  • 如果引入公式的时候,发现公式名称栏空白,调整电脑时间到1997年,能出现公式名称并正常显示,可能是公式使用期限已过。
  • 如果您发现下载链接错误,请点击报告错误谢谢!