好股票网每日提供最新股票软件下载,如果您觉得不错,麻烦推荐给您的好友,谢谢!
您现在的位置:好股票网 >> 股票公式 >> 通达信公式

艾略特波浪划线主图源码 通达信 贴图

[下载地址]

好股票网经过测试可运行,该软件通过多款专业杀毒软件扫描

  • 360通过
  • 金山通过
  • 瑞星通过
  • 江民通过
  • 卡巴通过
  • 诺顿通过
  • 运行平台:Win7/Vista/WinXP/Win2003/
  • 公式语言:简体中文
  • 更新时间:2017-11-03 10:33:00
  • 公式评级:
  • 公式类型:通达信公式
  • 授权方式:共享版
  • 公式大小:2.00 KB
  • 解压密码:goodgupiao
  • 下载统计:
  • 相关Tags:
已有次下载
推 荐0
不推荐0

艾略特波浪划线主图源码 通达信 贴图介绍

好股票软件下载网(www.goodgupiao.com)提示:您正在下载的是:艾略特波浪划线主图源码 通达信 贴图

艾略特波浪划线主图:艾略特波浪理论的五浪划线,方便看盘和技术分析


X:=5;
D:=10;
M5:MA(C,X);
M10:MA(C,D);

T:=BARSLAST(CROSS(M5,M10));
ST:=BARSLAST(CROSS(M10,M5));
T1:=SUMBARS(T=0,2);
T2:=SUMBARS(T=0,3);
ST1:=SUMBARS(ST=0,2);
ST2:=SUMBARS(ST=0,3);

H1:=IF(CONST(M5)>CONST(M10),HHV(H,T+1),REF(HHV(H,T+1),ST));
L1:=IF(CONST(M5)<CONST(M10),LLV(L,ST+1),REF(LLV(L,ST+1),T));
H2:=IF(CONST(M5)>CONST(M10),REF(HHV(H,T+1),ST),REF(HHV(H,T+1),ST1-1));
L2:=IF(CONST(M5)<CONST(M10),REF(LLV(L,ST+1),T),REF(LLV(L,ST+1),T1-1));
H3:=IF(CONST(M5)>CONST(M10),REF(HHV(H,T+1),ST1-1),REF(HHV(H,T+1),ST2-1));
L3:=IF(CONST(M5)<CONST(M10),REF(LLV(L,ST+1),T1-1),REF(LLV(L,ST+1),T2-1));

TJ1:=CONST(M5)>CONST(M10) AND CURRBARSCOUNT>=CONST(T2) AND CURRBARSCOUNT<=CONST(ST2) AND L=CONST(L3);
TJ2:=CONST(M5)>CONST(M10) AND CURRBARSCOUNT>=CONST(ST1) AND CURRBARSCOUNT<=CONST(T2) AND H=CONST(H3);
TJ3:=CONST(M5)>CONST(M10) AND CURRBARSCOUNT>=CONST(T1) AND CURRBARSCOUNT<=CONST(ST1) AND L=CONST(L2);
TJ4:=CONST(M5)>CONST(M10) AND CURRBARSCOUNT>=CONST(ST) AND CURRBARSCOUNT<=CONST(T1) AND H=CONST(H2);
TJ5:=CONST(M5)>CONST(M10) AND CURRBARSCOUNT>=CONST(T)+1 AND CURRBARSCOUNT<=CONST(ST)+1 AND L=CONST(L1);
TJ6:=CONST(M5)>CONST(M10) AND H=CONST(H1) AND CURRBARSCOUNT<=CONST(ST2);
TJ7:=CONST(M5)<CONST(M10) AND CURRBARSCOUNT>=CONST(ST2) AND CURRBARSCOUNT<=CONST(T2) AND H=CONST(H3);
TJ8:=CONST(M5)<CONST(M10) AND CURRBARSCOUNT>=CONST(T1) AND CURRBARSCOUNT<=CONST(ST2) AND L=CONST(L3);
TJ9:=CONST(M5)<CONST(M10) AND CURRBARSCOUNT>=CONST(ST1) AND CURRBARSCOUNT<=CONST(T1) AND H=CONST(H2);
TJ10:=CONST(M5)<CONST(M10) AND CURRBARSCOUNT>=CONST(T) AND CURRBARSCOUNT<=CONST(ST1) AND L=CONST(L2);
TJ11:=CONST(M5)<CONST(M10) AND CURRBARSCOUNT>=CONST(ST)+1 AND CURRBARSCOUNT<=CONST(T)+1 AND H=CONST(H1);
TJ12:=CONST(M5)<CONST(M10) AND L=CONST(L1)AND CURRBARSCOUNT<=CONST(T2);

DRAWLINE(TJ1,L,TJ2,H,0),COLORMAGENTA;
DRAWLINE(TJ2,H,TJ3,L,0),COLORMAGENTA;
DRAWLINE(TJ3,L,TJ4,H,0),COLORMAGENTA;
DRAWLINE(TJ4,H,TJ5,L,0),COLORMAGENTA;
DRAWLINE(TJ5,L,TJ6,H,0),COLORMAGENTA;
DRAWLINE(TJ7,H,TJ8,L,0),COLORGREEN;
DRAWLINE(TJ8,L,TJ9,H,0),COLORGREEN;
DRAWLINE(TJ9,H,TJ10,L,0),COLORGREEN;
DRAWLINE(TJ10,L,TJ11,H,0),COLORGREEN;
DRAWLINE(TJ11,H,TJ12,L,0),COLORGREEN;

HH:=CONST(MAX(MAX(H1,H2),H3));
LL:=CONST(MIN(MIN(L1,L2),L3));
Z:=(HH-LL)/2+LL;
DRAWLINE(TJ7,Z,ISLASTBAR,Z,0),COLORGREEN,DOTLINE;
DRAWTEXT(TJ7,CONST(Z)*1.01,VARCAT(VARCAT('中区价位:',VAR2STR(CONST(Z),2)),'元')),COLORGREEN;
HH1:=CONST(MAX(H1,MAX(H2,H3)));
LL1:=CONST(MIN(MIN(L1,L2),L3));
Z1:=(HH1-LL1)/2+LL1;
DRAWLINE(TJ1,Z1,ISLASTBAR,Z1,0),COLORMAGENTA,DOTLINE;
DRAWTEXT(TJ1,CONST(Z)*1.01,VARCAT(VARCAT('中区价位:',VAR2STR(CONST(Z1),2)),'元')),COLORMAGENTA;

近高:H1,COLORMAGENTA,NODRAW;
近低:L1,COLORGREEN,NODRAW;
中高:H2,COLORMAGENTA,NODRAW;
中底:L2,COLORGREEN,NODRAW;
远高:H3,COLORMAGENTA,NODRAW;
远底:L3,COLORGREEN,NODRAW;



好股票软件下载网(www.goodgupiao.com)提醒您:股市有风险,投资需谨慎。
艾略特波浪划线主图源码 通达信 贴图下载地址
相关说明
  • 好股票软件下载网欢迎用户将网页内容和下载地址转发到博客、微博、论坛等。
  • 发布的公式指标绝大部分是来源于各大论坛,谢谢各位老师的原创指标。
  • 判断公式指标好坏,请用户参考用户评论或者软件好评度
  • alg格式股票公式,仅仅可以用飞狐交易师股票软件引入使用;
  • fnc格式股票公式,可以用大智慧新一代高速行情分析系统股票软件使用,少部分可以用分析家股票软件引入使用;
  • exp格式股票公式,仅可以用大智慧经典版股票软件引入使用;
  • tnctni格式股票公式,仅可以用通达信新引入使用,例如可以用通达信股票软件引入使用;
  • tne格式公式,仅可以用通达信公式编辑器5.0版导入,高版本兼容低版本;
  • hxf格式股票公式,仅可以用同花顺股票软件引入使用。
  • 如果引入公式的时候,发现公式名称栏空白,调整电脑时间到1997年,能出现公式名称并正常显示,可能是公式使用期限已过。
  • 如果您发现下载链接错误,请点击报告错误谢谢!