好股票网每日提供最新股票软件下载,如果您觉得不错,麻烦推荐给您的好友,谢谢!
您现在的位置:好股票网 >> 股票公式 >> 通达信公式

通达信自用缠论分型笔线段主图指标 贴图

[下载地址]

好股票网经过测试可运行,该软件通过多款专业杀毒软件扫描

  • 360通过
  • 金山通过
  • 瑞星通过
  • 江民通过
  • 卡巴通过
  • 诺顿通过
  • 运行平台:Win7/Vista/WinXP/Win2003/
  • 公式语言:简体中文
  • 更新时间:2017-09-24 20:28:00
  • 公式评级:
  • 公式类型:通达信公式
  • 授权方式:共享版
  • 公式大小:7.00 KB
  • 解压密码:goodgupiao
  • 下载统计:
  • 相关Tags:
已有次下载
推 荐0
不推荐0

通达信自用缠论分型笔线段主图指标 贴图介绍

好股票软件下载网(www.goodgupiao.com)提示:您正在下载的是:通达信自用缠论分型笔线段主图指标 贴图

很牛逼的缠中说禅的分型笔线段主图指标

谁用谁知道,加入了自己用的量能平台和均线。


{【天堂分笔】-接近完美的通达信分笔公式
2011-8-28 地藏
最终版
说明:
----------------------------
参数:老笔=1,使用老笔定义,默认为0,使用新笔定义
缺口:反向缺口不破前笔,只看成一根K线
包含:使用近似算法可处理80%的情况
运行环境:需要通达信内核为5.68以上
}
MA5:MA(CLOSE,5) COLORWHITE,LINETHICK2;
MA10:MA(CLOSE,10) COLORMAGENTA,LINETHICK1;
MA20:MA(CLOSE,20) COLORBLUE,LINETHICK1;
MA60:MA(CLOSE,60) COLORYELLOW,LINETHICK2;
MA250:MA(CLOSE,250) COLORRED, LINETHICK1;

老笔:=0;
G:=MA(C,5);D:=MA(C,10);
HH:=REF(H,5)=HHV(H,11);
LL:=REF(L,5)=LLV(L,11);
FG01:=BACKSET(HH,6)>BACKSET(HH,5) ;
FD01:=BACKSET(LL,6)>BACKSET(LL,5) ;
FG02:=IF(BARSLAST(FG01)=BARSLAST(FD01) AND G>D,FG01,
IF(BARSLAST(FD01)>BARSLAST(FG01),FG01,0));
FD02:=IF(BARSLAST(FG01)=BARSLAST(FD01) AND D>G,FD01,
IF(BARSLAST(FG01)>BARSLAST(FD01),FD01,0));
FG0:=FG02 AND H=HHV(H,BARSLAST(FD02));
FD0:=FD02 AND L=LLV(L,BARSLAST(FG02));
GP:IF(FG0,H,DRAWNULL),CIRCLEDOT,COLORCYAN;
DP:IF(FD0,L,DRAWNULL),CIRCLEDOT,COLORCYAN;
GQ:=L>REF(H,1) AND DAY!=REF(DAY,1);
DQ:=H<REF(L,1) AND DAY!=REF(DAY,1);
GQL:=REF(L,BARSLAST(GQ));
DQH:=REF(H,BARSLAST(DQ));
FGH:=REF(H,BARSLAST(FG0));
FGL:=REF(L,BARSLAST(FG0));
FGH1:=REF(H,BARSLAST(FG0)+1);
FGL1:=REF(L,BARSLAST(FG0)+1);
FGH2:=REF(H,BARSLAST(FG0)+2);
FGL2:=REF(L,BARSLAST(FG0)+2);
FDH:=REF(H,BARSLAST(FD0));
FDL:=REF(L,BARSLAST(FD0));
FDH1:=REF(H,BARSLAST(FD0)+1);
FDL1:=REF(L,BARSLAST(FD0)+1);
FDH2:=REF(H,BARSLAST(FD0)+2);
FDL2:=REF(L,BARSLAST(FD0)+2);
FGZH:=IF(FGL<=FGL1,FGH2,FGH1);
FGZL:=IF(FGH1<FGL,FGL,IF(FGL<=FGL1,FGL2,FGL1));
FDZH:=IF(FDL1>FDH,FDH,IF(FDH>=FDH1,FDH2,FDH1));
FDZL:=IF(FDH>=FDH1,FDL2,FDL1);
FG1:=FGH>FDZH AND FG0;
FD1:=FDL<FGZL AND FD0;
FG:=FG1 AND FGH>FDH AND FGL>FDL AND FGL1>FDL;
FD:=FD1 AND FDL<FGL AND FDH<FGH AND FDH1<FGH;
BH0:=(H<=REF(H,1) AND L>=REF(L,1)) OR (H>=REF(H,1) AND L<=REF(L,1));
BHG:=COUNT(BH0,BARSLAST(FD0));
BHD:=COUNT(BH0,BARSLAST(FG0));
BGQ:=COUNT(GQ,BARSLAST(FD0));
BDQ:=COUNT(DQ,BARSLAST(FG0));
BK0:=IF(BHG>0,BHG+2+老笔,IF(BHD,BHD+2+老笔,3));
BK:=IF(BGQ,BK0-BGQ,IF(BDQ,BK0-BDQ,BK0));
G1X:=(FG AND BARSLAST(FD)>BK);
D1X:=(FD AND BARSLAST(FG)>BK);
G1:=(FG0 AND REF(H,BARSLAST(FG0))>=REF(H,BARSLAST(G1X)) AND BARSLAST(D1X)>BARSLAST(G1X))
OR (FG1 AND COUNT(GQ,BARSLAST(FD1))>0 AND REF(H,BARSLAST(FG1))>REF(H,BARSLAST(G1X)));{好股票网 http://www.goodgupiao.com 整理}
D1:=(FD0 AND REF(L,BARSLAST(FD0))<=REF(L,BARSLAST(D1X)) AND BARSLAST(G1X)>BARSLAST(D1X))
OR (FD1 AND COUNT(DQ,BARSLAST(FG1))>0 AND REF(L,BARSLAST(FD1))<REF(H,BARSLAST(D1X)));
G1H:=IF(BARSLAST(D1)>BARSLAST(G1),REF(H,BARSLAST(G1)),REF(H,BARSLAST(D1))),;
D1L:=IF(BARSLAST(G1)>BARSLAST(D1),REF(L,BARSLAST(D1)),REF(L,BARSLAST(G1)));
G2:=G1 AND H=HHV(G1H,BARSLAST(D1)+1) AND H>REF(H,1) AND BARSLAST(D1)>BARSLAST(G1);
D2:=D1 AND L=LLV(D1L,BARSLAST(G1)+1) AND L<REF(L,1) AND BARSLAST(G1)>BARSLAST(D1);
G3:=G2 OR (FG0 AND REF(H,BARSLAST(FG0))>REF(H,BARSLAST(G2)) AND BARSLAST(D2)>BARSLAST(G2));
D3:=D2 OR (FD0 AND REF(L,BARSLAST(FD0))<REF(L,BARSLAST(D2)) AND BARSLAST(G2)>BARSLAST(D2));
GPB:IF(G1X,H,DRAWNULL),CIRCLEDOT,COLORYELLOW;
DPB:IF(D1X,L,DRAWNULL),CIRCLEDOT,COLORYELLOW;

DRAWICON(CROSS(MA20,MA60),MA60*0.98,9);
DIF:=MA(CLOSE,5)-MA(CLOSE,89);
DIFMA:=MA(DIF,36);
XG:=CROSS(DIF,DIFMA) AND DIF<3;
DRAWICON(XG,H*1.03,23);

{画线}
NN:=G3;UU:=D3;
L1:DRAWLINE(UU,L,NN, H,0),COLORLIGREEN;L2:DRAWLINE(NN,H,UU, L,0),COLORLIGREEN;
{标示端点数值}
DRAWNUMBER(L1 AND L2 AND NN ,H,H),COLORLIRED;DRAWNUMBER(L1 AND L2 AND UU ,L,L),COLORLIMAGENTA;

{折扣价}
DRAWICON(CURRBARSCOUNT=6,LOW*0.98,24);
DRAWNUMBER(CURRBARSCOUNT=6,LOW*0.96,C);

DRAWICON(CURRBARSCOUNT=11,LOW*0.98,25);
DRAWNUMBER(CURRBARSCOUNT=11,LOW*0.96,C);

DRAWICON(CURRBARSCOUNT=21,LOW*0.98,26);
DRAWNUMBER(CURRBARSCOUNT=21,LOW*0.96,C);

DRAWICON(CURRBARSCOUNT=61,LOW*0.98,27);
DRAWNUMBER(CURRBARSCOUNT=61,LOW*0.96,C);

DRAWICON(CURRBARSCOUNT=121,LOW*0.98,18);
DRAWNUMBER(CURRBARSCOUNT=121,LOW*0.96,C);


{量能平台}
N250:=250;
PT250:=CONST(HHVBARS(V,N250));
T250:IF(CURRBARSCOUNT<=N250,CONST(IF(PT250=0,C,REF(C,PT250))),DRAWNULL),COLOR990000;
IF(CURRBARSCOUNT=PT250+1,T250,DRAWNULL),CIRCLEDOT,COLORFF0000,LINETHICK2;
DRAWTEXT(CURRBARSCOUNT=N250,T250,'250'),COLOR990000;
N120:=120;
PT120:=CONST(HHVBARS(V,N120));
T120:IF(CURRBARSCOUNT<=N120,CONST(IF(PT120=0,C,REF(C,PT120))),DRAWNULL),COLORAAAA00;
IF(CURRBARSCOUNT=PT120+1,T120,DRAWNULL),CIRCLEDOT,COLORFFFF00,LINETHICK2;
DRAWTEXT(CURRBARSCOUNT=N120,T120,'120'),COLORAAAA00;
N60:=60;
PT60:=CONST(HHVBARS(V,N60));
T60:IF(CURRBARSCOUNT<=N60,CONST(IF(PT60=0,C,REF(C,PT60))),DRAWNULL),COLOR00BB00;
IF(CURRBARSCOUNT=PT60+1,T60,DRAWNULL),CIRCLEDOT,COLOR00FF00,LINETHICK2;
DRAWTEXT(CURRBARSCOUNT=N60,T60,'60'),COLOR00BB00;
N30:=30;
PT30:=CONST(HHVBARS(V,N30));
T30:IF(CURRBARSCOUNT<=N30,CONST(IF(PT30=0,C,REF(C,PT30))),DRAWNULL),COLOR0000CC;
IF(CURRBARSCOUNT=PT30+1,T30,DRAWNULL),CIRCLEDOT,COLOR0000FF,LINETHICK2;
DRAWTEXT(CURRBARSCOUNT=N30,T30,'30'),COLOR0000CC;
N20:=20;
PT20:=CONST(HHVBARS(V,N20));
T20:IF(CURRBARSCOUNT<=N20,CONST(IF(PT20=0,C,REF(C,PT20))),DRAWNULL),COLORDD00DD;
IF(CURRBARSCOUNT=PT20+1,T20,DRAWNULL),CIRCLEDOT,COLORFF00FF,LINETHICK2;
DRAWTEXT(CURRBARSCOUNT=N20,T20,'20'),COLORDD00DD;
N10:=10;
PT10:=CONST(HHVBARS(V,N10));
T10:IF(CURRBARSCOUNT<=N10,CONST(IF(PT10=0,C,REF(C,PT10))),DRAWNULL),COLOR00EEEE;
IF(CURRBARSCOUNT=PT10+1,T10,DRAWNULL),CIRCLEDOT,COLOR00FFFF,LINETHICK2;
DRAWTEXT(CURRBARSCOUNT=N10,T10,'10'),COLOR00EEEE;
N5:=5;
PT5:=CONST(HHVBARS(V,N5));
T5:IF(CURRBARSCOUNT<=N5,CONST(IF(PT5=0,C,REF(C,PT5))),DRAWNULL),COLORFFFFFF;
IF(CURRBARSCOUNT=PT5+1,T5,DRAWNULL),CIRCLEDOT,COLORFFFFFF,LINETHICK2;
DRAWTEXT(CURRBARSCOUNT=N5,T5,'5'),COLORFFFFFF;
ND:=10;
PTD:=CONST(LLVBARS(V,ND));
TDPX:IF(CURRBARSCOUNT<=ND,CONST(IF(PTD=0,O,REF(O,PTD))),DRAWNULL), COLOR9370DB;
IF(CURRBARSCOUNT=PTD+1,TDPX,DRAWNULL),CIRCLEDOT, COLOR9370DB,LINETHICK2;
DRAWTEXT(ISLASTBAR,TDPX,' 地平线10'), COLOR9370DB;

 



好股票软件下载网(www.goodgupiao.com)提醒您:股市有风险,投资需谨慎。
通达信自用缠论分型笔线段主图指标 贴图下载地址
相关说明
  • 好股票软件下载网欢迎用户将网页内容和下载地址转发到博客、微博、论坛等。
  • 发布的公式指标绝大部分是来源于各大论坛,谢谢各位老师的原创指标。
  • 判断公式指标好坏,请用户参考用户评论或者软件好评度
  • alg格式股票公式,仅仅可以用飞狐交易师股票软件引入使用;
  • fnc格式股票公式,可以用大智慧新一代高速行情分析系统股票软件使用,少部分可以用分析家股票软件引入使用;
  • exp格式股票公式,仅可以用大智慧经典版股票软件引入使用;
  • tnctni格式股票公式,仅可以用通达信新引入使用,例如可以用通达信股票软件引入使用;
  • tne格式公式,仅可以用通达信公式编辑器5.0版导入,高版本兼容低版本;
  • hxf格式股票公式,仅可以用同花顺股票软件引入使用。
  • 如果引入公式的时候,发现公式名称栏空白,调整电脑时间到1997年,能出现公式名称并正常显示,可能是公式使用期限已过。
  • 如果您发现下载链接错误,请点击报告错误谢谢!