好股票网每日提供最新股票软件下载,如果您觉得不错,麻烦推荐给您的好友,谢谢!
您现在的位置:好股票网 >> 股票公式 >> 通达信公式

最简单的BS操盘线(均线参数分别为5.13.20.34)

[下载地址]

好股票网经过测试可运行,该软件通过多款专业杀毒软件扫描

  • 360通过
  • 金山通过
  • 瑞星通过
  • 江民通过
  • 卡巴通过
  • 诺顿通过
  • 运行平台:Win7/Vista/WinXP/Win2003/
  • 公式语言:简体中文
  • 更新时间:2017-09-16 15:13:00
  • 公式评级:
  • 公式类型:通达信公式
  • 授权方式:共享版
  • 公式大小:10.0 KB
  • 解压密码:goodgupiao
  • 下载统计:
  • 相关Tags:
已有次下载
推 荐0
不推荐0

最简单的BS操盘线(均线参数分别为5.13.20.34)介绍

好股票软件下载网(www.goodgupiao.com)提示:您正在下载的是:最简单的BS操盘线(均线参数分别为5.13.20.34)

最简单的BS操盘线(均线参数分别为5.13.20.34)

M5:MA(CLOSE,5),COLORWHITE;
M13:MA(CLOSE,13),COLORYELLOW;
M20:MA(CLOSE,20),COLORRED;
M34:MA(CLOSE,34)COLORLIMAGENTA;
M55:MA(CLOSE,55),COLORGREEN;
M144:MA(CLOSE,144),COLORFF7F00;
MA250:MA(CLOSE,250),COLORFF00FF,LINETHICK1;

VAR3:=LLV(HIGH,240);
VAR4:=100*(CLOSE-VAR3)/VAR3;
VAR5:=(CLOSE-LLV(LOW,528))/(HHV(HIGH,528)-LLV(LOW,528))*100;
VAR6:=(CLOSE-LLV(CLOSE,530))/(HHV(CLOSE,530)-LLV(CLOSE,530))*100;
VAR7:=0;
VAR8:=SMA(MAX(CLOSE-REF(CLOSE,1),0),34,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),7,1)*100;
VAR9:=SMA(MAX(CLOSE-REF(CLOSE,1),0),13,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),13,1)*100;
VARA:=BARSCOUNT(CLOSE);
VARB:=VAR8<20 AND VAR9<23 AND VARA>35;
VARC:=VARB AND COUNT(VARB,1)=1;
VARD:=EMA(CLOSE,21)-EMA(CLOSE,8);
VARE:=EMA(VARD,5);
VARF:=TROUGHBARS(3,6,1)<4 AND CROSS(VARD,VARE);
VAR10:=IF(TROUGHBARS(3,16,1)=0 AND HIGH>LOW+0.04,4,0);
VAR11:=ZIG(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3);
VAR12:=ZIG(3,6)<REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)>=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)>=REF(ZIG(3,6),3);
VAR13:=ZIG(3,22)>REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3);
VAR14:=ZIG(3,22)<REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)>=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)>=REF(ZIG(3,22),3);
VAR15:=ZIG(3,51)>REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3);
VAR16:=ZIG(3,51)<REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)>=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)>=REF(ZIG(3,51),3);
VAR17:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3);
VAR18:=ZIG(3,72)<REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)>=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)>=REF(ZIG(3,72),3);
VAR19:=EMA(CLOSE,2)-EMA(CLOSE,150);
VAR1A:=EMA(VAR19,100);
VAR1B:=2*(VAR19-VAR1A);
VAR1C:=POW(VAR1B,3)*0.1+POW(VAR1B,1);
VAR1D:=SQRT(SQRT(LOW*HIGH*OPEN*CLOSE));
VAR1E:=EMA(VAR1D*0.97,3);
VAR1F:=(HIGH+LOW+CLOSE)/3;
VAR20:=(VAR1F-MA(VAR1F,14))/(0.015*AVEDEV(VAR1F,14));
VAR21:=CROSS(VAR1E,LOW);
买1:=VAR10;
买2:=(VAR11+VAR13+VAR15+VAR17);
卖1:=(VAR12+VAR14+VAR16+VAR18);
VAR22:=买1 AND VARF AND VARC AND VAR21 AND VAR4<0 AND VAR5=0 AND VAR6=0 AND VAR20<(-110);
VAR1:=MA(CLOSE,5);
VAR2:=MA(CLOSE,10);
VAR3A:=MA(CLOSE,30);
VAR4A:=MA(CLOSE,55);
VAR5A:=EMA(COST(85),7);
VAR6A:=EMA(COST(15),7);
VAR7A:=SUM(CLOSE*VOL*100,4)/SUM(VOL*100,4);
VAR8A:=INTPART(VAR7*100)/100;
VAR9A:=SUM(CLOSE*VOL*100,7)/SUM(VOL*100,7);
VARA1:=INTPART(VAR9*100)/100;
VARB1:=SUM(CLOSE*VOL*100,28)/SUM(VOL*100,28);
VARC1:=INTPART(VARB*100)/100;
VARD1:=EMA(CLOSE,5)-EMA(CLOSE,10);
VARE1:=EMA(VARD,9);
VARF1:=(-100)*(HHV(CLOSE,5)-CLOSE)/(HHV(CLOSE,5)-LLV(LOW,5))+100;
VAR10A:=(-100)*(HHV(CLOSE,10)-CLOSE)/(HHV(CLOSE,10)-LLV(LOW,10))+100;
VAR11A:=(-100)*(HHV(CLOSE,20)-CLOSE)/(HHV(CLOSE,20)-LLV(LOW,20))+100;
VAR12A:=(-100)*(HHV(CLOSE,30)-CLOSE)/(HHV(CLOSE,30)-LLV(LOW,30))+100;
VAR13A:=REF(VARE,1);
VAR14A:=VARE;
VAR15A:=VAR14-VAR13;
VAR16A:=REF(VARD,1);
VAR17A:=VARD;
VAR18A:=VAR17-VAR16;
VAR19A:=OPEN;
VAR1AA:=CLOSE;
买3:=IF(VAR19<=VAR1 AND VAR19<=VAR2 AND VAR19<=VAR3 AND VAR1A>=VAR1 AND VAR1A>=VARC AND VAR15>0 AND VAR18>0,0.5,0);
DRAWICON(买3>0,LOW-0.01,4);
买线:=EMA(CLOSE,2);
卖线:=EMA(SLOPE(CLOSE,21)*20+CLOSE,42);
B1买:IF(买1>0 OR 买2>0,LOW-0.02,DRAWNULL),CROSSDOT,LINETHICK3,COLORRED;
B2买:IF(CROSS(买线,卖线),L-0.02,DRAWNULL),CROSSDOT,LINETHICK3,COLORMAGENTA;
S1卖:IF(卖1>0,HIGH+0.02,DRAWNULL),CROSSDOT,LINETHICK3,COLORYELLOW;
S2卖:IF(CROSS(卖线,买线),H+0.02,DRAWNULL),CROSSDOT,LINETHICK3,COLORLIGRAY;
BU:=CROSS(HIGH,SAR(3,1,20));
SEL:=CROSS(SAR(3,1,20),LOW);
DRAWTEXT(BU,LOW,'B'),COLORYELLOW,LINETHICK2;
DRAWTEXT(SEL,1.01*HIGH,'S'),COLORGREEN,LINETHICK2;

获利盘:=WINNER(C)*100;
近邻筹码:=(WINNER(C*1.07)-WINNER(C*0.93))*85;
换手率:=V/CAPITAL*100;
锁仓:=获利盘>=85 AND 近邻筹码<30 AND 换手率<5 STICK;
DRAWTEXT(锁仓,(L*0.99),'锁'),COLORWHITE;


DRAWTEXT_FIX(1,0.20,0.88,0,HYBLOCK);
DRAWTEXT_FIX(1,0.20,0.91,0,EXTERNSTR(0,1))COLOR00FF00;
DRAWTEXT_FIX(1,0.20,0.94,0,EXTERNSTR(0,3))COLORFF88FF;
DRAWTEXT_FIX(1,0.12,0.97,0,EXTERNSTR(0,2))COLORFFFFFF;
{高低点定位}
G0:=(XMA(XMA(H,30),30)-XMA(XMA(L,30),30))+XMA(XMA(H,30),30);
D0:=XMA(XMA(L,30),30)-(XMA(XMA(H,30),30)-XMA(XMA(L,30),30));
G01:=(XMA(XMA(H,30),30)-XMA(XMA(L,30),30))*0.5+XMA(XMA(H,30),30);
D01:=XMA(XMA(L,30),30)-(XMA(XMA(H,30),30)-XMA(XMA(L,30),30))*0.5;
GO0:=(XMA(XMA(H,60),60)-XMA(XMA(L,60),60))*3+XMA(XMA(H,60),60);
DO0:=XMA(XMA(L,60),60)-(XMA(XMA(H,60),60)-XMA(XMA(L,60),60))*3;

STICKLINE(CURRBARSCOUNT=1,G0,G0,100,5),COLORGREEN;
STICKLINE(CURRBARSCOUNT=1,D0,D0,100,5),COLORMAGENTA;
STICKLINE(CURRBARSCOUNT=1,GO0,GO0,100,5),COLORLIBLUE;
STICKLINE(CURRBARSCOUNT=1,DO0,DO0,100,5),COLORRED;
DRAWTEXT(ISLASTBAR,G0,'卖'),COLORGREEN;
DRAWTEXT(ISLASTBAR,D0,'买'),COLORMAGENTA;
DRAWTEXT(ISLASTBAR,GO0,'顶'),COLORLIBLUE;
DRAWTEXT(ISLASTBAR,DO0,'底'),COLORRED;
{红底绿顶}
低:=REF(LLV(L,150),3);
近期底:=REFDATE(低,DATE);
最底:=REFDATE(近期底,DATE);
入:=最底=L AND ((C+L)<(O+C) OR (O+L)<(C+O));
STICKLINE(入,O,(C+O)/2,3,0),COLORRED;
STICKLINE(入,H,L,0.2,0),COLORRED;
DRAWTEXT(入,L*1.0021,'-红底'),COLORLIMAGENTA;
高:=REF(HHV(H,150),3);
近期顶:=REFDATE(高,DATE);
最顶:=REFDATE(近期顶,DATE),NODRAW;
出:=最顶=H AND ((C-L)<(O-C) OR (O-L)<(C-O)),NODRAW;
STICKLINE(出,O,(C+O)/2,3,0),COLORBLUE;
STICKLINE(出,H,L,0.2,0),COLORBLUE;
DRAWTEXT(出,H*0.998,'--蓝顶'),COLORGREEN;
A2:=REF(MA(C,20),1);J1:=(MA(C,20)-A2)/A2*100;MJ1:=MA(J1,3);
乖离2:=(MA(C,20)-MA(C,30))/MA(C,30)*100;
VAC1:=IF(BETWEEN(乖离2,-2,5),2,0);

XL1:=((LLV(LOW,3) = LLV(LOW,60)) AND ((CLOSE / REF(CLOSE,1)) >= 1.04));
XL2:=(((CLOSE - EMA(CLOSE,21)) / EMA(CLOSE,21)) * 100);
XL3:=CROSS(XL2,(0 - 20));
DRAWTEXT(FILTER(((XL1 > 0) AND LOW),5),(LOW - 0.0014),'●买点');
DRAWTEXT((XL3 > 0),(LOW - 0.0011),'●绝对底部')COLORYELLOW;
X6:=REF(CLOSE,1);
X7:=((SMA(MAX((CLOSE - X6),0),7,1) / SMA(ABS((CLOSE - X6)),7,1)) * 100);
X8:=CROSS(79,X7);
X9:=FILTER(X8,4);
DRAWTEXT(X9,(HIGH * 0.9989),'-●出货'),COLORGREEN;

{有庄控盘}
VAW1:=EMA(EMA(CLOSE,13),13);
控盘:=(VAW1-REF(VAW1,1))/REF(VAW1,1)*1000;
无庄控盘:=控盘<0;
有庄控盘:=控盘>REF(控盘,1) AND 控盘>0;

{分时价格原码}
JJ:=DYNAINFO(11);
{波段买卖原码}
P:=21;S:=8;M1:=3;
财:=(EMA(CLOSE,S)-EMA(CLOSE,P))*50;
神:=EMA(财,M1);

{股价与均线偏离买卖条件}
BTJ1:=(C-JJ)/JJ<-0.03;
BTJ11:=(C-JJ)/JJ<-0.03;
BTJ12:=LAST(JJ>=REF(JJ,1),5,1) AND (C-JJ)/JJ<0.005;
STJ1:=(C-JJ)/JJ>0.005;
{控盘买卖条件}
STJ01:=控盘<REF(控盘,1) AND 控盘>0.5;
STJ02:=控盘>0;
BTJ2:=控盘>REF(控盘,1) AND 控盘<-0.2;
BTJ22:=控盘>REF(控盘,1) AND 控盘<0 ;
{波段买卖条件}
BTJ3:=CROSS(财,神) AND 财<-0.3;
BTJ32:=CROSS(财,神) AND 财<-0.1;
STJ31:=CROSS(神,财);
STJ32:=CROSS(神,财) AND 财>1.618;
{以下为信号};
BTJ81:=FILTER(BTJ1 AND BTJ2 AND BTJ3,13);
BTJ811:=FILTER(BTJ11 AND BTJ2 AND BTJ3,13);
BTJ82:=FILTER(BTJ12 AND BTJ22 AND BTJ32,13);

STJ81:=FILTER(STJ1 AND STJ01 AND STJ31,13);
STJ82:=FILTER(STJ02 AND STJ32 ,13);
STJ83:=STJ81 AND STJ82;


DRAWTEXT(STJ83,H*1.002,'↓庄出'),COLORGREEN;
DRAWICON(STJ83,H+0.003,24);

庄:= BTJ11 AND BTJ2 AND BTJ3;
有庄:=FILTER(庄,30);
DRAWTEXT(有庄,L-0.0011,'↖庄进'),COLORYELLOW;
DRAWICON(有庄,L*0.999,23);

{洗盘杀入线源码:}
T11:=CONST(LLVBARS(LOW,10));
T11HIGH:=CONST(REF(HIGH,T11));
CC1:=CONST(CURRBARSCOUNT);
T22:=CONST(BARSLAST(CURRBARSCOUNT>CC1+T11 AND H>T11HIGH));
T22HIGH:=CONST(REF(HIGH,T22));
T33:=CONST(BARSLAST(CURRBARSCOUNT>CC1+T22 AND HIGH>T22HIGH));
T33HIGH:=CONST(REF(HIGH,T33));
{C>=T33HIGH AND REF(C,1)<T33HIGH AND DYNAINFO(17)>2;}
N:=10;
T1K:=CONST(LLVBARS(LOW,N));
T1HIGH:=CONST(REF(HIGH,T1K));
CC:=CONST(CURRBARSCOUNT);
T2K:=CONST(BARSLAST((CURRBARSCOUNT >(CC+T1K)) AND (HIGH>T1HIGH)));
T2HIGH:=CONST(REF(HIGH,T2K));
T3K:=CONST(BARSLAST((CURRBARSCOUNT >(CC+T2K)) AND (HIGH>T2HIGH)));
T3HIGH:=CONST(REF(HIGH,T3K));
洗盘杀入线:DRAWLINE(CURRBARSCOUNT=10+1,T3HIGH,ISLASTBAR, T3HIGH,1),LINETHICK1,COLORLIRED;
DRAWTEXT(ISLASTBAR, T3HIGH,'杀入线')LINETHICK1,COLORLIRED;

AQ1:=REF(V,1);AQ2:=DVOL;AQ3:=AQ2/AQ1;
LNX:=AQ3-REF(AQ3,1);
E1:=REF(C,1);E2:=DCLOSE;E3:=(E2-E1)/E1*100;
QMX:=E3-REF(E3,1);
XG:=CROSS(LNX,500) AND CROSS(QMX,10);
DRAWTEXT(XG=1,L*0.995,'--钻石'),COLORFFCC88;
DRAWICON(XG=1,L*0.993,25);

{牛熊轨道上抓启爆点 适合抓爆涨股}
AHC1:=CLOSE*VOL;
AHC22:=EMA((EXPMA(AHC1,27)/EXPMA(VOL,27)+EXPMA(AHC1,54)/EXPMA(VOL,54)+EXPMA(AHC1,108)/EXPMA(VOL,108)+EXPMA(AHC1,316)/EXPMA(VOL,316))/4,34);
上轨:=1.06*AHC22;
下轨:=AHC22*0.94;
ZT:=REF(C,1)*1.1-C<0.01 AND H=C;
启爆:=CROSS(C,上轨) OR CROSS(C,下轨) AND ZT;
DRAWTEXT(启爆,L,'↖启爆'),COLORCYAN;
{STYLE:抄底钻石王--可以用于选股预警,也可以放到附图}
YY:=(REF(H,4)-REF(L,1))/C*100>10;{4天前的最高到昨天最低跌幅为10个点}
YY1:=(REF(L,1)-L)/C*100>=0;{昨天的最低价跟今天最低价相平或收下影线}
YY2:=REF(C<O,1) AND C>O;{昨天收阴,今天收阳线}
YY3:= CLOSE>REF(CLOSE,1)*1.03 ;{股价3个点预警}
YY4:=(H-C)/C*100<1.5;{上影线少于1.5个点}
YY5:=V<=LLV(V,5) OR V>=HHV(V,5);{成交量是五天最低或五天最高}
DRAWICON(YY AND YY1 AND YY2 AND YY3 AND YY4 AND YY5,L*0.988,26);{满足所有条件};
DRAWTEXT(YY AND YY1 AND YY2 AND YY3 AND YY4 AND YY5,L*0.988,'--钻石王'),COLORRED;
{伏击涨停}
T1:=MA(C,21)>REF(MA(C,21),1);
T2:=EXIST(C>REF(C,1)*1.093,21);
T3:=C<O AND C<REF(C,1) AND EVERY(MA(C,5)<REF(MA(C,5),1),3);
T5:=EVERY(V<REF(V,1),2) AND EVERY(V<MA(V,5),2);
T6:=MA(C,5)>MA(C,21);
DRAWTEXT(T1 AND T2 AND T3 AND T5 AND T6,L,'--伏击涨停');



最简单的BS操盘线(均线参数分别为5.13.20.34)

最简单的BS操盘线(均线参数分别为5.13.20.34)


好股票软件下载网(www.goodgupiao.com)提醒您:股市有风险,投资需谨慎。
最简单的BS操盘线(均线参数分别为5.13.20.34)下载地址
相关说明
  • 好股票软件下载网欢迎用户将网页内容和下载地址转发到博客、微博、论坛等。
  • 发布的公式指标绝大部分是来源于各大论坛,谢谢各位老师的原创指标。
  • 判断公式指标好坏,请用户参考用户评论或者软件好评度
  • alg格式股票公式,仅仅可以用飞狐交易师股票软件引入使用;
  • fnc格式股票公式,可以用大智慧新一代高速行情分析系统股票软件使用,少部分可以用分析家股票软件引入使用;
  • exp格式股票公式,仅可以用大智慧经典版股票软件引入使用;
  • tnctni格式股票公式,仅可以用通达信新引入使用,例如可以用通达信股票软件引入使用;
  • tne格式公式,仅可以用通达信公式编辑器5.0版导入,高版本兼容低版本;
  • hxf格式股票公式,仅可以用同花顺股票软件引入使用。
  • 如果引入公式的时候,发现公式名称栏空白,调整电脑时间到1997年,能出现公式名称并正常显示,可能是公式使用期限已过。
  • 如果您发现下载链接错误,请点击报告错误谢谢!