好股票网每日提供最新股票软件下载,如果您觉得不错,麻烦推荐给您的好友,谢谢!
您现在的位置:好股票网 >> 股票公式 >> 通达信公式

通达信【画蛇添足】主图源码 附图

[下载地址]

好股票网经过测试可运行,该软件通过多款专业杀毒软件扫描

  • 360通过
  • 金山通过
  • 瑞星通过
  • 江民通过
  • 卡巴通过
  • 诺顿通过
  • 运行平台:Win7/Vista/WinXP/Win2003/
  • 公式语言:简体中文
  • 更新时间:2017-08-20 23:09:00
  • 公式评级:
  • 公式类型:通达信公式
  • 授权方式:共享版
  • 公式大小:2.00 KB
  • 解压密码:goodgupiao
  • 下载统计:
  • 相关Tags:
已有次下载
推 荐0
不推荐0

通达信【画蛇添足】主图源码 附图介绍

好股票软件下载网(www.goodgupiao.com)提示:您正在下载的是:通达信【画蛇添足】主图源码 附图

昌九哥哥的原话
还有这个是我【画蛇添足】的产物 虽然可以用.但是不具备【三角洲 DELTA理论 预测】的功能. 我到认为这个楼主可以直接转换到通达信软件.但是我是不行.因为【LAYER0;】函数在大智慧里就很麻烦了 而通达信又没有这个函数. 那就看楼主的技巧了. 这才是二次握手的真实目的吧
{DELTA周线}
DRAWGBKlast(c>0,strip(RGB(0,50,0),RGB(0,0,80),0)),LAYER7;
{【必备】---K线【C AND REF(C,1).】----}
{----CLOSE AND OPEN----}
STICKLINE(CLOSE>=OPEN,OPEN,LOW,0.5,0 ),COLOR0000ff,LAYER0;
STICKLINE(CLOSE>=OPEN,CLOSE,HIGH,0.5,0 ),COLOR0000ff,LAYER0;
STICKLINE(CLOSE<OPEN,OPEN,LOW,0.8,0 ),COLOR00ff00,LAYER5;
STICKLINE(CLOSE<OPEN,CLOSE,HIGH,0.8,0 ),COLOR00ff00,LAYER5;
{----C>REF(C,1)----}
stickline(C>REF(C,1),C,O,8,0),Color000033,LAYER4;
stickline(C>REF(C,1),C,O,7,0),Color000055,LAYER4;
stickline(C>REF(C,1),C,O,6,0),Color000077,LAYER4;
stickline(C>REF(C,1),C,O,5,0),Color000099,LAYER4;
stickline(C>REF(C,1),C,O,4,0),Color0000bb,LAYER4;
stickline(C>REF(C,1),C,O,2,0),Color6500dd,LAYER4;
stickline(C>REF(C,1),C,O,1,0),Color9C00ff,LAYER4;
{----C<REF(C,1)----}
stickline(C<REF(C,1),C,O,8,0),Color003300,LAYER4;
stickline(C<REF(C,1),C,O,7,0),Color005500,LAYER4;
stickline(C<REF(C,1),C,O,6,0),Color007700,LAYER4;
stickline(C<REF(C,1),C,O,5,0),Color009900,LAYER4;
stickline(C<REF(C,1),C,O,4,0),Color00bb00,LAYER4;
stickline(C<REF(C,1),C,O,2,0),Color65dd00,LAYER4;
stickline(C<REF(C,1),C,O,1,0),Color9Cff00,LAYER4;
{----C=REF(C,1)----}
stickline(C=REF(C,1),C,O,8,0),Color008888,LAYER4;
stickline(C=REF(C,1),C,O,6,0),Color00AAAA,LAYER4;
stickline(C=REF(C,1),C,O,3,0),Color00DDDD,LAYER4;
stickline(C=REF(C,1),C,O,1,0),Color00ffFF,LAYER4;
现价: if (DYNAINFO(4)=0,C,DYNAINFO(7)),colorFF00FF,POINTDOT,LINETHICK2;
MID : MA(CLOSE,26),COLOR00ffFF,DOTLINE,LAYER0;;;
UPPER: MID + 2*STD(CLOSE,26),COLOR00ff00,LAYER0;;
LOWER: MID - 2*STD(CLOSE,26),COLOR0099ff,LAYER0;;;
DRAWBMP(CROSS(UPPER,C),H*1.008,'SE'),ALIGN1;
DRAWBMP(CROSS(LOWER,C),L*0.99,'BU'),ALIGN1;

FILLRGN(UPPER,MID,UPPER>MID,RGB(0,0,188)),LAYER7;
FILLRGN(LOWER,MID,LOWER<MID,RGB(78,0,0)),LAYER7;
上轨下:LAST(C<UPPER),LINETHICK0;
上轨上:LAST(C>UPPER),LINETHICK0;
DRAWTEXTABS(60,35,IFS((上轨下>0),'----◆在BOLL上轨下【第'+NUMTOSTRN(上轨下,0)+'个周期】◆----','')),LINETHICK4,Color00FF00;
DRAWTEXTABS(60,35,IFS((上轨上>0),'----◆在BOLL上轨上【第'+NUMTOSTRN(上轨上,0)+'个周期】◆----','')),LINETHICK4,Color00FFff;

周:="050引.CL#WEEK";
isColor:=if(周<>ref(周,1) or barpos=1,1,0); {转折线在每周一 }
DIS0:=if(barpos=1 or not(isColor),0,0);
DIS:=SUM(DIS0,0);
Num:=count(isColor,0)+DIS;
PD0:=isColor and mod(Num,4)=0;
PD1:=isColor and mod(Num,4)=1;
PD2:=isColor and mod(Num,4)=2;
PD3:=isColor and mod(Num,4)=3;
VERTLINE(PD0,0),colorred,linethick2,LAYER5;
VERTLINE(PD1,0),coloryellow,linethick1,LAYER5;
VERTLINE(PD2,0),colorff9900,linethick1,LAYER5;
VERTLINE(PD3,1),colorgreen,linethick1,LAYER5;
X:=BARSLAST(DISPSTATUS=1)+1; LL:=LLVALL(LLV(L,X));
DRAWTEXT(PD0,LL*0.99,'【红】'),COLORFF00FF,VALIGN2,ALIGN0,linethick2,LAYER0;;
DRAWTEXT(PD1,LL*0.99,'【黄】'),COLORFFFFFF,VALIGN2,ALIGN0,linethick2,LAYER0;;
DRAWTEXT(PD2,LL*0.99,'【兰】'),COLORFF9900,VALIGN2,ALIGN0,linethick2,LAYER0;;
DRAWTEXT(PD3,LL*0.99,'【绿】'),COLOR00FF00,VALIGN2,ALIGN0,linethick2,LAYER0;
DC0:=REF(C,BARSLAST(PD0));
DRAWLINE(PD0,DC0,PD0,DC0,0),ColorFFFFFF,DASHLINE;
{周涨}
CL:="050引.CL#WEEK";
RC:="050引.RC#WEEK";
ZF:=(CL-RC)/RC*100;
STICKLINE(CL>=RC ,CL ,RC,12,0) ,COLOR004960,LAYER6;
STICKLINE(CL>=RC ,CL ,CL,8,101),DASHLINE,COLOR0069FF,LAYER6;
STICKLINE(CL>=RC ,RC ,RC,12,101),LINETHICK2,COLOR0099FF,LAYER6;
STICKLINE(CL<RC ,CL ,RC,12,0) ,COLORff4400,LAYER6;
STICKLINE(CL<RC ,CL ,CL,8,101),DASHLINE,COLORFFDD00,LAYER6;
STICKLINE(CL<RC ,RC ,RC,12,101),LINETHICK2,COLORFF9900,LAYER6;
DRAWTEXT(DISPSTATUS=2,RC*0.99,' 周涨【'+NUMTOSTRN(ZF,2)+'%】'),COLORFFFFFF,LINETHICK2,ALIGN1;
-------用于日线周期---------------


 















周:=C#WEEK;
CL:=L#WEEK;
RC:=C#WEEK;
ZF:=(CL-RC)/RC*100;

DRAWTEXT(CURRBARSCOUNT=3,RC*0.998,STRCAT('周涨%',CON2STR(ZF,2))),COLORFFFFFF;
M:=BARSCOUNT(CLOSE)>31;
ISCOLOR:=IF(周<>REF(周,1) OR M=0,1,0);
DIS0:=IF(M=0 OR NOT(ISCOLOR),0,0);
DIS:=SUM(DIS0,0);
NUM:=COUNT(ISCOLOR,0)+DIS;
PD0:=ISCOLOR AND MOD(NUM,4)=0;
PD1:=ISCOLOR AND MOD(NUM,4)=1;
PD2:=ISCOLOR AND MOD(NUM,4)=2;
PD3:=ISCOLOR AND MOD(NUM,4)=3;
HH:=CONST(HHV(H,360));
LL:=CONST(LLV(L,360));
STICKLINE(ISCOLOR AND MOD(NUM,4)=0,HH,LL,0,-1),COLOR0000FF;
STICKLINE(ISCOLOR AND MOD(NUM,4)=1,HH,LL,0,-1),COLOR00FFFF;
STICKLINE(ISCOLOR AND MOD(NUM,4)=2,HH,LL,0,-1),COLORFFFF00;
STICKLINE(ISCOLOR AND MOD(NUM,4)=3,HH,LL,0,-1),COLOR00FF00;
DRAWTEXT(PD0,HH*0.98,'【红】'),COLOR0000FF;
DRAWTEXT(PD1,HH*0.98,'【黄】'),COLOR00FFFF;
DRAWTEXT(PD2,HH*0.98,'【兰】'),COLORFF9900;
DRAWTEXT(PD3,HH*0.98,'【绿】'),COLOR00FF00;
MID:MA(CLOSE,26),COLOR00FFFF,DOTLINE;
UPPER:MID + 2*STD(CLOSE,26),COLOR00FF00;
LOWER:MID - 2*STD(CLOSE,26),COLOR0099FF;
DRAWBMP(CROSS(UPPER,C),H*1.008,'SE');
DRAWBMP(CROSS(LOWER,C),L*0.99,'BU');


好股票软件下载网(www.goodgupiao.com)提醒您:股市有风险,投资需谨慎。
相关说明
  • 好股票软件下载网欢迎用户将网页内容和下载地址转发到博客、微博、论坛等。
  • 发布的公式指标绝大部分是来源于各大论坛,谢谢各位老师的原创指标。
  • 判断公式指标好坏,请用户参考用户评论或者软件好评度
  • alg格式股票公式,仅仅可以用飞狐交易师股票软件引入使用;
  • fnc格式股票公式,可以用大智慧新一代高速行情分析系统股票软件使用,少部分可以用分析家股票软件引入使用;
  • exp格式股票公式,仅可以用大智慧经典版股票软件引入使用;
  • tnctni格式股票公式,仅可以用通达信新引入使用,例如可以用通达信股票软件引入使用;
  • tne格式公式,仅可以用通达信公式编辑器5.0版导入,高版本兼容低版本;
  • hxf格式股票公式,仅可以用同花顺股票软件引入使用。
  • 如果引入公式的时候,发现公式名称栏空白,调整电脑时间到1997年,能出现公式名称并正常显示,可能是公式使用期限已过。
  • 如果您发现下载链接错误,请点击报告错误谢谢!