好股票网每日提供最新股票软件下载,如果您觉得不错,麻烦推荐给您的好友,谢谢!
您现在的位置:好股票网 >> 股票公式 >> 大智慧L2公式

网上抄来的【大智慧新一代DELTA主图公式】我就给他来个【画蛇添足】

[下载地址]

好股票网经过测试可运行,该软件通过多款专业杀毒软件扫描

  • 360通过
  • 金山通过
  • 瑞星通过
  • 江民通过
  • 卡巴通过
  • 诺顿通过
  • 运行平台:Win7/Vista/WinXP/Win2003/
  • 公式语言:简体中文
  • 更新时间:2017-08-13 21:29:00
  • 公式评级:
  • 公式类型:大智慧L2公式
  • 授权方式:共享版
  • 公式大小:0 Bytes
  • 解压密码:goodgupiao
  • 下载统计:
  • 相关Tags:
已有次下载
推 荐0
不推荐0

网上抄来的【大智慧新一代DELTA主图公式】我就给他来个【画蛇添足】介绍

好股票软件下载网(www.goodgupiao.com)提示:您正在下载的是:网上抄来的【大智慧新一代DELTA主图公式】我就给他来个【画蛇添足】

这个就是我 网上抄来的【大智慧新一代DELTA主图公式】的源码:
农历:=lday;
isFirst:=if(农历>Ref(农历,1) and ref(农历,1)<15 and 农历>15,1,0);
isColor:=if(lday=15 or isFirst,1,0); {判断是否绘制彩线的位置:农历15,或者农历15后的第一个交易日}
Num:=count(isColor,0);
VERTLINE(isColor and mod(Num,4)=0,1),colorred,pointdot;
VERTLINE(isColor and mod(Num,4)=1,1),coloryellow,pointdot;
VERTLINE(isColor and mod(Num,4)=2,1),colorblue,pointdot;
VERTLINE(isColor and mod(Num,4)=3,1),colorgreen,pointdot;




为了进一步看清楚原来《三角洲预测》有利于咱们使用我编辑大智慧源码如下;-----------
{DELTA月15}
DRAWGBKlast(c>0,strip(RGB(0,50,0),RGB(0,0,80),0)),LAYER7;
DRAWTEXTABS(660,6,'今天农历:◆'+NUMTOSTRN(LMONTH,0)+'月'+NUMTOSTRN(LDAY,0)+'日◆'),LINETHICK5,COLOR00ffff;
{【必备】---K线【C AND REF(C,1).】----}
{----CLOSE AND OPEN----}
STICKLINE(CLOSE>=OPEN,OPEN,LOW,0.5,0 ),COLOR0000ff,LAYER0;
STICKLINE(CLOSE>=OPEN,CLOSE,HIGH,0.5,0 ),COLOR0000ff,LAYER0;
STICKLINE(CLOSE<OPEN,OPEN,LOW,0.8,0 ),COLOR00ff00,LAYER5;
STICKLINE(CLOSE<OPEN,CLOSE,HIGH,0.8,0 ),COLOR00ff00,LAYER5;
{----C>REF(C,1)----}
stickline(C>REF(C,1),C,O,8,0),Color000033,LAYER4;
stickline(C>REF(C,1),C,O,7,0),Color000055,LAYER4;
stickline(C>REF(C,1),C,O,6,0),Color000077,LAYER4;
stickline(C>REF(C,1),C,O,5,0),Color000099,LAYER4;
stickline(C>REF(C,1),C,O,4,0),Color0000bb,LAYER4;
stickline(C>REF(C,1),C,O,2,0),Color6500dd,LAYER4;
stickline(C>REF(C,1),C,O,1,0),Color9C00ff,LAYER4;
{----C<REF(C,1)----}
stickline(C<REF(C,1),C,O,8,0),Color003300,LAYER4;
stickline(C<REF(C,1),C,O,7,0),Color005500,LAYER4;
stickline(C<REF(C,1),C,O,6,0),Color007700,LAYER4;
stickline(C<REF(C,1),C,O,5,0),Color009900,LAYER4;
stickline(C<REF(C,1),C,O,4,0),Color00bb00,LAYER4;
stickline(C<REF(C,1),C,O,2,0),Color65dd00,LAYER4;
stickline(C<REF(C,1),C,O,1,0),Color9Cff00,LAYER4;
{----C=REF(C,1)----}
stickline(C=REF(C,1),C,O,8,0),Color008888,LAYER4;
stickline(C=REF(C,1),C,O,6,0),Color00AAAA,LAYER4;
stickline(C=REF(C,1),C,O,3,0),Color00DDDD,LAYER4;
stickline(C=REF(C,1),C,O,1,0),Color00ffFF,LAYER4;
现价: if (DYNAINFO(4)=0,C,DYNAINFO(7)),colorFF00FF,POINTDOT,LINETHICK2;
MID : MA(CLOSE,26),COLOR00ffFF,DOTLINE,LAYER0;;;
UPPER: MID + 2*STD(CLOSE,26),COLOR00ff00,DOTLINE,LAYER0;;
LOWER: MID - 2*STD(CLOSE,26),COLOR0099ff,DOTLINE,LAYER0;;;
DRAWBMP(CROSS(UPPER,C),H*1.008,'SE'),ALIGN1;
DRAWBMP(CROSS(LOWER,C),L*0.99,'BU'),ALIGN1;

FILLRGN(UPPER,MID,UPPER>MID,RGB(0,0,188)),LAYER7;
FILLRGN(LOWER,MID,LOWER<MID,RGB(78,0,0)),LAYER7;
上轨下:LAST(C<UPPER),LINETHICK0;
上轨上:LAST(C>UPPER),LINETHICK0;
DRAWTEXTABS(60,35,IFS((上轨下>0),'----◆在BOLL上轨下【第'+NUMTOSTRN(上轨下,0)+'个周期】◆----','')),LINETHICK4,Color00FF00;
DRAWTEXTABS(60,35,IFS((上轨上>0),'----◆在BOLL上轨上【第'+NUMTOSTRN(上轨上,0)+'个周期】◆----','')),LINETHICK4,Color00FFff;

农历:=LDAY;;
isFirst:=if(农历>Ref(农历,1) and ref(农历,1)<15 and 农历>15,1,0);
isColor:=if(lday=15 or isFirst,1,0); {判断是否绘制彩线的位置:农历15,或者农历15后的第一个交易日}
Num:=count(isColor,0);
VERTLINE(isColor and mod(Num,4)=0,0),colorred,LINETHICK2,LAYER5;
VERTLINE(isColor and mod(Num,4)=1,0),coloryellow,LINETHICK1,LAYER5;
VERTLINE(isColor and mod(Num,4)=2,0),colorff9900,LINETHICK1,LAYER5;
VERTLINE(isColor and mod(Num,4)=3,0),colorgreen,LINETHICK1,LAYER5;
X:=BARSLAST(DISPSTATUS=1)+1; LL:=LLVALL(LLV(L,X)); HH:=HHVALL(HHV(H,X)); HH*1.04,COLOR000000;
PD0:=isColor and mod(Num,4)=0;
DRAWTEXT(PD0,LL*1.01,'农历:'+NUMTOSTRN(LMONTH,0)+'.'+NUMTOSTRN(LDAY,0)+'→'),COLOR00FFFF,VALIGN2,ALIGN2,linethick2,LAYER0;;
DRAWTEXT(PD0,LL*0.98,'【红】四次转折'),COLORFF00FF,VALIGN2,ALIGN0,linethick2,LAYER0;;
PD1:=isColor and mod(Num,4)=1;
DRAWTEXT(PD1,LL*1.01,'农历:'+NUMTOSTRN(LMONTH,0)+'.'+NUMTOSTRN(LDAY,0)+'→'),COLOR00FFFF,VALIGN2,ALIGN2,linethick2,LAYER0;;
DRAWTEXT(PD1,LL*0.98,'【黄】可逢高减仓'),COLORFFFFFF,VALIGN2,ALIGN0,linethick2,LAYER0;;
PD2:=isColor and mod(Num,4)=2;
DRAWTEXT(PD2,LL*1.01,'农历:'+NUMTOSTRN(LMONTH,0)+'.'+NUMTOSTRN(LDAY,0)+'→'),COLOR00FFFF,VALIGN2,ALIGN2,linethick2,LAYER0;;
DRAWTEXT(PD2,LL*0.98,'【兰】常规应调整'),COLORFF9900,VALIGN2,ALIGN0,linethick2,LAYER0;;
PD3:=isColor and mod(Num,4)=3;
DRAWTEXT(PD3,LL*1.01,'农历:'+NUMTOSTRN(LMONTH,0)+'.'+NUMTOSTRN(LDAY,0)+'→'),COLOR00FFFF,VALIGN2,ALIGN2,linethick2,LAYER0;
DRAWTEXT(PD3,LL*0.98,'【绿】逢低可建仓'),COLOR00FF00,VALIGN2,ALIGN0,linethick2,LAYER0;
DC0:=REF(C,BARSLAST(PD0));;
DRAWTEXT(PD0,HH,' C='+NUMTOSTRN(DC0,2)+' '),COLOR00FFFF,VALIGN2,ALIGN0,linethick2,LAYER0;;
DC1:=REF(C,BARSLAST(PD1));
DRAWTEXT(PD1,HH,' C='+NUMTOSTRN(DC1,2)+' '),COLOR00FFFF,VALIGN2,ALIGN0,linethick2,LAYER0;;
DC2:=REF(C,BARSLAST(PD2));
DRAWTEXT(PD2,HH,' C='+NUMTOSTRN(DC2,2)+' '),COLOR00FFFF,VALIGN2,ALIGN0,linethick2,LAYER0;;
DC3:=REF(C,BARSLAST(PD3));
DRAWTEXT(PD3,HH,' C='+NUMTOSTRN(DC3,2)+' '),COLOR00FFFF,VALIGN2,ALIGN0,linethick2,LAYER0;;
DRAWLINE(PD0,DC0,PD1,DC1,0),Color0044ff,LINETHICK2;;
DRAWLINE(PD1,DC1,PD2,DC2,0),Color00FFff,LINETHICK2;;
DRAWLINE(PD2,DC2,PD3,DC3,0),ColorFF9900,LINETHICK2;;
DRAWLINE(PD3,DC3,PD0,DC0,0),Color00ff00,LINETHICK2;
DRAWLINE(PD0,DC0,PD0,DC0,0),ColorFFFFFF,DASHLINE;;


 



【注意】这是农历每月十五就是转折点.第一根红线就是四个循环的起点.而且第一根红线就是该股上市那天以后每四个【农历15日】循环一次.所以现在每个股票是处于那个循环就更不一样了


我想说一楼每月转折一次.对于散户来说间隔有点长.我们还想知道每一周的变化.可是【DELTA理论】短期是每四天一次循环.可惜大智慧软件没有时间間間隔的函数,【DATEDIFF】 所以我只好用大智慧的周线.其实周线是五天一个循环.与【三角洲 DELTA理论 预测】不符. 没有办法;
下面是添加了【周线循环】的源码.仅供参考-------------
{DELTA月15}
DRAWGBKlast(c>0,strip(RGB(0,50,0),RGB(0,0,80),0)),LAYER7;
DRAWTEXTABS(660,6,'今天农历:◆'+NUMTOSTRN(LMONTH,0)+'月'+NUMTOSTRN(LDAY,0)+'日◆'),LINETHICK5,COLOR00ffff;
{【必备】---K线【C AND REF(C,1).】----}
{----CLOSE AND OPEN----}
STICKLINE(CLOSE>=OPEN,OPEN,LOW,0.5,0 ),COLOR0000ff,LAYER0;
STICKLINE(CLOSE>=OPEN,CLOSE,HIGH,0.5,0 ),COLOR0000ff,LAYER0;
STICKLINE(CLOSE<OPEN,OPEN,LOW,0.8,0 ),COLOR00ff00,LAYER5;
STICKLINE(CLOSE<OPEN,CLOSE,HIGH,0.8,0 ),COLOR00ff00,LAYER5;
{----C>REF(C,1)----}
stickline(C>REF(C,1),C,O,8,0),Color000033,LAYER4;
stickline(C>REF(C,1),C,O,7,0),Color000055,LAYER4;
stickline(C>REF(C,1),C,O,6,0),Color000077,LAYER4;
stickline(C>REF(C,1),C,O,5,0),Color000099,LAYER4;
stickline(C>REF(C,1),C,O,4,0),Color0000bb,LAYER4;
stickline(C>REF(C,1),C,O,2,0),Color6500dd,LAYER4;
stickline(C>REF(C,1),C,O,1,0),Color9C00ff,LAYER4;
{----C<REF(C,1)----}
stickline(C<REF(C,1),C,O,8,0),Color003300,LAYER4;
stickline(C<REF(C,1),C,O,7,0),Color005500,LAYER4;
stickline(C<REF(C,1),C,O,6,0),Color007700,LAYER4;
stickline(C<REF(C,1),C,O,5,0),Color009900,LAYER4;
stickline(C<REF(C,1),C,O,4,0),Color00bb00,LAYER4;
stickline(C<REF(C,1),C,O,2,0),Color65dd00,LAYER4;
stickline(C<REF(C,1),C,O,1,0),Color9Cff00,LAYER4;
{----C=REF(C,1)----}
stickline(C=REF(C,1),C,O,8,0),Color008888,LAYER4;
stickline(C=REF(C,1),C,O,6,0),Color00AAAA,LAYER4;
stickline(C=REF(C,1),C,O,3,0),Color00DDDD,LAYER4;
stickline(C=REF(C,1),C,O,1,0),Color00ffFF,LAYER4;
现价: if (DYNAINFO(4)=0,C,DYNAINFO(7)),colorFF00FF,POINTDOT,LINETHICK2;
MID : MA(CLOSE,26),COLOR00ffFF,DOTLINE,LAYER0;;;
UPPER: MID + 2*STD(CLOSE,26),COLOR00ff00,DOTLINE,LAYER0;;
LOWER: MID - 2*STD(CLOSE,26),COLOR0099ff,DOTLINE,LAYER0;;;
DRAWBMP(CROSS(UPPER,C),H*1.008,'SE'),ALIGN1;
DRAWBMP(CROSS(LOWER,C),L*0.99,'BU'),ALIGN1;

FILLRGN(UPPER,MID,UPPER>MID,RGB(0,0,188)),LAYER7;
FILLRGN(LOWER,MID,LOWER<MID,RGB(78,0,0)),LAYER7;
上轨下:LAST(C<UPPER),LINETHICK0;
上轨上:LAST(C>UPPER),LINETHICK0;
DRAWTEXTABS(60,35,IFS((上轨下>0),'----◆在BOLL上轨下【第'+NUMTOSTRN(上轨下,0)+'个周期】◆----','')),LINETHICK4,Color00FF00;
DRAWTEXTABS(60,35,IFS((上轨上>0),'----◆在BOLL上轨上【第'+NUMTOSTRN(上轨上,0)+'个周期】◆----','')),LINETHICK4,Color00FFff;

农历:=LDAY;;
isFirst:=if(农历>Ref(农历,1) and ref(农历,1)<15 and 农历>15,1,0);
isColor:=if(lday=15 or isFirst,1,0); {判断是否绘制彩线的位置:农历15,或者农历15后的第一个交易日}
Num:=count(isColor,0);
VERTLINE(isColor and mod(Num,4)=0,0),colorred,LINETHICK2,LAYER5;
VERTLINE(isColor and mod(Num,4)=1,0),coloryellow,LINETHICK1,LAYER5;
VERTLINE(isColor and mod(Num,4)=2,0),colorff9900,LINETHICK1,LAYER5;
VERTLINE(isColor and mod(Num,4)=3,0),colorgreen,LINETHICK1,LAYER5;
X:=BARSLAST(DISPSTATUS=1)+1; LL:=LLVALL(LLV(L,X)); HH:=HHVALL(HHV(H,X)); HH*1.04,COLOR000000;
PD0:=isColor and mod(Num,4)=0;
DRAWTEXT(PD0,LL*1.01,'农历:'+NUMTOSTRN(LMONTH,0)+'.'+NUMTOSTRN(LDAY,0)+'→'),COLOR00FFFF,VALIGN2,ALIGN2,linethick2,LAYER0;;
DRAWTEXT(PD0,LL*0.98,'【红】四次转折'),COLORFF00FF,VALIGN2,ALIGN0,linethick2,LAYER0;;
PD1:=isColor and mod(Num,4)=1;
DRAWTEXT(PD1,LL*1.01,'农历:'+NUMTOSTRN(LMONTH,0)+'.'+NUMTOSTRN(LDAY,0)+'→'),COLOR00FFFF,VALIGN2,ALIGN2,linethick2,LAYER0;;
DRAWTEXT(PD1,LL*0.98,'【黄】可逢高减仓'),COLORFFFFFF,VALIGN2,ALIGN0,linethick2,LAYER0;;
PD2:=isColor and mod(Num,4)=2;
DRAWTEXT(PD2,LL*1.01,'农历:'+NUMTOSTRN(LMONTH,0)+'.'+NUMTOSTRN(LDAY,0)+'→'),COLOR00FFFF,VALIGN2,ALIGN2,linethick2,LAYER0;;
DRAWTEXT(PD2,LL*0.98,'【兰】常规应调整'),COLORFF9900,VALIGN2,ALIGN0,linethick2,LAYER0;;
PD3:=isColor and mod(Num,4)=3;
DRAWTEXT(PD3,LL*1.01,'农历:'+NUMTOSTRN(LMONTH,0)+'.'+NUMTOSTRN(LDAY,0)+'→'),COLOR00FFFF,VALIGN2,ALIGN2,linethick2,LAYER0;
DRAWTEXT(PD3,LL*0.98,'【绿】逢低可建仓'),COLOR00FF00,VALIGN2,ALIGN0,linethick2,LAYER0;
DC0:=REF(C,BARSLAST(PD0));;
DRAWTEXT(PD0,HH,' C='+NUMTOSTRN(DC0,2)+' '),COLOR00FFFF,VALIGN2,ALIGN0,linethick2,LAYER0;;
DC1:=REF(C,BARSLAST(PD1));
DRAWTEXT(PD1,HH,' C='+NUMTOSTRN(DC1,2)+' '),COLOR00FFFF,VALIGN2,ALIGN0,linethick2,LAYER0;;
DC2:=REF(C,BARSLAST(PD2));
DRAWTEXT(PD2,HH,' C='+NUMTOSTRN(DC2,2)+' '),COLOR00FFFF,VALIGN2,ALIGN0,linethick2,LAYER0;;
DC3:=REF(C,BARSLAST(PD3));
DRAWTEXT(PD3,HH,' C='+NUMTOSTRN(DC3,2)+' '),COLOR00FFFF,VALIGN2,ALIGN0,linethick2,LAYER0;;
{DRAWLINE(PD0,DC0,PD1,DC1,0),Color0044ff,LINETHICK2;;
DRAWLINE(PD1,DC1,PD2,DC2,0),Color00FFff,LINETHICK2;;
DRAWLINE(PD2,DC2,PD3,DC3,0),ColorFF9900,LINETHICK2;;
DRAWLINE(PD3,DC3,PD0,DC0,0),Color00ff00,LINETHICK2; ;}
DRAWLINE(PD0,DC0,PD0,DC0,0),ColorFFFFFF,DASHLINE;;

周:="050引.CL#WEEK";
isColor周:=if(周<>ref(周,1) or barpos=1,1,0); {{转折线在每周一 }
DIS0周:=if(barpos=1 or not(isColor周),0,0);
DIS周:=SUM(DIS0周,0);
Num周:=count(isColor周,0)+DIS周;
PD0周:=isColor周 and mod(Num周,4)=0;
PD1周:=isColor周 and mod(Num周,4)=1;
PD2周:=isColor周 and mod(Num周,4)=2;
PD3周:=isColor周 and mod(Num周,4)=3;
DC0周:=REF(C,BARSLAST(PD0周));
DC1周:=REF(C,BARSLAST(PD1周));
DC2周:=REF(C,BARSLAST(PD2周));
DC3周:=REF(C,BARSLAST(PD3周));
DRAWLINE(PD0周,DC0周,PD1周,DC1周,0),Color0044ff,LINETHICK2,LAYER0;
DRAWLINE(PD1周,DC1周,PD2周,DC2周,0),Color00FFff,LINETHICK2,LAYER0;
DRAWLINE(PD2周,DC2周,PD3周,DC3周,0),ColorFF9900,LINETHICK2,LAYER0;
DRAWLINE(PD3周,DC3周,PD0周,DC0周,0),Color00ff00,LINETHICK2,LAYER0; { }
这里用到【"050引.CL#WEEK"】其中CL就是收盘价 【CL:C,LINETHICK0;】因为引用就是为了变化周期【050引】名称可以改的.





可不可以另编辑一个单独的【DELTA周线】源码.用起来方便可以在周.日.分钟等.其他各类周期去用这个公式------------
{DELTA周线}
DRAWGBKlast(c>0,strip(RGB(0,50,0),RGB(0,0,80),0)),LAYER7;
{【必备】---K线【C AND REF(C,1).】----}
{----CLOSE AND OPEN----}
STICKLINE(CLOSE>=OPEN,OPEN,LOW,0.5,0 ),COLOR0000ff,LAYER0;
STICKLINE(CLOSE>=OPEN,CLOSE,HIGH,0.5,0 ),COLOR0000ff,LAYER0;
STICKLINE(CLOSE<OPEN,OPEN,LOW,0.8,0 ),COLOR00ff00,LAYER5;
STICKLINE(CLOSE<OPEN,CLOSE,HIGH,0.8,0 ),COLOR00ff00,LAYER5;
{----C>REF(C,1)----}
stickline(C>REF(C,1),C,O,8,0),Color000033,LAYER4;
stickline(C>REF(C,1),C,O,7,0),Color000055,LAYER4;
stickline(C>REF(C,1),C,O,6,0),Color000077,LAYER4;
stickline(C>REF(C,1),C,O,5,0),Color000099,LAYER4;
stickline(C>REF(C,1),C,O,4,0),Color0000bb,LAYER4;
stickline(C>REF(C,1),C,O,2,0),Color6500dd,LAYER4;
stickline(C>REF(C,1),C,O,1,0),Color9C00ff,LAYER4;
{----C<REF(C,1)----}
stickline(C<REF(C,1),C,O,8,0),Color003300,LAYER4;
stickline(C<REF(C,1),C,O,7,0),Color005500,LAYER4;
stickline(C<REF(C,1),C,O,6,0),Color007700,LAYER4;
stickline(C<REF(C,1),C,O,5,0),Color009900,LAYER4;
stickline(C<REF(C,1),C,O,4,0),Color00bb00,LAYER4;
stickline(C<REF(C,1),C,O,2,0),Color65dd00,LAYER4;
stickline(C<REF(C,1),C,O,1,0),Color9Cff00,LAYER4;
{----C=REF(C,1)----}
stickline(C=REF(C,1),C,O,8,0),Color008888,LAYER4;
stickline(C=REF(C,1),C,O,6,0),Color00AAAA,LAYER4;
stickline(C=REF(C,1),C,O,3,0),Color00DDDD,LAYER4;
stickline(C=REF(C,1),C,O,1,0),Color00ffFF,LAYER4;
现价: if (DYNAINFO(4)=0,C,DYNAINFO(7)),colorFF00FF,POINTDOT,LINETHICK2;
MID : MA(CLOSE,26),COLOR00ffFF,DOTLINE,LAYER0;;;
UPPER: MID + 2*STD(CLOSE,26),COLOR00ff00,DOTLINE,LAYER0;;
LOWER: MID - 2*STD(CLOSE,26),COLOR0099ff,DOTLINE,LAYER0;;;
DRAWBMP(CROSS(UPPER,C),H*1.008,'SE'),ALIGN1;
DRAWBMP(CROSS(LOWER,C),L*0.99,'BU'),ALIGN1;

FILLRGN(UPPER,MID,UPPER>MID,RGB(0,0,188)),LAYER7;
FILLRGN(LOWER,MID,LOWER<MID,RGB(78,0,0)),LAYER7;
上轨下:LAST(C<UPPER),LINETHICK0;
上轨上:LAST(C>UPPER),LINETHICK0;
DRAWTEXTABS(60,35,IFS((上轨下>0),'----◆在BOLL上轨下【第'+NUMTOSTRN(上轨下,0)+'个周期】◆----','')),LINETHICK4,Color00FF00;
DRAWTEXTABS(60,35,IFS((上轨上>0),'----◆在BOLL上轨上【第'+NUMTOSTRN(上轨上,0)+'个周期】◆----','')),LINETHICK4,Color00FFff;

周:="050引.CL#WEEK";
isColor:=if(周<>ref(周,1) or barpos=1,1,0); {转折线在每周一 }
DIS0:=if(barpos=1 or not(isColor),0,0);
DIS:=SUM(DIS0,0);
Num:=count(isColor,0)+DIS;
PD0:=isColor and mod(Num,4)=0;
PD1:=isColor and mod(Num,4)=1;
PD2:=isColor and mod(Num,4)=2;
PD3:=isColor and mod(Num,4)=3;
VERTLINE(PD0,0),colorred,linethick2,LAYER6;
VERTLINE(PD1,0),coloryellow,linethick1,LAYER6;
VERTLINE(PD2,0),colorff9900,linethick1,LAYER6;
VERTLINE(PD3,1),colorgreen,linethick1,LAYER6;
X:=BARSLAST(DISPSTATUS=1)+1; LL:=LLVALL(LLV(L,X));
DRAWTEXT(PD0,LL*0.99,'【红】'),COLORFF00FF,VALIGN2,ALIGN0,linethick2,LAYER0;;
DRAWTEXT(PD1,LL*0.99,'【黄】'),COLORFFFFFF,VALIGN2,ALIGN0,linethick2,LAYER0;;
DRAWTEXT(PD2,LL*0.99,'【兰】'),COLORFF9900,VALIGN2,ALIGN0,linethick2,LAYER0;;
DRAWTEXT(PD3,LL*0.99,'【绿】'),COLOR00FF00,VALIGN2,ALIGN0,linethick2,LAYER0;
DC0:=REF(C,BARSLAST(PD0));;
DC1:=REF(C,BARSLAST(PD1));
DC2:=REF(C,BARSLAST(PD2));
DC3:=REF(C,BARSLAST(PD3));
DRAWLINE(PD0,DC0,PD1,DC1,0),Color0044ff,LINETHICK2;;
DRAWLINE(PD1,DC1,PD2,DC2,0),Color00FFff,LINETHICK2;;
DRAWLINE(PD2,DC2,PD3,DC3,0),ColorFF9900,LINETHICK2;;
DRAWLINE(PD3,DC3,PD0,DC0,0),Color00ff00,LINETHICK2;;
DRAWLINE(PD0,DC0,PD0,DC0,0),ColorFFFFFF,DASHLINE;;
这里用到【"050引.CL#WEEK"】其中CL就是收盘价 【CL:C,LINETHICK0;】因为引用就是为了变化周期【050引】名称可以改的.




这是30分钟周期里看得到----------------------------------


 


好股票软件下载网(www.goodgupiao.com)提醒您:股市有风险,投资需谨慎。
网上抄来的【大智慧新一代DELTA主图公式】我就给他来个【画蛇添足】下载地址
相关说明
  • 好股票软件下载网欢迎用户将网页内容和下载地址转发到博客、微博、论坛等。
  • 发布的公式指标绝大部分是来源于各大论坛,谢谢各位老师的原创指标。
  • 判断公式指标好坏,请用户参考用户评论或者软件好评度
  • alg格式股票公式,仅仅可以用飞狐交易师股票软件引入使用;
  • fnc格式股票公式,可以用大智慧新一代高速行情分析系统股票软件使用,少部分可以用分析家股票软件引入使用;
  • exp格式股票公式,仅可以用大智慧经典版股票软件引入使用;
  • tnctni格式股票公式,仅可以用通达信新引入使用,例如可以用通达信股票软件引入使用;
  • tne格式公式,仅可以用通达信公式编辑器5.0版导入,高版本兼容低版本;
  • hxf格式股票公式,仅可以用同花顺股票软件引入使用。
  • 如果引入公式的时候,发现公式名称栏空白,调整电脑时间到1997年,能出现公式名称并正常显示,可能是公式使用期限已过。
  • 如果您发现下载链接错误,请点击报告错误谢谢!