好股票网每日提供最新股票软件下载,如果您觉得不错,麻烦推荐给您的好友,谢谢!
您现在的位置:好股票网 >> 股票公式 >> 通达信公式

通达信波浪尺主图源码 贴图

[下载地址]

好股票网经过测试可运行,该软件通过多款专业杀毒软件扫描

  • 360通过
  • 金山通过
  • 瑞星通过
  • 江民通过
  • 卡巴通过
  • 诺顿通过
  • 运行平台:Win7/Vista/WinXP/Win2003/
  • 公式语言:简体中文
  • 更新时间:2017-03-17 09:49:00
  • 公式评级:
  • 公式类型:通达信公式
  • 授权方式:共享版
  • 公式大小:2.00 KB
  • 解压密码:goodgupiao
  • 下载统计:
  • 相关Tags:
已有次下载
推 荐0
不推荐0

通达信波浪尺主图源码 贴图介绍

好股票软件下载网(www.goodgupiao.com)提示:您正在下载的是:通达信波浪尺主图源码 贴图

通达信波浪尺主图指标

调整参数设定
快速自动画波浪尺

画法精准 可自行验证!



通达信波浪尺主图源码:


参数
{高点 1 9999 10}
{低点 1 9999 10}
{高点选择 1 9999 1}
{低点选择 1 9999 1}
{波浪尺1 0 9999 0}
{波浪尺2 1 999 1}


PURC:=CONST(FINDHIGH(H,0,高点*10,高点选择));
PLZ:=CONST(BARSLAST(PURC=H))+1;
顶X:=CONST(IF(PLZ=1,H,REF(H,PLZ-1)));
QQT:=CONST(FINDLOW(L,0,低点*10,低点选择));
PLL:=CONST(BARSLAST(QQT=L))+1;
低X:=CONST(IF(PLL=1,L,REF(L,PLL-1)));
DRAWKLINE(H,O,L,C);

顶点:顶X,COLORRED;
底点:低X,COLORRED;


波动速率:=100*((顶X-低X)/(IF(PLL>PLZ,低X,顶X)))/(PLL-PLZ),NODRAW,COLORMAGENTA;
波动幅度:=((顶X-低X)/(IF(PLL>PLZ,低X,顶X)))*100;
波动价位:=(顶X-低X)*(IF(PLL>PLZ,1,-1));

BPURC:=CONST(FINDHIGH(H,0,(IF(波浪尺1>0,波浪尺1,IF(PLZ<PLL,高点,低点)))*5,波浪尺2));
BPLZ:=CONST(BARSLAST(BPURC=H))+1;
BQQT:=CONST(FINDLOW(L,0,(IF(波浪尺1>0,波浪尺1,IF(PLZ<PLL,高点,低点)))*5,波浪尺2));
BPLL:=CONST(BARSLAST(BQQT=L))+1;


BLC1:=CONST(FINDHIGH(H,0,(IF(波浪尺1>0,波浪尺1,IF(PLZ<PLL,高点,低点)))*5,波浪尺2));
BLC2:=CONST(BARSLAST(BPURC=H))+1;
BLC顶X:=CONST(IF(BPLZ=1,H,REF(H,BPLZ-1)));
BLC3:=CONST(FINDLOW(L,0,(IF(波浪尺1>0,波浪尺1,IF(PLZ<PLL,高点,低点)))*5,波浪尺2));
B6C4:=CONST(BARSLAST(BQQT=L))+1;
BLC低X:=CONST(IF(BPLL=1,L,REF(L,BPLL-1)));
BASE:=IF(波动速率<0,BLC顶X,BLC低X)COLORRED;
BLCX:=IF(波动速率<0,-1,1);
BLCZ:=(顶点-底点)*(IF(PLL>PLZ,1,-1));
{好股票网 http://www.goodgupiao.com 整理}

B618:=BASE+(BLCZ*0.618)COLORRED,DOTLINE;
B382:=BASE+(BLCZ*0.382)COLORRED,DOTLINE;
B05:=BASE+(BLCZ*0.5)COLORRED,DOTLINE;
B809:=BASE+(BLCZ*0.809)COLORRED,DOTLINE;
B191:=BASE+(BLCZ*0.191)COLORRED,DOTLINE;
B100:=BASE+(BLCZ*1)COLORRED;
B200:=BASE+(BLCZ*2)COLORRED;
B11:=BASE+(BLCZ*1.191)COLORRED;
B12:=BASE+(BLCZ*1.382)COLORRED;
B13:=BASE+(BLCZ*1.5)COLORRED;
B14:=BASE+(BLCZ*1.618)COLORRED;
B15:=BASE+(BLCZ*1.809)COLORRED;

BZ1:=BASE+(BLCZ*0.236)COLORRED;
BZ2:=BASE+(BLCZ*1.236)COLORRED;
BZ3:=BASE+(BLCZ*2.236)COLORRED;

B11B:=BASE+(BLCZ*2.191)COLORRED;
B12B:=BASE+(BLCZ*2.382)COLORRED;
B13B:=BASE+(BLCZ*2.5)COLORRED;
B14B:=BASE+(BLCZ*2.618)COLORRED;
B15B:=BASE+(BLCZ*2.809)COLORRED;

B300:=BASE+(BLCZ*3)COLORRED;

XZDD:=IF(PLL>PLZ,BPLL,BPLZ);
STICKLINE(CURRBARSCOUNT=XZDD ,BASE,B300,0,0),COLORRED;
DRAWTEXT(CURRBARSCOUNT=XZDD,B05,'---------0.500')COLORRED;
DRAWTEXT(CURRBARSCOUNT=XZDD,BASE,'---------BASE')COLORRED;
DRAWTEXT(CURRBARSCOUNT=XZDD,B618,'---------0.618')COLORRED;
DRAWTEXT(CURRBARSCOUNT=XZDD,B809,'---------0.809')COLORRED;
DRAWTEXT(CURRBARSCOUNT=XZDD,B382,'---------0.382')COLORRED;
DRAWTEXT(CURRBARSCOUNT=XZDD,B191,'---------0.191')COLORRED;
DRAWTEXT(CURRBARSCOUNT=XZDD,B100,'---------1.000')COLORRED;

DRAWTEXT(CURRBARSCOUNT=XZDD,B11,'---------1.191')COLORRED;
DRAWTEXT(CURRBARSCOUNT=XZDD,B12,'---------1.382')COLORRED;
DRAWTEXT(CURRBARSCOUNT=XZDD,B13,'---------1.500')COLORRED;
DRAWTEXT(CURRBARSCOUNT=XZDD,B14,'---------1.618')COLORRED;
DRAWTEXT(CURRBARSCOUNT=XZDD,B15,'---------1.809')COLORRED;
DRAWTEXT(CURRBARSCOUNT=XZDD,B200,'---------2.000')COLORRED;

DRAWTEXT(CURRBARSCOUNT=XZDD,B11B,'---------2.191')COLORRED;
DRAWTEXT(CURRBARSCOUNT=XZDD,B12B,'---------2.382')COLORRED;
DRAWTEXT(CURRBARSCOUNT=XZDD,B13B,'---------2.500')COLORRED;
DRAWTEXT(CURRBARSCOUNT=XZDD,B14B,'---------2.618')COLORRED;
DRAWTEXT(CURRBARSCOUNT=XZDD,B15B,'---------2.809')COLORRED;
DRAWTEXT(CURRBARSCOUNT=XZDD,B300,'---------3.000')COLORRED;

DRAWTEXT(CURRBARSCOUNT=XZDD,BZ1,'---------0.236')COLORRED;
DRAWTEXT(CURRBARSCOUNT=XZDD,BZ2,'---------1.236')COLORRED;
DRAWTEXT(CURRBARSCOUNT=XZDD,BZ3,'---------2.236')COLORRED;

QADQ:=IF(PLL>PLZ,PLL,PLZ);
QADH:=IF(PLL>PLZ,PLZ,PLL);
QHL1:=IF(PLL>PLZ,L,H);
QHL2:=IF(PLL>PLZ,H,L);

DRAWLINE(CURRBARSCOUNT=QADQ,QHL1,CURRBARSCOUNT=QADH,QHL2,0)COLORRED;
DRAWLINE(CURRBARSCOUNT=QADH,QHL2,CURRBARSCOUNT=XZDD,QHL1,0)COLORRED;


通达信波浪尺主图源码 贴图

通达信波浪尺主图源码 贴图

通达信波浪尺主图源码 贴图


好股票软件下载网(www.goodgupiao.com)提醒您:股市有风险,投资需谨慎。
相关说明
  • 好股票软件下载网欢迎用户将网页内容和下载地址转发到博客、微博、论坛等。
  • 发布的公式指标绝大部分是来源于各大论坛,谢谢各位老师的原创指标。
  • 判断公式指标好坏,请用户参考用户评论或者软件好评度
  • alg格式股票公式,仅仅可以用飞狐交易师股票软件引入使用;
  • fnc格式股票公式,可以用大智慧新一代高速行情分析系统股票软件使用,少部分可以用分析家股票软件引入使用;
  • exp格式股票公式,仅可以用大智慧经典版股票软件引入使用;
  • tnctni格式股票公式,仅可以用通达信新引入使用,例如可以用通达信股票软件引入使用;
  • tne格式公式,仅可以用通达信公式编辑器5.0版导入,高版本兼容低版本;
  • hxf格式股票公式,仅可以用同花顺股票软件引入使用。
  • 如果引入公式的时候,发现公式名称栏空白,调整电脑时间到1997年,能出现公式名称并正常显示,可能是公式使用期限已过。
  • 如果您发现下载链接错误,请点击报告错误谢谢!