好股票网每日提供最新股票软件下载,如果您觉得不错,麻烦推荐给您的好友,谢谢!
您现在的位置:好股票网 >> 股票公式 >> 通达信公式

CCI全背离 副图 源码 通达信 说明

[下载地址]

好股票网经过测试可运行,该软件通过多款专业杀毒软件扫描

  • 360通过
  • 金山通过
  • 瑞星通过
  • 江民通过
  • 卡巴通过
  • 诺顿通过
  • 运行平台:Win7/Vista/WinXP/Win2003/
  • 公式语言:简体中文
  • 更新时间:2016-04-15 21:36:00
  • 公式评级:
  • 公式类型:通达信公式
  • 授权方式:共享版
  • 公式大小:0 Bytes
  • 解压密码:goodgupiao
  • 下载统计:
  • 相关Tags:CCI  
已有次下载
推 荐0
不推荐0

CCI全背离 副图 源码 通达信 说明介绍

好股票软件下载网(www.goodgupiao.com)提示:您正在下载的是:CCI全背离 副图 源码 通达信 说明

1,cci穿过-100,并且趋势变红色,底部买点
2,面织背离是我自己加上去的,面积底背是指cci在0轴下方的面织也前一个在0轴下方的面积的对比,顶背也是这道理
3,所有背离信号只能作参考!



{背景}
DRAWGBK(C>0, RGB(1,1,1),RGB(1,1,1),0,'0',0);
STICKLINE(C>0,-100,100,28,0)COLOR000840;
STICKLINE(C>0,200,200,28,-1)COLOR000080;
STICKLINE(C>0,100,100,28,-1)COLOR000080;
STICKLINE(C>0,-2.5,2.5,28,0)COLOR000080;
STICKLINE(C>0,-100,-100,28,-1)COLOR000080;
STICKLINE(C>0,-200,-200,28,-1)COLOR000080;

{}
TYP:=(HIGH+LOW+CLOSE)/3;
CCI:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14)),STICK;{CCI柱线}
趋势线:EXPMA(CCI,4.5),COLORFF8000,NODRAW;{CCI的5天EMA}
DRAWBAND(CCI,RGB(128,0,0),趋势线,RGB(0,128,0));
STICKLINE(CCI>=0,0,CCI,0,-1),COLORLIRED;{红柱}
STICKLINE(CCI<0,0,CCI,0,-1),COLORLIBLUE;{绿柱}

{CCI}
{TYP:=(HIGH+LOW+CLOSE)/3;}
CCI值:(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14)),COLORYELLOW,LINETHICK1;{CCI线}
DRAWTEXT(ISLASTBAR,CCI值,' ←CCI'),COLORYELLOW;

{CCI背离}
N:=5;
CCI底背:=REF(C,BARSLAST(REF(FILTER(BACKSET(REF(CCI,N)=LLV(CCI,2*N+1),N+1),N) AND CCI=LLV(CCI,N+1),1))+1)>C AND
REF(CCI,BARSLAST(REF(FILTER(BACKSET(REF(CCI,N)=LLV(CCI,2*N+1),N+1),N) AND CCI=LLV(CCI,N+1),1))+1)<CCI AND
FILTER(BACKSET(REF(CCI,N)=LLV(CCI,2*N+1),N+1),N) AND CCI=LLV(CCI,N+1),COLORWHITE,NODRAW;{WWW.STOVIEW.COM}
DRAWLINE(FILTER(BACKSET(REF(CCI,N)=LLV(CCI,2*N+1),N+1),N) AND CCI=LLV(CCI,N+1),CCI,FILTER(CCI底背>0,5),CCI,0),
COLORWHITE,DOTLINE;
DRAWTEXT(CCI底背,CCI,'底背'),COLORWHITE;
CCI顶背:=REF(C,BARSLAST(REF(FILTER(BACKSET(REF(CCI,N)=HHV(CCI,2*N+1),N+1),N) AND CCI=HHV(CCI,N+1),1))+1)<C AND
REF(CCI,BARSLAST(REF(FILTER(BACKSET(REF(CCI,N)=HHV(CCI,2*N+1),N+1),N) AND CCI=HHV(CCI,N+1),1))+1)>CCI AND
FILTER(BACKSET(REF(CCI,N)=HHV(CCI,2*N+1),N+1),N) AND CCI=HHV(CCI,N+1),COLORGREEN,NODRAW;
DRAWLINE(FILTER(BACKSET(REF(CCI,N)=HHV(CCI,2*N+1),N+1),N) AND CCI=HHV(CCI,N+1),CCI,FILTER(CCI顶背>0,5),CCI,0),
COLORGREEN,DOTLINE;
DRAWTEXT(CCI顶背,CCI,'顶背'),COLORGREEN;

{------------------------------------------------------------------}
{趋势线的背离}
趋势线底背:=REF(C,BARSLAST(REF(FILTER(BACKSET(REF(趋势线,N)=LLV(趋势线,2*N+1),N+1),N) AND 趋势线=LLV(趋势线,N+1),1))+1)>C AND
REF(趋势线,BARSLAST(REF(FILTER(BACKSET(REF(趋势线,N)=LLV(趋势线,2*N+1),N+1),N) AND 趋势线=LLV(趋势线,N+1),1))+1)<趋势线 AND
FILTER(BACKSET(REF(趋势线,N)=LLV(趋势线,2*N+1),N+1),N) AND 趋势线=LLV(趋势线,N+1),COLORWHITE,NODRAW;
DRAWLINE(FILTER(BACKSET(REF(趋势线,N)=LLV(趋势线,2*N+1),N+1),N) AND 趋势线=LLV(趋势线,N+1),趋势线,FILTER(趋势线底背>0,5),趋势线,0),
COLORWHITE,DOTLINE;
DRAWTEXT(趋势线底背,趋势线,'趋势底背'),COLORFF80FF;
趋势线顶背:=REF(C,BARSLAST(REF(FILTER(BACKSET(REF(趋势线,N)=HHV(趋势线,2*N+1),N+1),N) AND 趋势线=HHV(趋势线,N+1),1))+1)<C AND
REF(趋势线,BARSLAST(REF(FILTER(BACKSET(REF(趋势线,N)=HHV(趋势线,2*N+1),N+1),N) AND 趋势线=HHV(趋势线,N+1),1))+1)>趋势线 AND
FILTER(BACKSET(REF(趋势线,N)=HHV(趋势线,2*N+1),N+1),N) AND 趋势线=HHV(趋势线,N+1),COLORGREEN,NODRAW;
DRAWLINE(FILTER(BACKSET(REF(趋势线,N)=HHV(趋势线,2*N+1),N+1),N) AND 趋势线=HHV(趋势线,N+1),趋势线,FILTER(趋势线顶背>0,5),趋势线,0),
COLORGREEN,DOTLINE;
DRAWTEXT(趋势线顶背,趋势线,'趋势顶背'),COLORFF8000;

{面积背离}
JC:= 0-CCI;
绿柱面积:=IF(CCI<0,SUM(CCI,BARSLAST(JC<0)),0);
红柱面积:=IF(CCI>0,SUM(CCI,BARSLAST(JC>0)),0);
本次最低价:=LLV(L,BARSLAST(JC<0));
本次最高价:=HHV(H,BARSLAST(JC>0));
X1:=IF (CCI<0,BARSLAST(CROSS(CCI,0)),0);
前次绿柱面积:=REF(绿柱面积,X1+1);
前次最低价:=REF(本次最低价,X1+1);
Y1:=IF((绿柱面积<0 AND ABS(绿柱面积)<ABS(前次绿柱面积) AND 本次最低价<前次最低价 ),1,0);
RS1:= CCI<0 AND REF(CCI,1)<0 AND C<前次最低价
AND ABS(绿柱面积)<ABS(前次绿柱面积) AND ABS(CCI)<ABS(REF(CCI,1));
底背驰:= IF (CROSS(CCI,0),REF(Y1,1),0);
DRAWTEXT(底背驰,LLV(CCI,5),'←面积底背'),COLORLIRED;
X2:=IF (CCI>0,BARSLAST(CROSS(0,CCI)),0);
前次红柱面积:=REF(红柱面积,X2+1);
前次最高价:=REF(本次最高价,X2+1);
Y2:=IF((红柱面积>0 AND 红柱面积<前次红柱面积 AND 本次最高价>前次最高价 ),1,0);
RS2:= CCI>0 AND REF(CCI,1)>0 AND C>前次最高价 AND ABS(红柱面积)<ABS(前次红柱面积) AND ABS(CCI)<ABS(REF(CCI,1));
顶背驰:= IF (CROSS(0,CCI),REF(Y2,1),0);
DRAWTEXT(顶背驰,HHV(CCI,5),'←面积顶背'),COLORCYAN;






 


好股票软件下载网(www.goodgupiao.com)提醒您:股市有风险,投资需谨慎。
CCI全背离 副图 源码 通达信 说明下载地址
相关说明
  • 好股票软件下载网欢迎用户将网页内容和下载地址转发到博客、微博、论坛等。
  • 发布的公式指标绝大部分是来源于各大论坛,谢谢各位老师的原创指标。
  • 判断公式指标好坏,请用户参考用户评论或者软件好评度
  • alg格式股票公式,仅仅可以用飞狐交易师股票软件引入使用;
  • fnc格式股票公式,可以用大智慧新一代高速行情分析系统股票软件使用,少部分可以用分析家股票软件引入使用;
  • exp格式股票公式,仅可以用大智慧经典版股票软件引入使用;
  • tnctni格式股票公式,仅可以用通达信新引入使用,例如可以用通达信股票软件引入使用;
  • tne格式公式,仅可以用通达信公式编辑器5.0版导入,高版本兼容低版本;
  • hxf格式股票公式,仅可以用同花顺股票软件引入使用。
  • 如果引入公式的时候,发现公式名称栏空白,调整电脑时间到1997年,能出现公式名称并正常显示,可能是公式使用期限已过。
  • 如果您发现下载链接错误,请点击报告错误谢谢!