好股票网每日提供最新股票软件下载,如果您觉得不错,麻烦推荐给您的好友,谢谢!
您现在的位置:好股票网 >> 股票公式 >> 大智慧L2公式

高山的流水----趋势排序指标;预测明涨跌幅,大智慧2号版本

[下载地址]

好股票网经过测试可运行,该软件通过多款专业杀毒软件扫描

  • 360通过
  • 金山通过
  • 瑞星通过
  • 江民通过
  • 卡巴通过
  • 诺顿通过
  • 运行平台:Win7/Vista/WinXP/Win2003/
  • 公式语言:简体中文
  • 更新时间:2015-10-12 11:02:00
  • 公式评级:
  • 公式类型:大智慧L2公式
  • 授权方式:共享版
  • 公式大小:0 Bytes
  • 解压密码:goodgupiao
  • 下载统计:
  • 相关Tags:
已有次下载
推 荐0
不推荐0

高山的流水----趋势排序指标;预测明涨跌幅,大智慧2号版本介绍

好股票软件下载网(www.goodgupiao.com)提示:您正在下载的是:高山的流水----趋势排序指标;预测明涨跌幅,大智慧2号版本

直接找盘中热点和强势股!
{高山的流水----趋势排序指标;预测明涨跌幅,大智慧2号版本}
{周周期使用}
X00:=C;
MX000:=(0.3609454219*X00-0.03309329629*REF(X00,1)-0.04241822779*REF(X00,2)-0.026737249*REF(X00,3)-0.007010041271*REF(X00,4)-0.002652859952*REF(X00,5)-0.0008415042966*REF(X00,6)-0.0002891931964*REF(X00,7)-0.0000956265934*REF(X00,8)-0.0000321286052*REF(X00,9)-0.0000106773454*REF(X00,10)-0.0000035457562*REF(X00,11)-0.0000011670713*REF(X00,12) )/ (1-0.7522406533 );
明日重心涨跌幅:=(MX000-X00)/X00*100;
{波段趋势}
VAR21:=(CLOSE-LLV(LOW,80))/(HHV(HIGH,80)-LLV(LOW,80))*200;
VAR22:=SMA(VAR21,3,1);VAR23:=SMA(VAR22,3,1);
VAR24:=3*VAR22-2*VAR23;VAR25:=LLV(LOW,5);VAR26:=HHV(HIGH,5);
VAR27:=EMA((CLOSE-VAR25)/(VAR26-VAR25)*100,4)*2;
VAR28:=EMA(0.667*REF(VAR27,1)+0.333*VAR27,2); VAR29:=3*VAR27-2*VAR28;
VARA:=POW(MA(CLOSE,5),2)+MA(CLOSE,5);
VARB:=POW(MA(LOW,5),2)+MA(LOW,5);
VARC:=POW(MA(HIGH,5),2)+MA(HIGH,5);
VARD:=(VARA-LLV(VARB,64))/(HHV(VARC,64)-LLV(VARB,64))*150+65-10;
VARE:=SMA(VARD,3,1)*1.5-100; VARF:=SMA(VARE,3,1);
VAR30:=3*VARE-2*VARF;VAR31:=(HIGH+LOW+CLOSE*2)/4;
VAR32:=EMA(VAR31,13);
VAR33:=STD(VAR31,13);
VAR34:=(VAR31-VAR32)*100/ VAR33;
VAR35:=EMA(VAR34,5);
VAR37:=EMA(VAR35,13)+200-100;
VAR38:=EMA(VAR37,10);
VAR39:=3*VAR37-2*VAR38;
VAR1A:=VAR22+VAR27+VARE+VAR37;
VAR1B:=VAR23+VAR28+VARF+VAR38;
VAR1C:=VAR24+VAR29+VAR30+VAR39;
VAR1D:=(HIGH+LOW+CLOSE)/3;
VAR40:=(VAR1D-MA(VAR1D,34))/(0.015*AVEDEV(VAR1D,34));
VAR42:=(HIGH+LOW+CLOSE+VAR1D)/4;
VAR43:=EMA(VAR42,24);
VAR44:=STD(VAR42,24);
VAR45:=(VAR42-VAR43)/ VAR44*100;
VAR46:=(VAR1D-MA(VAR1D,24))/(0.015*AVEDEV(VAR1D,24));
VAR47:=EMA(VAR45,5);
VAR2A:=((VAR47+VAR46+VAR40)/3+165)/4;
VAR2C:=(VAR1A+VAR1B+VAR1C*30)/32/5-15;
VAR2E:=(VAR2A+VAR2C)/2/1.1;
VAR48:=EMA(VAR2E,3);
VAR49:=EMA(VAR48,5);
VAR51:=SMA(VAR48,2,1);
{为了规避风险,设定了VAR48>=VAR51进行处理}
周明:IF((VAR48>VAR51 OR VAR48=VAR51) ,明日重心涨跌幅,-99);
{-99表示为已经在下跌趋势里};
----------------------------------------------------------------------------------------------
高山的流水----趋势排序指标;预测明涨跌幅,大智慧2号版本}
{日周期使用}
X00:=C;
MX000:=(0.3609454219*X00-0.03309329629*REF(X00,1)-0.04241822779*REF(X00,2)-0.026737249*REF(X00,3)-0.007010041271*REF(X00,4)-0.002652859952*REF(X00,5)-0.0008415042966*REF(X00,6)-0.0002891931964*REF(X00,7)-0.0000956265934*REF(X00,8)-0.0000321286052*REF(X00,9)-0.0000106773454*REF(X00,10)-0.0000035457562*REF(X00,11)-0.0000011670713*REF(X00,12) )/ (1-0.7522406533 );
明日重心涨跌幅:=(MX000-X00)/X00*100;
{波段趋势}
VAR21:=(CLOSE-LLV(LOW,80))/(HHV(HIGH,80)-LLV(LOW,80))*200;
VAR22:=SMA(VAR21,3,1);VAR23:=SMA(VAR22,3,1);
VAR24:=3*VAR22-2*VAR23;VAR25:=LLV(LOW,5);VAR26:=HHV(HIGH,5);
VAR27:=EMA((CLOSE-VAR25)/(VAR26-VAR25)*100,4)*2;
VAR28:=EMA(0.667*REF(VAR27,1)+0.333*VAR27,2); VAR29:=3*VAR27-2*VAR28;
VARA:=POW(MA(CLOSE,5),2)+MA(CLOSE,5);
VARB:=POW(MA(LOW,5),2)+MA(LOW,5);
VARC:=POW(MA(HIGH,5),2)+MA(HIGH,5);
VARD:=(VARA-LLV(VARB,64))/(HHV(VARC,64)-LLV(VARB,64))*150+65-10;
VARE:=SMA(VARD,3,1)*1.5-100; VARF:=SMA(VARE,3,1);
VAR30:=3*VARE-2*VARF;VAR31:=(HIGH+LOW+CLOSE*2)/4;
VAR32:=EMA(VAR31,13);
VAR33:=STD(VAR31,13);
VAR34:=(VAR31-VAR32)*100/ VAR33;
VAR35:=EMA(VAR34,5);
VAR37:=EMA(VAR35,13)+200-100;
VAR38:=EMA(VAR37,10);
VAR39:=3*VAR37-2*VAR38;
VAR1A:=VAR22+VAR27+VARE+VAR37;
VAR1B:=VAR23+VAR28+VARF+VAR38;
VAR1C:=VAR24+VAR29+VAR30+VAR39;
VAR1D:=(HIGH+LOW+CLOSE)/3;
VAR40:=(VAR1D-MA(VAR1D,34))/(0.015*AVEDEV(VAR1D,34));
VAR42:=(HIGH+LOW+CLOSE+VAR1D)/4;
VAR43:=EMA(VAR42,24);
VAR44:=STD(VAR42,24);
VAR45:=(VAR42-VAR43)/ VAR44*100;
VAR46:=(VAR1D-MA(VAR1D,24))/(0.015*AVEDEV(VAR1D,24));
VAR47:=EMA(VAR45,5);
VAR2A:=((VAR47+VAR46+VAR40)/3+165)/4;
VAR2C:=(VAR1A+VAR1B+VAR1C*30)/32/5-15;
VAR2E:=(VAR2A+VAR2C)/2/1.1;
VAR48:=EMA(VAR2E,3);
VAR49:=EMA(VAR48,5);
VAR51:=SMA(VAR48,2,1);
{为了规避风险,设定了VAR48>=VAR51进行处理}
日明:IF((VAR48>VAR51 OR VAR48=VAR51) ,明日重心涨跌幅,-99);
{-99表示已经在下跌趋势里};
---------------------------------------------------------------------------------------------------------------
{高山的流水----趋势排序指标;预测明涨跌幅,大智慧2号版本}
{60分钟周期使用}
X00:=C;
MX000:=(0.3609454219*X00-0.03309329629*REF(X00,1)-0.04241822779*REF(X00,2)-0.026737249*REF(X00,3)-0.007010041271*REF(X00,4)-0.002652859952*REF(X00,5)-0.0008415042966*REF(X00,6)-0.0002891931964*REF(X00,7)-0.0000956265934*REF(X00,8)-0.0000321286052*REF(X00,9)-0.0000106773454*REF(X00,10)-0.0000035457562*REF(X00,11)-0.0000011670713*REF(X00,12) )/ (1-0.7522406533 );
明日重心涨跌幅:=(MX000-X00)/X00*100;
{波段趋势}
VAR21:=(CLOSE-LLV(LOW,80))/(HHV(HIGH,80)-LLV(LOW,80))*200;
VAR22:=SMA(VAR21,3,1);VAR23:=SMA(VAR22,3,1);
VAR24:=3*VAR22-2*VAR23;VAR25:=LLV(LOW,5);VAR26:=HHV(HIGH,5);
VAR27:=EMA((CLOSE-VAR25)/(VAR26-VAR25)*100,4)*2;
VAR28:=EMA(0.667*REF(VAR27,1)+0.333*VAR27,2); VAR29:=3*VAR27-2*VAR28;
VARA:=POW(MA(CLOSE,5),2)+MA(CLOSE,5);
VARB:=POW(MA(LOW,5),2)+MA(LOW,5);
VARC:=POW(MA(HIGH,5),2)+MA(HIGH,5);
VARD:=(VARA-LLV(VARB,64))/(HHV(VARC,64)-LLV(VARB,64))*150+65-10;
VARE:=SMA(VARD,3,1)*1.5-100; VARF:=SMA(VARE,3,1);
VAR30:=3*VARE-2*VARF;VAR31:=(HIGH+LOW+CLOSE*2)/4;
VAR32:=EMA(VAR31,13);
VAR33:=STD(VAR31,13);
VAR34:=(VAR31-VAR32)*100/ VAR33;
VAR35:=EMA(VAR34,5);
VAR37:=EMA(VAR35,13)+200-100;
VAR38:=EMA(VAR37,10);
VAR39:=3*VAR37-2*VAR38;
VAR1A:=VAR22+VAR27+VARE+VAR37;
VAR1B:=VAR23+VAR28+VARF+VAR38;
VAR1C:=VAR24+VAR29+VAR30+VAR39;
VAR1D:=(HIGH+LOW+CLOSE)/3;
VAR40:=(VAR1D-MA(VAR1D,34))/(0.015*AVEDEV(VAR1D,34));
VAR42:=(HIGH+LOW+CLOSE+VAR1D)/4;
VAR43:=EMA(VAR42,24);
VAR44:=STD(VAR42,24);
VAR45:=(VAR42-VAR43)/ VAR44*100;
VAR46:=(VAR1D-MA(VAR1D,24))/(0.015*AVEDEV(VAR1D,24));
VAR47:=EMA(VAR45,5);
VAR2A:=((VAR47+VAR46+VAR40)/3+165)/4;
VAR2C:=(VAR1A+VAR1B+VAR1C*30)/32/5-15;
VAR2E:=(VAR2A+VAR2C)/2/1.1;
VAR48:=EMA(VAR2E,3);
VAR49:=EMA(VAR48,5);
VAR51:=SMA(VAR48,2,1);
{为了规避风险,设定了VAR48>=VAR51进行处理}
六十明:IF((VAR48>VAR51 OR VAR48=VAR51) ,明日重心涨跌幅,-99);
{-99表示为已经在下跌趋势里};
可以结合量,KDJ;最好周、日、60分钟的排序都是正数;60分钟排序靠前的、日的正数也是不低的,周的正数也是不低的;这差不多是个不同周期的共振原理;
盘中直接抓热点和强势股;

必须设定周期!!!不然,60分钟、日、周、排序数据都会一样------这样就会搞错的哦;
搞好后,要刷新计算;
该排序抓强壮轿夫方法,不会输于任何涨停板公式;
我们不但希望要涨停,还希望要天天涨个不停;
该排序指标的另一个用法:也可以用于盘中找最强的板块,进入板块后,按排序立即找到板块里最强势的股;
 该排序指标的核心就是那组奇怪的带很多小数的数列;该数列来源于东方的3的从中间向两侧统计法通过不断压栈微分逼近的手段再由金港先生经过推演换算而成;该数列其实和微积分有异曲同工之妙;该数列能够非常快速敏捷地追随股价、同时又对波形锯齿有一定的修波功能;还带有一定程度上的预测功能;
该排序指标里不含未来函数 XMA这个统计法里面统计理念的确比均线先进,从中间向两侧统计,但是它有个致命的缺点就是漂移;我对XMA的研究只突破到9,而且9里面只是搞到9.1;后面的13、29我尝试了很多次不断地完善数学模型,都无法最终突破,原因主要是通达信的股软程序语言连BASIC都不如;打个比方吧:想找个开平方的函数是有现成的,想找个开3次方、开5次方的函数找不到,想找其他东西代替,精度却达不到要求,没办法,没有合适的函数,表达不出来;如果通达信开放C语言编程?有些意图就好表达些;有些东西搞到那里后就只好搁置了。。。。。。。;
现在用3推导出来的,灵敏性是好的,就是稳定性欠佳(摆动度偏大);如果能搞到13、29?把3、5、9、13、29组成一个共振模式搞到各周期里去,就会既有灵敏性又有稳定性;再采用周、日、60分钟不同周期共振原理,找到产生强共振的票,估计比现在的方式的效果至少还能还能提高一个数量级以上;
除了XMA以外,也许还有其他更先进的统计理念???不过,这些都需要人们去探索。。。。。。。。。
------------------------------------------------------------------------------------------------------------------------------------------------
----------------------------------------------------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------------------------------------------------
{指标名:周明}
{高山的流水----趋势排序指标;预测明涨跌幅,飞狐、大智慧通用的2号版本}
{说明:高山排序周周期使用}
X00:=C;
MX000:=(0.3609454219*X00-0.03309329629*REF(X00,1)-0.04241822779*REF(X00,2)-0.026737249*REF(X00,3)-0.007010041271*REF(X00,4)-0.002652859952*REF(X00,5)-0.0008415042966*REF(X00,6)-0.0002891931964*REF(X00,7)-0.0000956265934*REF(X00,8)-0.0000321286052*REF(X00,9)-0.0000106773454*REF(X00,10)-0.0000035457562*REF(X00,11)-0.0000011670713*REF(X00,12) )/ (1-0.7522406533 );
明日重心涨跌幅:=(MX000-X00)/X00*100;
{波段趋势}
VAR21:=(CLOSE-LLV(LOW,80))/(HHV(HIGH,80)-LLV(LOW,80))*200;
VAR22:=SMA(VAR21,3,1);VAR23:=SMA(VAR22,3,1);
VAR24:=3*VAR22-2*VAR23;VAR25:=LLV(LOW,5);VAR26:=HHV(HIGH,5);
VAR27:=EMA((CLOSE-VAR25)/(VAR26-VAR25)*100,4)*2;
VAR28:=EMA(0.667*REF(VAR27,1)+0.333*VAR27,2); VAR29:=3*VAR27-2*VAR28;
VARA:=POW(MA(CLOSE,5),2)+MA(CLOSE,5);
VARB:=POW(MA(LOW,5),2)+MA(LOW,5);
VARC:=POW(MA(HIGH,5),2)+MA(HIGH,5);
VARD:=(VARA-LLV(VARB,64))/(HHV(VARC,64)-LLV(VARB,64))*150+65-10;
VARE:=SMA(VARD,3,1)*1.5-100; VARF:=SMA(VARE,3,1);
VAR30:=3*VARE-2*VARF;VAR31:=(HIGH+LOW+CLOSE*2)/4;
VAR32:=EMA(VAR31,13);
VAR33:=STD(VAR31,13);
VAR34:=(VAR31-VAR32)*100/ VAR33;
VAR35:=EMA(VAR34,5);
VAR37:=EMA(VAR35,13)+200-100;
VAR38:=EMA(VAR37,10);
VAR39:=3*VAR37-2*VAR38;
VAR1A:=VAR22+VAR27+VARE+VAR37;
VAR1B:=VAR23+VAR28+VARF+VAR38;
VAR1C:=VAR24+VAR29+VAR30+VAR39;
VAR1D:=(HIGH+LOW+CLOSE)/3;
VAR40:=(VAR1D-MA(VAR1D,34))/(0.015*AVEDEV(VAR1D,34));
VAR42:=(HIGH+LOW+CLOSE+VAR1D)/4;
VAR43:=EMA(VAR42,24);
VAR44:=STD(VAR42,24);
VAR45:=(VAR42-VAR43)/ VAR44*100;
VAR46:=(VAR1D-MA(VAR1D,24))/(0.015*AVEDEV(VAR1D,24));
VAR47:=EMA(VAR45,5);
VAR2A:=((VAR47+VAR46+VAR40)/3+165)/4;
VAR2C:=(VAR1A+VAR1B+VAR1C*30)/32/5-15;
VAR2E:=(VAR2A+VAR2C)/2/1.1;
VAR48:=EMA(VAR2E,3);
VAR49:=EMA(VAR48,5);
VAR51:=SMA(VAR48,2,1);
{为了规避风险,设定了VAR48>=VAR51进行处理}
周明:IF((VAR48>VAR51 OR VAR48=VAR51) ,明日重心涨跌幅,-99);
{-99表示为已经在下跌趋势里};
-----------------------------------------------------------------------------------------------------------------------------------------------------
-------------------------------------------------------------------------------------------------------------------------------------------------------
{指标名:日明}
{高山的流水----趋势排序指标;预测明涨跌幅,飞狐、大智慧通用的2号版本}
{说明:高山排序日周期使用}
X00:=C;
MX000:=(0.3609454219*X00-0.03309329629*REF(X00,1)-0.04241822779*REF(X00,2)-0.026737249*REF(X00,3)-0.007010041271*REF(X00,4)-0.002652859952*REF(X00,5)-0.0008415042966*REF(X00,6)-0.0002891931964*REF(X00,7)-0.0000956265934*REF(X00,8)-0.0000321286052*REF(X00,9)-0.0000106773454*REF(X00,10)-0.0000035457562*REF(X00,11)-0.0000011670713*REF(X00,12) )/ (1-0.7522406533 );
明日重心涨跌幅:=(MX000-X00)/X00*100;
{波段趋势}
VAR21:=(CLOSE-LLV(LOW,80))/(HHV(HIGH,80)-LLV(LOW,80))*200;
VAR22:=SMA(VAR21,3,1);VAR23:=SMA(VAR22,3,1);
VAR24:=3*VAR22-2*VAR23;VAR25:=LLV(LOW,5);VAR26:=HHV(HIGH,5);
VAR27:=EMA((CLOSE-VAR25)/(VAR26-VAR25)*100,4)*2;
VAR28:=EMA(0.667*REF(VAR27,1)+0.333*VAR27,2); VAR29:=3*VAR27-2*VAR28;
VARA:=POW(MA(CLOSE,5),2)+MA(CLOSE,5);
VARB:=POW(MA(LOW,5),2)+MA(LOW,5);
VARC:=POW(MA(HIGH,5),2)+MA(HIGH,5);
VARD:=(VARA-LLV(VARB,64))/(HHV(VARC,64)-LLV(VARB,64))*150+65-10;
VARE:=SMA(VARD,3,1)*1.5-100; VARF:=SMA(VARE,3,1);
VAR30:=3*VARE-2*VARF;VAR31:=(HIGH+LOW+CLOSE*2)/4;
VAR32:=EMA(VAR31,13);
VAR33:=STD(VAR31,13);
VAR34:=(VAR31-VAR32)*100/ VAR33;
VAR35:=EMA(VAR34,5);
VAR37:=EMA(VAR35,13)+200-100;
VAR38:=EMA(VAR37,10);
VAR39:=3*VAR37-2*VAR38;
VAR1A:=VAR22+VAR27+VARE+VAR37;
VAR1B:=VAR23+VAR28+VARF+VAR38;
VAR1C:=VAR24+VAR29+VAR30+VAR39;
VAR1D:=(HIGH+LOW+CLOSE)/3;
VAR40:=(VAR1D-MA(VAR1D,34))/(0.015*AVEDEV(VAR1D,34));
VAR42:=(HIGH+LOW+CLOSE+VAR1D)/4;
VAR43:=EMA(VAR42,24);
VAR44:=STD(VAR42,24);
VAR45:=(VAR42-VAR43)/ VAR44*100;
VAR46:=(VAR1D-MA(VAR1D,24))/(0.015*AVEDEV(VAR1D,24));
VAR47:=EMA(VAR45,5);
VAR2A:=((VAR47+VAR46+VAR40)/3+165)/4;
VAR2C:=(VAR1A+VAR1B+VAR1C*30)/32/5-15;
VAR2E:=(VAR2A+VAR2C)/2/1.1;
VAR48:=EMA(VAR2E,3);
VAR49:=EMA(VAR48,5);
VAR51:=SMA(VAR48,2,1);
{为了规避风险,设定了VAR48>=VAR51进行处理}
日明:IF((VAR48>VAR51 OR VAR48=VAR51) ,明日重心涨跌幅,-99);
{-99表示为已经在下跌趋势里};
-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
{指标名:六十明}
{高山的流水----趋势排序指标;预测明涨跌幅,飞狐、大智慧通用的2号版本}
{说明:高山排序60分钟周期使用}
X00:=C;
MX000:=(0.3609454219*X00-0.03309329629*REF(X00,1)-0.04241822779*REF(X00,2)-0.026737249*REF(X00,3)-0.007010041271*REF(X00,4)-0.002652859952*REF(X00,5)-0.0008415042966*REF(X00,6)-0.0002891931964*REF(X00,7)-0.0000956265934*REF(X00,8)-0.0000321286052*REF(X00,9)-0.0000106773454*REF(X00,10)-0.0000035457562*REF(X00,11)-0.0000011670713*REF(X00,12) )/ (1-0.7522406533 );
明日重心涨跌幅:=(MX000-X00)/X00*100;
{波段趋势}
VAR21:=(CLOSE-LLV(LOW,80))/(HHV(HIGH,80)-LLV(LOW,80))*200;
VAR22:=SMA(VAR21,3,1);VAR23:=SMA(VAR22,3,1);
VAR24:=3*VAR22-2*VAR23;VAR25:=LLV(LOW,5);VAR26:=HHV(HIGH,5);
VAR27:=EMA((CLOSE-VAR25)/(VAR26-VAR25)*100,4)*2;
VAR28:=EMA(0.667*REF(VAR27,1)+0.333*VAR27,2); VAR29:=3*VAR27-2*VAR28;
VARA:=POW(MA(CLOSE,5),2)+MA(CLOSE,5);
VARB:=POW(MA(LOW,5),2)+MA(LOW,5);
VARC:=POW(MA(HIGH,5),2)+MA(HIGH,5);
VARD:=(VARA-LLV(VARB,64))/(HHV(VARC,64)-LLV(VARB,64))*150+65-10;
VARE:=SMA(VARD,3,1)*1.5-100; VARF:=SMA(VARE,3,1);
VAR30:=3*VARE-2*VARF;VAR31:=(HIGH+LOW+CLOSE*2)/4;
VAR32:=EMA(VAR31,13);
VAR33:=STD(VAR31,13);
VAR34:=(VAR31-VAR32)*100/ VAR33;
VAR35:=EMA(VAR34,5);
VAR37:=EMA(VAR35,13)+200-100;
VAR38:=EMA(VAR37,10);
VAR39:=3*VAR37-2*VAR38;
VAR1A:=VAR22+VAR27+VARE+VAR37;
VAR1B:=VAR23+VAR28+VARF+VAR38;
VAR1C:=VAR24+VAR29+VAR30+VAR39;
VAR1D:=(HIGH+LOW+CLOSE)/3;
VAR40:=(VAR1D-MA(VAR1D,34))/(0.015*AVEDEV(VAR1D,34));
VAR42:=(HIGH+LOW+CLOSE+VAR1D)/4;
VAR43:=EMA(VAR42,24);
VAR44:=STD(VAR42,24);
VAR45:=(VAR42-VAR43)/ VAR44*100;
VAR46:=(VAR1D-MA(VAR1D,24))/(0.015*AVEDEV(VAR1D,24));
VAR47:=EMA(VAR45,5);
VAR2A:=((VAR47+VAR46+VAR40)/3+165)/4;
VAR2C:=(VAR1A+VAR1B+VAR1C*30)/32/5-15;
VAR2E:=(VAR2A+VAR2C)/2/1.1;
VAR48:=EMA(VAR2E,3);
VAR49:=EMA(VAR48,5);
VAR51:=SMA(VAR48,2,1);
{为了规避风险,设定了VAR48>=VAR51进行处理}
六十明:IF((VAR48>VAR51 OR VAR48=VAR51) ,明日重心涨跌幅,-99);
{-99表示为已经在下跌趋势里};
--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
{指标名:三十明}
{高山的流水----趋势排序指标;预测明涨跌幅,飞狐、大智慧通用的2号版本}
{说明:高山排序30分钟周期使用}
X00:=C;
MX000:=(0.3609454219*X00-0.03309329629*REF(X00,1)-0.04241822779*REF(X00,2)-0.026737249*REF(X00,3)-0.007010041271*REF(X00,4)-0.002652859952*REF(X00,5)-0.0008415042966*REF(X00,6)-0.0002891931964*REF(X00,7)-0.0000956265934*REF(X00,8)-0.0000321286052*REF(X00,9)-0.0000106773454*REF(X00,10)-0.0000035457562*REF(X00,11)-0.0000011670713*REF(X00,12) )/ (1-0.7522406533 );
明日重心涨跌幅:=(MX000-X00)/X00*100;
{波段趋势}
VAR21:=(CLOSE-LLV(LOW,80))/(HHV(HIGH,80)-LLV(LOW,80))*200;
VAR22:=SMA(VAR21,3,1);VAR23:=SMA(VAR22,3,1);
VAR24:=3*VAR22-2*VAR23;VAR25:=LLV(LOW,5);VAR26:=HHV(HIGH,5);
VAR27:=EMA((CLOSE-VAR25)/(VAR26-VAR25)*100,4)*2;
VAR28:=EMA(0.667*REF(VAR27,1)+0.333*VAR27,2); VAR29:=3*VAR27-2*VAR28;
VARA:=POW(MA(CLOSE,5),2)+MA(CLOSE,5);
VARB:=POW(MA(LOW,5),2)+MA(LOW,5);
VARC:=POW(MA(HIGH,5),2)+MA(HIGH,5);
VARD:=(VARA-LLV(VARB,64))/(HHV(VARC,64)-LLV(VARB,64))*150+65-10;
VARE:=SMA(VARD,3,1)*1.5-100; VARF:=SMA(VARE,3,1);
VAR30:=3*VARE-2*VARF;VAR31:=(HIGH+LOW+CLOSE*2)/4;
VAR32:=EMA(VAR31,13);
VAR33:=STD(VAR31,13);
VAR34:=(VAR31-VAR32)*100/ VAR33;
VAR35:=EMA(VAR34,5);
VAR37:=EMA(VAR35,13)+200-100;
VAR38:=EMA(VAR37,10);
VAR39:=3*VAR37-2*VAR38;
VAR1A:=VAR22+VAR27+VARE+VAR37;
VAR1B:=VAR23+VAR28+VARF+VAR38;
VAR1C:=VAR24+VAR29+VAR30+VAR39;
VAR1D:=(HIGH+LOW+CLOSE)/3;
VAR40:=(VAR1D-MA(VAR1D,34))/(0.015*AVEDEV(VAR1D,34));
VAR42:=(HIGH+LOW+CLOSE+VAR1D)/4;
VAR43:=EMA(VAR42,24);
VAR44:=STD(VAR42,24);
VAR45:=(VAR42-VAR43)/ VAR44*100;
VAR46:=(VAR1D-MA(VAR1D,24))/(0.015*AVEDEV(VAR1D,24));
VAR47:=EMA(VAR45,5);
VAR2A:=((VAR47+VAR46+VAR40)/3+165)/4;
VAR2C:=(VAR1A+VAR1B+VAR1C*30)/32/5-15;
VAR2E:=(VAR2A+VAR2C)/2/1.1;
VAR48:=EMA(VAR2E,3);
VAR49:=EMA(VAR48,5);
VAR51:=SMA(VAR48,2,1);
{为了规避风险,设定了VAR48>=VAR51进行处理}
三十明:IF((VAR48>VAR51 OR VAR48=VAR51) ,明日重心涨跌幅,-99);
{-99表示为已经在下跌趋势里};


 


{指标名:十五明}
{高山的流水----趋势排序指标;预测明涨跌幅,飞狐、大智慧通用的2号版本}
{说明:高山排序15分钟周期使用}
X00:=C;
MX000:=(0.3609454219*X00-0.03309329629*REF(X00,1)-0.04241822779*REF(X00,2)-0.026737249*REF(X00,3)-0.007010041271*REF(X00,4)-0.002652859952*REF(X00,5)-0.0008415042966*REF(X00,6)-0.0002891931964*REF(X00,7)-0.0000956265934*REF(X00,8)-0.0000321286052*REF(X00,9)-0.0000106773454*REF(X00,10)-0.0000035457562*REF(X00,11)-0.0000011670713*REF(X00,12) )/ (1-0.7522406533 );
明日重心涨跌幅:=(MX000-X00)/X00*100;
{波段趋势}
VAR21:=(CLOSE-LLV(LOW,80))/(HHV(HIGH,80)-LLV(LOW,80))*200;
VAR22:=SMA(VAR21,3,1);VAR23:=SMA(VAR22,3,1);
VAR24:=3*VAR22-2*VAR23;VAR25:=LLV(LOW,5);VAR26:=HHV(HIGH,5);
VAR27:=EMA((CLOSE-VAR25)/(VAR26-VAR25)*100,4)*2;
VAR28:=EMA(0.667*REF(VAR27,1)+0.333*VAR27,2); VAR29:=3*VAR27-2*VAR28;
VARA:=POW(MA(CLOSE,5),2)+MA(CLOSE,5);
VARB:=POW(MA(LOW,5),2)+MA(LOW,5);
VARC:=POW(MA(HIGH,5),2)+MA(HIGH,5);
VARD:=(VARA-LLV(VARB,64))/(HHV(VARC,64)-LLV(VARB,64))*150+65-10;
VARE:=SMA(VARD,3,1)*1.5-100; VARF:=SMA(VARE,3,1);
VAR30:=3*VARE-2*VARF;VAR31:=(HIGH+LOW+CLOSE*2)/4;
VAR32:=EMA(VAR31,13);
VAR33:=STD(VAR31,13);
VAR34:=(VAR31-VAR32)*100/ VAR33;
VAR35:=EMA(VAR34,5);
VAR37:=EMA(VAR35,13)+200-100;
VAR38:=EMA(VAR37,10);
VAR39:=3*VAR37-2*VAR38;
VAR1A:=VAR22+VAR27+VARE+VAR37;
VAR1B:=VAR23+VAR28+VARF+VAR38;
VAR1C:=VAR24+VAR29+VAR30+VAR39;
VAR1D:=(HIGH+LOW+CLOSE)/3;
VAR40:=(VAR1D-MA(VAR1D,34))/(0.015*AVEDEV(VAR1D,34));
VAR42:=(HIGH+LOW+CLOSE+VAR1D)/4;
VAR43:=EMA(VAR42,24);
VAR44:=STD(VAR42,24);
VAR45:=(VAR42-VAR43)/ VAR44*100;
VAR46:=(VAR1D-MA(VAR1D,24))/(0.015*AVEDEV(VAR1D,24));
VAR47:=EMA(VAR45,5);
VAR2A:=((VAR47+VAR46+VAR40)/3+165)/4;
VAR2C:=(VAR1A+VAR1B+VAR1C*30)/32/5-15;
VAR2E:=(VAR2A+VAR2C)/2/1.1;
VAR48:=EMA(VAR2E,3);
VAR49:=EMA(VAR48,5);
VAR51:=SMA(VAR48,2,1);
{为了规避风险,设定了VAR48>=VAR51进行处理}
十五明:IF((VAR48>VAR51 OR VAR48=VAR51) ,明日重心涨跌幅,-99);
{-99表示为已经在下跌趋势里};
-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
{指标名:五明}
{高山的流水----趋势排序指标;预测明涨跌幅,飞狐、大智慧通用的2号版本}
{说明:高山排序5分钟周期使用}
X00:=C;
MX000:=(0.3609454219*X00-0.03309329629*REF(X00,1)-0.04241822779*REF(X00,2)-0.026737249*REF(X00,3)-0.007010041271*REF(X00,4)-0.002652859952*REF(X00,5)-0.0008415042966*REF(X00,6)-0.0002891931964*REF(X00,7)-0.0000956265934*REF(X00,8)-0.0000321286052*REF(X00,9)-0.0000106773454*REF(X00,10)-0.0000035457562*REF(X00,11)-0.0000011670713*REF(X00,12) )/ (1-0.7522406533 );
明日重心涨跌幅:=(MX000-X00)/X00*100;
{波段趋势}
VAR21:=(CLOSE-LLV(LOW,80))/(HHV(HIGH,80)-LLV(LOW,80))*200;
VAR22:=SMA(VAR21,3,1);VAR23:=SMA(VAR22,3,1);
VAR24:=3*VAR22-2*VAR23;VAR25:=LLV(LOW,5);VAR26:=HHV(HIGH,5);
VAR27:=EMA((CLOSE-VAR25)/(VAR26-VAR25)*100,4)*2;
VAR28:=EMA(0.667*REF(VAR27,1)+0.333*VAR27,2); VAR29:=3*VAR27-2*VAR28;
VARA:=POW(MA(CLOSE,5),2)+MA(CLOSE,5);
VARB:=POW(MA(LOW,5),2)+MA(LOW,5);
VARC:=POW(MA(HIGH,5),2)+MA(HIGH,5);
VARD:=(VARA-LLV(VARB,64))/(HHV(VARC,64)-LLV(VARB,64))*150+65-10;
VARE:=SMA(VARD,3,1)*1.5-100; VARF:=SMA(VARE,3,1);
VAR30:=3*VARE-2*VARF;VAR31:=(HIGH+LOW+CLOSE*2)/4;
VAR32:=EMA(VAR31,13);
VAR33:=STD(VAR31,13);
VAR34:=(VAR31-VAR32)*100/ VAR33;
VAR35:=EMA(VAR34,5);
VAR37:=EMA(VAR35,13)+200-100;
VAR38:=EMA(VAR37,10);
VAR39:=3*VAR37-2*VAR38;
VAR1A:=VAR22+VAR27+VARE+VAR37;
VAR1B:=VAR23+VAR28+VARF+VAR38;
VAR1C:=VAR24+VAR29+VAR30+VAR39;
VAR1D:=(HIGH+LOW+CLOSE)/3;
VAR40:=(VAR1D-MA(VAR1D,34))/(0.015*AVEDEV(VAR1D,34));
VAR42:=(HIGH+LOW+CLOSE+VAR1D)/4;
VAR43:=EMA(VAR42,24);
VAR44:=STD(VAR42,24);
VAR45:=(VAR42-VAR43)/ VAR44*100;
VAR46:=(VAR1D-MA(VAR1D,24))/(0.015*AVEDEV(VAR1D,24));
VAR47:=EMA(VAR45,5);
VAR2A:=((VAR47+VAR46+VAR40)/3+165)/4;
VAR2C:=(VAR1A+VAR1B+VAR1C*30)/32/5-15;
VAR2E:=(VAR2A+VAR2C)/2/1.1;
VAR48:=EMA(VAR2E,3);
VAR49:=EMA(VAR48,5);
VAR51:=SMA(VAR48,2,1);
{为了规避风险,设定了VAR48>=VAR51进行处理}
五明:IF((VAR48>VAR51 OR VAR48=VAR51) ,明日重心涨跌幅,-99);
{-99表示为已经在下跌趋势里};
关于那组数列、如何由金港先生的17循环数列推演过来?
X00:=C;
X01:=0.7522406533*X00+0.3609454219*REF(X00,1)-0.03309329629*REF(X00,2)-0.04241822779*REF(X00,3)-0.026737249*REF(X00,4)-0.007010041271*REF(X00,5)-0.002652859952*REF(X00,6)-0.0008415042966*REF(X00,7)-0.0002891931964*REF(X00,8)-0.0000956265934*REF(X00,9)-0.0000321286052*REF(X00,10)-0.0000106773454*REF(X00,11)-0.0000035457562*REF(X00,12)-0.0000011670713*REF(X00,13);
这组数列就是来源于东方的3的从中间向两侧统计法通过不断压栈微分逼近的手段再由金港先生经过推演换算而成;从理想论坛过去我所发的帖子里和土港金著先生在理想所发的帖子里能找到它的来源;
X01相当于今日股价重心;除了拐点处稍有差异外,其他地方和股价运动真实的情况基本相同,这个等式是基本成立的;也就是说今日股价重心由今日及过去的共计13日的价格有关系,并呈现这种数列关系;直到拐点处才会产生变异;
那么明日的股价重心,在拐点还未来临之前,按理----也应该由明日价和向前的12天(共计13天)的价格有关系,并呈现这种数列关系;直到拐点处才会产生变异;
在预测时候会有两个未知的变量:X01(明日股价重心)、X00(明日价)
只有一个方程,不构成方程组,有两个变量,我们是无法求出的;
如果明天是涨的?X00(明日价)>=X01(明日股价重心);
如果明天是跌的?X00(明日价)<=X01(明日股价重心);
为了求出,我大胆先假设它们,在求出后再分离它们:令:X00=X01;
这样,就很快求出了。。。。。。。
这个是深市在拉尾盘的,通过5分钟周期刷新就能看出;尤其南京中北拉的厉害些;

以上源码适合大智慧和飞狐-----可以盘中动态刷新来排序,你的股软----最好是数据全推;
排序前需刷新计算,因为盘中数据是动态的;
如果你的电脑计算速度不快?或者网速不快?或者没买全推数据?你就拖动窗口、每个周期多刷几下吧;
如果你们自己有兴趣?也可以再添加15分钟周期和5分钟周期的排序,监控盘中异动股;
那些小量比的涨停,表示是缩量涨停,下个交易日接着涨的概率极大;
以上源码也适合通达信使用,但是由于通达信历史行情排序,只能日周期使用,分时周期用不上,没分时数据;而且数据要靠请求发送方式,通达信速度极慢,不建议通达信盘中使用;
大智慧要看版本,有些全推版本是假全推版本,只有日周期数据是全推,分时数据不是全推,对于这样的、刷分时有些困难;
飞狐也可以刷

该排序方法,最好结合GSCD,结合量、KDJ等指标;
用GSCD来看大盘,日周期级别,如果DIF在DEA1之上运行,且DEA1在DEA2之上运行?表明大盘趋势向上,你尽管运用该排序指标抓强势股,将会获得不菲的收益;
不符合以上大盘条件的?小心使用;因为大盘不好的时候,你上午买进去是涨的,下午却给你来个大跌,主力有诱多嫌疑;
这其实和抓涨停板是一回事,大盘不好,你用涨停板公式去抓也容易挨套;大盘不好,你用任何公式成功率都容易大大降低;
有些在大盘大跌的时候,市场上个别的热点可能会另类:
比如:这几天和今天热炒的触摸屏题材:
300088 长信科技
000823 超声电子
002106 莱宝高科
这类股、今天受市场资金的关照多些,显得很强势;
去年在当时的大盘大跌的情况下,也有过熊猫烟花、黔轮胎、双钱股份逆势上涨,成为当时的牛股;
这些,也要结合题材、热点、基本面等综合判断;
炒股------绝不是简简单单只依靠技术面就可以了,还要结合基本面、题材、热点等综合判断;
排序方法只是给大家提供了一个参考手段方法而已,不可神话它。。。。。。。。。;
另外,举个例子吧:从9月底开始的南方重稀土的炒作(600259/000758/600549)——————》转到稀土永磁深加工(中科三环,太原刚玉、宁波韵升等)、---------》再转到商务部公布明年部分稀有金属出口配额文件确定的配额限制金属:钨、锡、锑、钼和铟----先启动钨(厦门钨业、章源钨业)、又启动钼(金钼股份)、。。。。。。
市场资金追捧炒作的次序很有意思哦;暂时没有被超炒的,就差哪个资金大佬去点把火就够了,获得市场认同的概率极大;
不管大家运用什么方法?能够抓住涨速较快的股,乘机坐上去被资金抬轿抬上一段,总是非常舒服的感觉;
以上源码也适合通达信使用,但是由于通达信历史行情排序,只能日周期使用,分时周期用不上,没分时数据;而且数据要靠请求发送方式,通达信速度极慢,不建议通达信盘中使用;
可以刷日周期,就是刷起来很麻烦,速度慢;


好股票软件下载网(www.goodgupiao.com)提醒您:股市有风险,投资需谨慎。
高山的流水----趋势排序指标;预测明涨跌幅,大智慧2号版本下载地址
相关说明
  • 好股票软件下载网欢迎用户将网页内容和下载地址转发到博客、微博、论坛等。
  • 发布的公式指标绝大部分是来源于各大论坛,谢谢各位老师的原创指标。
  • 判断公式指标好坏,请用户参考用户评论或者软件好评度
  • alg格式股票公式,仅仅可以用飞狐交易师股票软件引入使用;
  • fnc格式股票公式,可以用大智慧新一代高速行情分析系统股票软件使用,少部分可以用分析家股票软件引入使用;
  • exp格式股票公式,仅可以用大智慧经典版股票软件引入使用;
  • tnctni格式股票公式,仅可以用通达信新引入使用,例如可以用通达信股票软件引入使用;
  • tne格式公式,仅可以用通达信公式编辑器5.0版导入,高版本兼容低版本;
  • hxf格式股票公式,仅可以用同花顺股票软件引入使用。
  • 如果引入公式的时候,发现公式名称栏空白,调整电脑时间到1997年,能出现公式名称并正常显示,可能是公式使用期限已过。
  • 如果您发现下载链接错误,请点击报告错误谢谢!