好股票网每日提供最新股票软件下载,如果您觉得不错,麻烦推荐给您的好友,谢谢!
您现在的位置:好股票网 >> 股票公式 >> 通达信公式

通达信自用集成CCI指标

[下载地址]

好股票网经过测试可运行,该软件通过多款专业杀毒软件扫描

  • 360通过
  • 金山通过
  • 瑞星通过
  • 江民通过
  • 卡巴通过
  • 诺顿通过
  • 运行平台:Win7/Vista/WinXP/Win2003/
  • 公式语言:简体中文
  • 更新时间:2013-06-09 09:34:31
  • 公式评级:
  • 公式类型:通达信公式
  • 授权方式:共享版
  • 公式大小:0 Bytes
  • 解压密码:goodgupiao
  • 下载统计:
  • 相关Tags:CCI  
已有次下载
推 荐0
不推荐0

通达信自用集成CCI指标介绍

好股票软件下载网(www.goodgupiao.com)提示:您正在下载的是:通达信自用集成CCI指标

说明:
1、按照本人对CCI指标的理解,将CCI指标图表化;
2、集成了主力建仓、底部判断指标;
3、集成低买指标;
4、集成时间窗指标;
5、低买及起涨点提示
6、n(1,100,20),即n的取值为20



N:=20;
ZD1:=BACKSET(ISLASTBAR,150);
TYP:=(HIGH+LOW+CLOSE)/3;
CCI:=IF((TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14))<-100,-100,(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14))),COLORRED,LINETHICK1;
J1:IF(CCI<-100,-100,MA(CCI,1)),COLORGREEN,LINETHICK1;
IF(J1>=REF(J1,1),J1,DRAWNULL),COLORRED,LINETHICK2;

STICKLINE(CCI>=0 AND CCI>=100,CCI,0,2,0),COLORFF00FF;
STICKLINE(CCI>=0 AND CCI<100,CCI,0,2,0),COLORYELLOW;
STICKLINE(CCI>0 AND REF(CCI,1)<=0 AND CCI<100,CCI,0,2,0),COLORRED;

100,COLORFF00FF,LINETHICK1,DOTLINE;
{CCI起涨点}
J20下行:=BARSLAST(CROSS(MA(C,20),MA(C,5)))>=20;
起涨点:=EVERY(REF(CCI,1)<100,20) AND CROSS(CCI,100) AND J20下行;
STICKLINE(起涨点,CCI,0,2,1),,COLORYELLOW;
DRAWTEXT(起涨点,J1*1.02,'★←起涨'),COLORGREEN;

{时间窗-高点}
AA:=H=HHV(H,N);
高点日期:=IF(ZD1=1,BARSLAST(AA),DRAWNULL),COLORYELLOW;
DRAWTEXT(高点日期=2,-13,'3'),COLORYELLOW;
DRAWTEXT(高点日期=4,-13,'5'),COLORYELLOW;
DRAWTEXT(高点日期=7,-13,'8'),COLORYELLOW;
DRAWTEXT(高点日期=12,-13,'13'),COLORYELLOW;
DRAWTEXT(高点日期=20,-13,'21'),COLORYELLOW;
DRAWTEXT(高点日期=33,-13,'34'),COLORYELLOW;
DRAWTEXT(高点日期=54,-13,'55'),COLORYELLOW;
DRAWTEXT(高点日期=88,-13,'89'),COLORYELLOW;
DRAWTEXT(高点日期=143,-13,'144'),COLORYELLOW;
DRAWTEXT(高点日期=232,-13,'233'),COLORYELLOW;
DRAWTEXT(高点日期=376,-13,'377'),COLORYELLOW;


{主力建仓}
VAR1:=(CLOSE-LLV(LOW,100))/(HHV(HIGH,100)-LLV(LOW,100))*200;
VAR2:=SMA(VAR1,3,1);
VAR3:=SMA(VAR2,3,1);
VAR4:=3*VAR2-2*VAR3;
VAR5:=LLV(LOW,5);
VAR6:=HHV(HIGH,5);
VAR7:=EMA((CLOSE-VAR5)/(VAR6-VAR5)*100,4)*2;
VAR8:=EMA(0.667*REF(VAR7,1)+0.333*VAR7,2);
VAR9:=3*VAR7-2*VAR8;
VARA:=POW(MA(CLOSE,5),2)+MA(CLOSE,5);
VARB:=POW(MA(LOW,5),2)+MA(LOW,5);
VARC:=POW(MA(HIGH,5),2)+MA(HIGH,5);
VARD:=(VARA-LLV(VARB,64))/(HHV(VARC,64)-LLV(VARB,64))*150+65-10;
VARE:=SMA(VARD,3,1)*1.5-100;
VARF:=SMA(VARE,3,1);
VAR10:=3*VARE-2*VARF;
VAR11:=(HIGH+LOW+CLOSE*2)/4;
VAR12:=EMA(VAR11,13);
VAR13:=STD(VAR11,13);
VAR14:=(VAR11-VAR12)*100/VAR13;
VAR15:=EMA(VAR14,5);
VAR16:=EMA(VAR15,13);
VAR17:=EMA(VAR15,13)+200-100;
VAR18:=EMA(VAR17,10);
VAR19:=3*VAR17-2*VAR18;
VAR1A:=VAR2+VAR7+VARE+VAR17;
VAR1B:=VAR3+VAR8+VARF+VAR18;
VAR1C:=VAR4+VAR9+VAR10+VAR19;
VAR1D:=(HIGH+LOW+CLOSE)/3;
VAR1E:=AMOUNT/VOL/100;
VAR1F:=SUM(AMOUNT,5)/SUM(VOL,5)/100;
VAR20:=(VAR1D-MA(VAR1D,34))/(0.015*AVEDEV(VAR1D,34));
VAR21:=DMA(AMOUNT/VOL/100,VOL);
VAR22:=(HIGH+LOW+CLOSE+VAR1D)/4;
VAR23:=EMA(VAR22,24);
VAR24:=STD(VAR22,24);
VAR25:=(VAR22-VAR23)/VAR24*100;
VAR26:=(VAR1D-MA(VAR1D,24))/(0.015*AVEDEV(VAR1D,24));
VAR27:=EMA(VAR25,5);
VAR28:=(VAR1E-MA(VAR1E,21))/(0.015*AVEDEV(VAR1E,21));
VAR29:=(VAR1F-MA(VAR1F,90))/(0.015*AVEDEV(VAR1F,90));
VAR2A:=((VAR29+VAR28+VAR27+VAR26+VAR20)/5+165)/4;
VAR2B:=(EMA(EMA(EMA(VAR2A,15),10),5)-25)*2+VAR21;
VAR2C:=(VAR1A+VAR1B+VAR1C*30)/32/5-15;
VAR2E:=(VAR2A+VAR2C)/2/1.1;
(VAR2E<5 AND VAR2E>REF(VAR2E,1) AND REF(VAR2E,1)<0)*100,VOLSTICK;

VAR31:=(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100;
VAR32:=SMA(VAR31,3,1);
VAR33:=SMA(VAR32,3,1.2);
VAR34:=VOL/34;
VAR35:=REF(VAR34,1);
主建仓:(VAR33<8.5 AND VAR32<11)*80,LINETHICK2,COLOR00FF00;
大户转建:(VAR35>4 AND VAR35<4.2)*80,LINETHICK1,COLORYELLOW;
VAR1A0:=100*(C-(10))/(10);
VAR1W:=(CLOSE-LLV(LOW,28))/(HHV(HIGH,28)-LLV(LOW,28))*100;
VAR2W:=SMA(VAR1W,4,1);
VAR3W:=SMA(VAR2W,2,1);
VAR4W:=VOL/34;
VAR5W:=REF(VAR4W,1);
主力偷建:(IF(VAR3W<8.5 AND VAR2W<11,0.5,0))*100,COLORCC3299,LINETHICK1;


{低买}
J2:=EMA(C,2);
J18:=EMA(C,18);
买点:=IF(CROSS(J18,J2),5,10*1000),COLORFF00FF,LINETHICK2;
RSVV:=(CLOSE-LLV(LOW,10))/(HHV(HIGH,10)-LLV(LOW,10))*100;
VARB2:=(RSVV/2+22)*1;
Q:=EMA(VOL,13);
Y:=EMA(AMOUNT,13);
S:=((Y /Q) / 100);
X:=(((CLOSE -S) / S) * 100);
F:=((X < (0)) AND ZXNH);
XQ:=F AND RSVV<VARB2-2;
低买:=FILTER(买点 AND XQ,10);
IF(低买,188,0),COLORWHITE,LINETHICK1;

{时间窗-低点}
BB:=L=LLV(L,N);
低点日期:=IF(ZD1=1,BARSLAST(BB),DRAWNULL),COLORFF00FF;
DRAWTEXT(低点日期=2,-33,'3'),COLORFF00FF;
DRAWTEXT(低点日期=4,-33,'5'),COLORFF00FF;
DRAWTEXT(低点日期=7,-33,'8'),COLORFF00FF;
DRAWTEXT(低点日期=12,-33,'13'),COLORFF00FF;
DRAWTEXT(低点日期=20,-33,'21'),COLORFF00FF;
DRAWTEXT(低点日期=33,-33,'34'),COLORFF00FF;
DRAWTEXT(低点日期=54,-33,'55'),COLORFF00FF;
DRAWTEXT(低点日期=88,-33,'89'),COLORFF00FF;
DRAWTEXT(低点日期=143,-33,'144'),COLORFF00FF;
DRAWTEXT(低点日期=232,-33,'233'),COLORFF00FF;
DRAWTEXT(低点日期=376,-33,'377'),COLORFF00FF;

{低吸}
LC:=REF(CLOSE,1);
RSI:SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100,COLORGREEN,NODRAW;
低吸:=IF(CROSS(RSI,11),0.60,0)*100,COLORWHITE;
STICKLINE(低吸,0.7,60,4,0),COLORWHITE;



 


好股票软件下载网(www.goodgupiao.com)提醒您:股市有风险,投资需谨慎。
通达信自用集成CCI指标下载地址
相关说明
  • 好股票软件下载网欢迎用户将网页内容和下载地址转发到博客、微博、论坛等。
  • 发布的公式指标绝大部分是来源于各大论坛,谢谢各位老师的原创指标。
  • 判断公式指标好坏,请用户参考用户评论或者软件好评度
  • alg格式股票公式,仅仅可以用飞狐交易师股票软件引入使用;
  • fnc格式股票公式,可以用大智慧新一代高速行情分析系统股票软件使用,少部分可以用分析家股票软件引入使用;
  • exp格式股票公式,仅可以用大智慧经典版股票软件引入使用;
  • tnctni格式股票公式,仅可以用通达信新引入使用,例如可以用通达信股票软件引入使用;
  • tne格式公式,仅可以用通达信公式编辑器5.0版导入,高版本兼容低版本;
  • hxf格式股票公式,仅可以用同花顺股票软件引入使用。
  • 如果引入公式的时候,发现公式名称栏空白,调整电脑时间到1997年,能出现公式名称并正常显示,可能是公式使用期限已过。
  • 如果您发现下载链接错误,请点击报告错误谢谢!