好股票网每日提供最新股票软件下载,如果您觉得不错,麻烦推荐给您的好友,谢谢!
您现在的位置:好股票网 >> 股票公式 >> 通达信公式

通达信神笔马良主图指标公式

[下载地址]

好股票网经过测试可运行,该软件通过多款专业杀毒软件扫描

  • 360通过
  • 金山通过
  • 瑞星通过
  • 江民通过
  • 卡巴通过
  • 诺顿通过
  • 运行平台:Win7/Vista/WinXP/Win2003/
  • 公式语言:简体中文
  • 更新时间:2013-06-01 08:27:35
  • 公式评级:
  • 公式类型:通达信公式
  • 授权方式:共享版
  • 公式大小:0 Bytes
  • 解压密码:goodgupiao
  • 下载统计:
  • 相关Tags:
已有次下载
推 荐0
不推荐0

通达信神笔马良主图指标公式介绍

好股票软件下载网(www.goodgupiao.com)提示:您正在下载的是:通达信神笔马良主图指标公式

漂亮实用的主图--神笔马良。这是一个老公式了,欢迎大家使用。


神笔马良
VV:=(C+L+H)/3;
DSA:=SMA(EMA(VV,2),2,1)LINETHICK2,COLORRED;
Y396:=DSA;
险1:=Y396*1.1,COLORLIRED;
险2:=Y396*1.125,COLORLIRED;
险3:=Y396*1.15,COLORLIRED;
良1:=Y396*0.9,COLORLIBLUE;
良2:=Y396*0.875,COLORLIBLUE;
良3:=Y396*0.85,COLORLIBLUE;

变色:=IF(Y396<REF(Y396,1),Y396,DRAWNULL),LINETHICK2,COLORBLUE;
{WSR1:=(CLOSE-MA(CLOSE,5))/MA(CLOSE,5)*100;}
{WSR2:=CROSS(WSR1,5);}
{WSR3:=CROSS(8,WSR1);}
{WSR4:=CROSS(WSR1,-5);}
{WSR5:=CROSS(WSR1,-8);}
{WSR6:=WSR3;}
{WSR7:=WSR4 OR WSR5;}
{WSR8:=WSR7 AND FILTER(WSR7,5);}
{WSR10:DRAWICON(WSR8,L-0.01,1);}
{WSR9:=WSR6 AND FILTER(WSR6,5);}
{WSR11:DRAWICON(WSR9,H+0.01,2);}
WSR1:=(CLOSE-MA(CLOSE,5))/MA(CLOSE,5)*100;
WSR2:=CROSS(WSR1,5);
WSR3:=CROSS(8,WSR1);
WSR4:=CROSS(WSR1,-5);
WSR5:=CROSS(WSR1,-8);
WSR6:=WSR3;
WSR7:=WSR4 OR WSR5;
WSR8:=WSR7 AND FILTER(WSR7,5);
WSR10:DRAWICON(WSR8,L-0.01,1);
WSR9:=WSR6 AND FILTER(WSR6,5);
WSR11:DRAWICON(WSR9,H+0.01,2);
WSR12:=O<良3;
DRAWICON(WSR12 AND FILTER(WSR12,12),L-0.03,9);
W1:=C>REF(C,1) AND MACD<REF(MACD,1) AND MACD>0 AND V<REF(V,1);
W2:=C>REF(C,1) AND MACD<0 AND MACD<REF(MACD,1) AND V<REF(V,1);
XG:=W1 OR W2;
VAR1:=AMOUNT/VOL/7;
VAR2:=(3*HIGH+LOW+OPEN+2*CLOSE)/7;
VAR3:=SUM(AMOUNT,10)/VAR1/7;
VAR4:=DMA(VAR2,VOL/VAR3);
VAR5:=(CLOSE-VAR4)/VAR4*100,COLORLIMAGENTA;
XG1:=CROSS(VAR5,MA(VAR5,2)) AND VAR5<0 AND C<(HHV(H,5)*0.88) AND REF(O>C,1) AND REF(O>C,2);
XG3:=XG AND XG1 AND L<良1;
WSR13:=O>良3 AND L<良1 OR XG3;
DRAWICON(WSR13 AND FILTER(WSR13,10),L-0.03,5);
WSR14:=H>险3;DRAWICON(WSR14 AND FILTER(WSR14,15),H+0.03,6);
WSR15:=H<险3 AND H>险2;DRAWICON(WSR15 AND FILTER(WSR15,5),H+0.03,4);
WSR16:=(INDEXC-MA(INDEXC,3))/MA(INDEXC,3);
WSR17:=(INDEXC-MA(INDEXC,8))/MA(INDEXC,8);
WSR18:=(INDEXC-MA(INDEXC,18))/MA(INDEXC,18);
WSR19:=(WSR16 + WSR17 + WSR18)/3;
WSR20:=(C-MA(C,3))/MA(C,3);
WSR21:=(C-MA(C,8))/MA(C,8);
WSR22:=(C-MA(C,18))/MA(C,18);
WSR23:=(WSR20 + WSR21 + WSR22)/3;
WSR24:=(WSR19>REF(WSR19,1) AND CROSS(WSR23,WSR19))*50;
WSR25:=(INDEXC-MA(INDEXC,6))/MA(INDEXC,6);
WSR26:=(INDEXC-MA(INDEXC,12))/MA(INDEXC,12);
WSR27:=(INDEXC-MA(INDEXC,24))/MA(INDEXC,24);
WSR28:=(WSR25 + WSR26 + WSR27)/3;
WSR29:=(C-MA(C,6))/MA(C,6);
WSR30:=(C-MA(C,12))/MA(C,12);
WSR31:=(C-MA(C,24))/MA(C,24);
WSR32:=(WSR29 + WSR30 + WSR31)/3;
WSR33:=(WSR28>REF(WSR28,1) AND CROSS(WSR32,WSR28))*20;

WSR34:=(INDEXC-MA(INDEXC,13))/MA(INDEXC,13);
WSR35:=(INDEXC-MA(INDEXC,34))/MA(INDEXC,34);
WSR36:=(INDEXC-MA(INDEXC,55))/MA(INDEXC,55);
WSR37:=(WSR34 + WSR35 + WSR36)/3;
WSR38:=(C-MA(C,13))/MA(C,13);
WSR39:=(C-MA(C,34))/MA(C,34);
WSR40:=(C-MA(C,55))/MA(C,55);
WSR41:=(WSR38 + WSR39 + WSR40)/3;
WSR42:=(WSR37>REF(WSR37,1) AND CROSS(WSR41,WSR37));
WSR43:=(INDEXC-MA(INDEXC,13))/MA(INDEXC,13);
WSR44:=(INDEXC-MA(INDEXC,34))/MA(INDEXC,34);
WSR45:=(INDEXC-MA(INDEXC,55))/MA(INDEXC,55);
WSR46:=(WSR43 + WSR44 + WSR45)/3;
WSR47:=(C-MA(C,30))/MA(C,30);
WSR48:=(C-MA(C,60))/MA(C,60);
WSR49:=(C-MA(C,90))/MA(C,90);
WSR50:=(WSR47 + WSR48 + WSR49)/3;
WSR51:=(WSR46>REF(WSR46,1) AND CROSS(WSR50,WSR46));
WSR52:=(INDEXC-MA(INDEXC,34))/MA(INDEXC,34);
WSR53:=(INDEXC-MA(INDEXC,55))/MA(INDEXC,55);
WSR54:=(INDEXC-MA(INDEXC,89))/MA(INDEXC,89);
WSR55:=(WSR52 + WSR53 + WSR54)/3;
WSR56:=(C-MA(C,60))/MA(C,60);
WSR57:=(C-MA(C,120))/MA(C,120);
WSR58:=(C-MA(C,220))/MA(C,220);
WSR59:=(WSR56 + WSR57 + WSR58)/3;
WSR60:=(WSR59>REF(WSR59,1) AND CROSS(WSR59,WSR55));
WSR61:=WSR24 OR WSR33 OR WSR42 OR WSR51 OR WSR60;
{DRAWICON(WSR61 AND H<Y396 AND FILTER(WSR61,5),良3,7);
DRAWTEXT(WSR61 AND H<Y396 AND FILTER(WSR61,5),良3,'良机');}

N1:=20;N2:=10;N3:=5;
STICKLINE(CLOSE>REF(CLOSE,1)*1.095 AND CLOSE=HIGH,CLOSE,OPEN,2,1),COLOR0000FF;{涨停}
STICKLINE(CLOSE<REF(CLOSE,1)*0.9015 AND CLOSE=LOW,CLOSE,OPEN,2,1),COLORGREEN;{跌停};
GJ:=(C+H+L+O)/4;
明日阻力:=L+(GJ-L)+(C-L);
明日支撑:=L+(C-GJ);
今日阻力:REF(明日阻力 , 1),NODRAW;
今日支撑:REF(明日支撑 , 1),NODRAW;
STICKLINE(ISLASTBAR AND C>=今日阻力,今日阻力,今日阻力,10,1),COLOR0000FF;
STICKLINE(ISLASTBAR AND C<今日阻力,今日阻力,今日阻力,10,1),COLOR00FF00;
STICKLINE(ISLASTBAR AND C>=今日支撑,今日支撑,今日支撑,10,1),COLORFF00FF;
STICKLINE(ISLASTBAR AND C<今日支撑,今日支撑,今日支撑,10,1),COLORFF8800;
AA:=REF(H,N1)=HHV(H,2*N1+1);
QY:=BACKSET(AA,N1+1);
CC:=FILTER(QY,N1) AND H=HHV(H,N1+1);
DDD:=BARSLAST(CC);
GDTS:=IF(CC,CURRBARSCOUNT,0);
DINGBU:=IF(DDD,REF(H,DDD),H);{顶部}
DINGBUTS:=IF(DDD,REF(GDTS,DDD),GDTS);
DINGBU1:=REF(DINGBU,DDD+1);
GDCS1:=CONST(DINGBUTS);
DINGBUTS1:=REF(DINGBUTS,DDD+1);
GDCS2:=CONST(DINGBUTS1);
DINGBU2:=REF(DINGBU1,DDD+1);
MM:=IF(CURRBARSCOUNT>GDCS2,0,1);
高点压力:DRAWLINE(CURRBARSCOUNT=GDCS2,H,CURRBARSCOUNT=GDCS1,H,1),COLORRED;
DRAWLINE(CURRBARSCOUNT=GDCS2,H,ISLASTBAR,REF(H,GDCS2-1),1),COLOR00FF00,POINTDOT,LINETHICK2;
DRAWLINE(CURRBARSCOUNT=GDCS1,H,ISLASTBAR,REF(H,GDCS1-1),1),COLOR00FF00,POINTDOT,LINETHICK2;
AA1:=REF(L,N1)=LLV(L,2*N1+1);
QY1:=BACKSET(AA1,N1+1);
CC1:=FILTER(QY1,N1) AND L=LLV(L,N1+1);
DD1:=BARSLAST(CC1);
DDTS:=IF(CC1,CURRBARSCOUNT,0);
YDB:=IF(DD1,REF(L,DD1),L);
DDTS1:=IF(DD1,REF(DDTS,DD1),DDTS);
DDCS1:=CONST(DDTS1);
ZDB:=REF(YDB,DD1+1);
DDTS2:=REF(DDTS1,DD1+1);
DDCS2:=CONST(DDTS2);
低点支撑:DRAWLINE(CURRBARSCOUNT=DDCS2,L,CURRBARSCOUNT=DDCS1,L,1) COLORRED;
DRAWLINE(CURRBARSCOUNT=DDCS2,L,ISLASTBAR,REF(L,DDCS2-1),1),COLOR00FF00,POINTDOT,LINETHICK2;
DRAWLINE(CURRBARSCOUNT=DDCS1,L,ISLASTBAR,REF(L,DDCS1-1),1),COLOR00FF00,POINTDOT,LINETHICK2;
LAA:=REF(H,N2)=HHV(H,2*N2+1);
LQY:=BACKSET(LAA,N2+1);
LCC:=FILTER(LQY,N2) AND H=HHV(H,N2+1);
LDDD:=BARSLAST(LCC);
LGDTS:=IF(LCC,CURRBARSCOUNT,0);
LDINGBU:=IF(LDDD,REF(H,LDDD),H);{顶部}
LDINGBUTS:=IF(LDDD,REF(LGDTS,LDDD),LGDTS);
LDINGBU1:=REF(LDINGBU,LDDD+1);
LGDCS1:=CONST(LDINGBUTS);
LDINGBUTS1:=REF(LDINGBUTS,LDDD+1);
LGDCS2:=CONST(LDINGBUTS1);
LDINGBU2:=REF(LDINGBU1,LDDD+1);
LMM:=IF(CURRBARSCOUNT>LGDCS2,0,1);
压力:DRAWLINE(CURRBARSCOUNT=LGDCS2,H,CURRBARSCOUNT=LGDCS1,H,1),COLORFF0000;
DRAWLINE(CURRBARSCOUNT=LGDCS2,H,ISLASTBAR,REF(H,LGDCS2-1),1),COLOR00FF00,POINTDOT;
DRAWLINE(CURRBARSCOUNT=LGDCS1,H,ISLASTBAR,REF(H,LGDCS1-1),1),COLOR00FF00,POINTDOT;
LAA1:=REF(L,N2)=LLV(L,2*N2+1);
LQY1:=BACKSET(LAA1,N2+1);
LCC1:=FILTER(LQY1,N2) AND L=LLV(L,N2+1);
LDD1:=BARSLAST(LCC1);
LDDTS:=IF(LCC1,CURRBARSCOUNT,0);
LYDB:=IF(LDD1,REF(L,LDD1),L);
LDDTS1:=IF(LDD1,REF(LDDTS,LDD1),LDDTS);
LDDCS1:=CONST(LDDTS1);
LZDB:=REF(LYDB,LDD1+1);
LDDTS2:=REF(LDDTS1,DD1+1);
LDDCS2:=CONST(LDDTS2);
支撑:DRAWLINE(CURRBARSCOUNT=LDDCS2,L,CURRBARSCOUNT=LDDCS1,L,1),COLORFF0000;
ZGSTAR:=(压力+支撑)/2;
ZGEND:=CONST((压力+支撑)/2);
STARDAY:=IF(DDCS2<GDCS2,DDCS2,GDCS2);
中轨:DRAWLINE(CURRBARSCOUNT=STARDAY,ZGSTAR,ISLASTBAR,ZGEND,1),COLORWHITE;
LLAA:=REF(H,N3)=HHV(H,2*N3+1);
LLQY:=BACKSET(LLAA,N3+1);
LLCC:=FILTER(LLQY,N3) AND H=HHV(H,N3+1);
LLDDD:=BARSLAST(LLCC);
LLGDTS:=IF(LLCC,CURRBARSCOUNT,0);
LLDINGBU:=IF(LLDDD,REF(H,LLDDD),H);{顶部}
LLDINGBUTS:=IF(LLDDD,REF(LLGDTS,LLDDD),LLGDTS);
LLDINGBU1:=REF(LLDINGBU,LLDDD+1);
LLGDCS1:=CONST(LLDINGBUTS);
LLDINGBUTS1:=REF(LLDINGBUTS,LLDDD+1);
LLGDCS2:=CONST(LLDINGBUTS1);
LLDINGBU2:=REF(LLDINGBU1,LLDDD+1);
LLMM:=IF(CURRBARSCOUNT>LGDCS2,0,1);
L压力:DRAWLINE(CURRBARSCOUNT=LLGDCS2,H,CURRBARSCOUNT=LLGDCS1,H,1) COLORFF0000;
DRAWLINE(CURRBARSCOUNT=LLGDCS2,H,ISLASTBAR,REF(H,LLGDCS2-1),1),COLOR00FF00,POINTDOT;
DRAWLINE(CURRBARSCOUNT=LLGDCS1,H,ISLASTBAR,REF(H,LLGDCS1-1),1),COLOR00FF00,POINTDOT;
LLAA1:=REF(L,N3)=LLV(L,2*N3+1);
LLQY1:=BACKSET(LLAA1,N3+1);
LLCC1:=FILTER(LLQY1,N3) AND L=LLV(L,N3+1);
LLDD1:=BARSLAST(LCC1);
LLDDTS:=IF(LLCC1,CURRBARSCOUNT,0);
LLYDB:=IF(LLDD1,REF(L,LLDD1),L);
LLDDTS1:=IF(LLDD1,REF(LLDDTS,LLDD1),LDDTS);
LLDDCS1:=CONST(LLDDTS1);
LLZDB:=REF(LLYDB,LLDD1+1);
LLDDTS2:=REF(LLDDTS1,DD1+1);
LLDDCS2:=CONST(LLDDTS2);
L支撑:DRAWLINE(CURRBARSCOUNT=LLDDCS2,L,CURRBARSCOUNT=LLDDCS1,L,1) COLORYELLOW;
LZGSTAR:=(L压力+L支撑)/2;
LZGEND:=CONST((L压力+L支撑)/2);
LSTARDAY:=IF(LLDDCS2<LLGDCS2,LLDDCS2,LLGDCS2);
L中轨:DRAWLINE(CURRBARSCOUNT=LSTARDAY,LZGSTAR,ISLASTBAR,LZGEND,1),COLORYELLOW;

{A:=DRAWLINE(LOW<=LLV(LOW,120),LOW,HHV(H,6)<=HHV(H,10),LLV(LOW,6),1),
COLORBLUE ,LINETHICK2;}
A:=(3*C+L+O+H)/6;
TY:=C;
成本:=(MA(CLOSE,60)+MA(CLOSE,70)+MA(CLOSE,90)+MA(CLOSE,108))/4,COLORRED,LINETHICK2;
MA0:MA(C,0)COLORYELLOW ,LINETHICK2;
K:=(C+H+L)/3;
D:=MA(K,4);
阻力:=HHV(D,55),COLORYELLOW,LINETHICK2;
顶部:=HHV(H*0.98,55)COLORFFFFFF,LINETHICK2;
DRAWICON(REF(C,1)<D AND C>D AND D<REF(D,1),L*0.98,1),COLORYELLOW,LINETHICK2 ;
{均线}
TYP:= (HIGH + LOW +2* C)/4;
均线:=EMA(TYP,3),LINETHICK2,COLORWHITE;
均线上轨:=HHV(均线,14),LINETHICK2,COLORYELLOW;
均线下轨:=LLV(均线,14),LINETHICK2,COLORGREEN;
角度:=ATAN((均线/REF(均线,1)-1)*100)*180/3.1416;
{K线优化}
STICKLINE(CLOSE>=OPEN,HIGH,LOW,0,1 ),COLOR5B5BFF;
STICKLINE(CLOSE>=OPEN,OPEN,CLOSE,2.7,0 ),COLOR0000CC;
STICKLINE(CLOSE>=OPEN,OPEN,CLOSE,2,0 ),COLOR0E0EFF;
STICKLINE(CLOSE>=OPEN,OPEN,CLOSE,1.2,0 ),COLOR4848FF;
STICKLINE(CLOSE>=OPEN,OPEN,CLOSE,0.6,0 ),COLOR7878FF;
STICKLINE(CLOSE>=OPEN,OPEN,CLOSE,0.1,0 ),COLORA1A1FF;
STICKLINE(CLOSE>=OPEN,OPEN,CLOSE,0,0 ),COLORCACAFF;
STICKLINE(CLOSE< OPEN,HIGH,LOW,0,1 ),COLORCYAN;
STICKLINE(CLOSE< OPEN,OPEN,CLOSE,2.7,0 ),COLOR990000;
STICKLINE(CLOSE< OPEN,OPEN,CLOSE,2,0 ),COLORCC0000;
STICKLINE(CLOSE< OPEN,OPEN,CLOSE,1.2,0 ),COLORFF4400;
STICKLINE(CLOSE< OPEN,OPEN,CLOSE,0.6,0 ),COLORFF8800;
STICKLINE(CLOSE< OPEN,OPEN,CLOSE,0.1,0 ),COLORFFCC00;
STICKLINE(CLOSE< OPEN,OPEN,CLOSE,0,0 ),COLORCYAN;
X:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+
14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)
+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+
REF(A,20))/210;
MTM:=C-REF(C,1);
DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
CB:=EMA(X,13);
买:=IF(LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2)),1,0);
DRAWICON(FILTER(买=1,5),L*0.97,1);
{DT1:=C>REF(C,N);
DT2:=C>REF(C,M);
STICKLINE(DT2,H,L,0,0),COLORRED;
STICKLINE(DT2=0,H,L,0,0),COLORBLUE;
STICKLINE(DT1,H,MAX(O,C),0,0),COLORRED;
STICKLINE(DT1=0,L,MIN(O,C),0,0),COLORBLUE;
STICKLINE(DT2,O,C,2.5,0),COLORRED;
STICKLINE(DT2=0,O,C,2.5,0),COLORBLUE;
STICKLINE(DT1,(O+C)/2,O,2.5,0),COLORRED;
STICKLINE(DT1=0,(O+C)/2,C,2.5,0),COLORBLUE;};




好股票软件下载网(www.goodgupiao.com)提醒您:股市有风险,投资需谨慎。
通达信神笔马良主图指标公式下载地址
相关说明
  • 好股票软件下载网欢迎用户将网页内容和下载地址转发到博客、微博、论坛等。
  • 发布的公式指标绝大部分是来源于各大论坛,谢谢各位老师的原创指标。
  • 判断公式指标好坏,请用户参考用户评论或者软件好评度
  • alg格式股票公式,仅仅可以用飞狐交易师股票软件引入使用;
  • fnc格式股票公式,可以用大智慧新一代高速行情分析系统股票软件使用,少部分可以用分析家股票软件引入使用;
  • exp格式股票公式,仅可以用大智慧经典版股票软件引入使用;
  • tnctni格式股票公式,仅可以用通达信新引入使用,例如可以用通达信股票软件引入使用;
  • tne格式公式,仅可以用通达信公式编辑器5.0版导入,高版本兼容低版本;
  • hxf格式股票公式,仅可以用同花顺股票软件引入使用。
  • 如果引入公式的时候,发现公式名称栏空白,调整电脑时间到1997年,能出现公式名称并正常显示,可能是公式使用期限已过。
  • 如果您发现下载链接错误,请点击报告错误谢谢!