好股票网每日提供最新股票软件下载,如果您觉得不错,麻烦推荐给您的好友,谢谢!
您现在的位置:好股票网 >> 股票公式 >> 金字塔公式

金字塔经典K线形态解盘指标源码[金字塔模型]

[下载地址]

好股票网经过测试可运行,该软件通过多款专业杀毒软件扫描

  • 360通过
  • 金山通过
  • 瑞星通过
  • 江民通过
  • 卡巴通过
  • 诺顿通过
  • 运行平台:Win7/Vista/WinXP/Win2003/
  • 公式语言:简体中文
  • 更新时间:2013-03-05 09:19:46
  • 公式评级:
  • 公式类型:金字塔公式
  • 授权方式:共享版
  • 公式大小:0 Bytes
  • 解压密码:goodgupiao
  • 下载统计:
  • 相关Tags:
已有次下载
推 荐0
不推荐0

金字塔经典K线形态解盘指标源码[金字塔模型]介绍

好股票软件下载网(www.goodgupiao.com)提示:您正在下载的是:金字塔经典K线形态解盘指标源码[金字塔模型]

金字塔公式 金字塔模型策略源码:{CZW-G}
DRAWBKBMP(CLOSE>0,\'a008\');
{p1:3,0,30;p2:6,1,300;p3:18,1,300;p4:250,0,300}
Var1:=(C+L+H)/3;
Var2:=eMA(Var1,6);
Var3:=eMA(Var2,5);
Var4:=eMA(Var3,12);
Var5:=eMA(Var4,5);
生命线:eMA(Var3,30),COLORRED,POINTDOT;
DRAWICON(C>=生命线,生命线,10);
DRAWICON(C<生命线,生命线,11);
a:=HHV(MA((L+H+C)/3,3),3);
b:=llv(MA((L+H+C)/3,3),10);
STICKLINE(BARSCOUNT(C)=SYSPARAM(1),a,a,20,0),Coloryellow,linethick3,shift1;
DRAWNUMBER(BARSCOUNT(C)=SYSPARAM(1),a,a,3),shift3,colorYELLOW;
STICKLINE(BARSCOUNT(C)=SYSPARAM(1),b,b,20,0),ColorDB3FDD,linethick3,shift1;
DRAWNUMBER(BARSCOUNT(C)=SYSPARAM(1),b,b,3),shift3,ColorDB3FDD;
DRAWTEXT(sysparam(2)=BARPOS,c,\' \'+BLKNAME),COLORccffcc,ALIGN4;//板块
a1:=cost(95);
a2:=cost(5);
ly:=(a1-a2)*100/(a1+a2);
drawicon(ly>ref(ly,1), l*0.98,8)ALIGN5;
N:=3;{原码 N:=3;}
A1:=REF(H,N)=HHV(H,2*N+1); B1:=FILTER(A1,N); C1:=BACKSET(B1,N+1); D1:=FILTER(C1,N);{高点}
A2:=REF(L,N)=LLV(L,2*N+1); B2:=FILTER(A2,N); C2:=BACKSET(B2,N+1); D2:=FILTER(C2,N);{低点}
E1:=(REF(LLV(L,2*N),1)+REF(HHV(H,2*N),1))/2; E2:=(H+L)/2;{高低点出现在同一K线上时可作取舍}
H1:=(D1 AND NOT(D2 AND E1>=E2)) OR ISLASTBAR OR BARSCOUNT(C)=1;
L1:=(D2 AND NOT(D1 AND E1<E2)); H2:=D1 AND NOT(D2 AND E1>=E2);
X1:=REF(BARSLAST(H1),1)+1; F1:=BACKSET(H1 AND COUNT(L1,X1)>0,LLVBARS(IF(L1,L,10000),X1));
G1:=F1>REF(F1,1); I1:=BACKSET(G1,2); LD:=I1>REF(I1,1),LINETHICK0;{过滤后低点}
L2:=LD OR ISLASTBAR OR BARSCOUNT(C)=1;
X2:=REF(BARSLAST(L2),1)+1; F2:=BACKSET(L2 AND COUNT(H2,X2)>0,HHVBARS(IF(H2,H,0),X2));
G2:=F2>REF(F2,1); I2:=BACKSET(G2,2); HD:=I2>REF(I2,1),LINETHICK0;{过滤后高点}
///HD:="jgb.HD"(N);LD:="jgb.LD"(N);
R1:=BACKSET(ISLASTBAR,BARSLAST(HD)+1); S1:=R1>REF(R1,1); {前一高}
T1:=BACKSET(ISLASTBAR,BARSLAST(LD)+1); U1:=T1>REF(T1,1); {前一低}
R2:=BACKSET(S1,REF(BARSLAST(HD),1)+2); S2:=R2>REF(R2,1); {前二高}
T2:=BACKSET(U1,REF(BARSLAST(LD),1)+2); U2:=T2>REF(T2,1); {前二低}
T3:=BACKSET(U2,REF(BARSLAST(LD),1)+2); U3:=T3>REF(T3,1); {前三低}
T4:=BACKSET(U3,REF(BARSLAST(LD),1)+2); U4:=T4>REF(T4,1); {前四低}
R3:=BACKSET(S2,REF(BARSLAST(HD),1)+2); S3:=R3>REF(R3,1); {前三高}
R4:=BACKSET(S3,REF(BARSLAST(HD),1)+2); S4:=R4>REF(R4,1); {前四高}
★压力1:DRAWLINE(S2,H,S1,H,1),Color80FFFF;
★支撑1:DRAWLINE(U2,L,U1,L,1),POINTDOT,Color00FFFF,linethick2;
★压力2:DRAWLINE(S3,H,S2,H,1),ColorFF8000;
★支撑2:DRAWLINE(U3,L,U2,L,1),POINTDOT,ColorFF8000;
★压力3:DRAWLINE(S4,H,S3,H,1),Color0000FF;
★支撑3:DRAWLINE(U4,L,U3,L,1)POINTDOT,Color0000FF;
DRAWICON(S2,H*1.01,10); DRAWICON(S3,H*1.01,10);
DRAWNUMBER(S2,H*1.02,H,2),COLORMAGENTA;
DRAWNUMBER(S1,H*1.02,H,2),COLORMAGENTA;
DRAWNUMBER(S3,H*1.02,H,2),COLORMAGENTA;
DRAWICON(U1,L*0.99,11); DRAWICON(U2,L*0.99,11);
DRAWICON(U3,L*0.99,11);DRAWICON(U4,L*0.99,11);
DRAWNUMBER(U1,L*0.98,L,2),COLORCYAN;
DRAWNUMBER(U2,L*0.98,L,2),COLORCYAN;
DRAWNUMBER(U3,L*0.98,L,2),COLORCYAN;
DRAWNUMBER(U4,L*0.98,L,2),COLORCYAN;
STICKLINE(open>=close ,close ,open,0,0 ),COLOR00FF00;
STICKLINE(open>=close ,close ,open,8,0 ),COLOR008800;
STICKLINE(open>=close ,close ,open,7,0 ),COLOR009900;
STICKLINE(open>=close ,close ,open,6,0 ),COLOR00AA00;
STICKLINE(open>=close ,close ,open,5,0 ),COLOR00BB00;
STICKLINE(open>=close ,close ,open,4,0 ),COLOR00CC00;
STICKLINE(open>=close ,close ,open,3,0 ),COLOR00DD00;
STICKLINE(open>=close ,close ,open,2,0 ),COLOR00EE00;
STICKLINE(open>=close ,close ,open,1,0 ),COLOR00FF00;
STICKLINE(close>open,close,open,0,0) ,COLORFFBBFF;
STICKLINE(close>open,close,open,8,0) ,COLORFF00FF;
STICKLINE(close>open,close,open,7,0) ,COLORFF22FF;
STICKLINE(close>open,close,open,6,0) ,COLORFF44FF;
STICKLINE(close>open,close,open,5,0) ,COLORFF66FF;
STICKLINE(close>open,close,open,4,0) ,COLORFF88FF;
STICKLINE(close>open,close,open,3,0) ,COLORFF99FF;
STICKLINE(close>open,close,open,2,0) ,COLORFFAAFF;
STICKLINE(close>open,close,open,1,0) ,COLORFFBBFF;
EXPLAIN(c>0 ,\'〓 K 线形态分析 〓 \'),ColorFFFFFF;
★早晨之星:=REF(CLOSE,2)/REF(OPEN,2) < 0.95 AND REF(OPEN,1) < REF(CLOSE,2) AND ABS(REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<0.03 AND
CLOSE/OPEN>1.05 AND CLOSE>REF(CLOSE,2);
★黄昏之星:=REF(CLOSE,2)/REF(OPEN,2) > 1.03 AND REF(OPEN,1) > REF(CLOSE,2) AND ABS(REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<0.02 AND
CLOSE/OPEN<0.97 AND CLOSE<REF(CLOSE,2);
★长十字:=CLOSE=OPEN AND HIGH/LOW >1.03;
★垂死十字:=CLOSE=OPEN AND CLOSE=LOW AND CLOSE<>HIGH;
★早晨十字星:=REF(CLOSE,2)/REF(OPEN,2) < 0.95 AND REF(OPEN,1) < REF(CLOSE,2) AND REF(OPEN,1)=REF(CLOSE,1) AND
CLOSE/OPEN>1.05 AND CLOSE>REF(CLOSE,2);
★黄昏十字星:=REF(CLOSE,2)/REF(OPEN,2) > 1.05 AND REF(OPEN,1) > REF(CLOSE,2) AND REF(OPEN,1)=REF(CLOSE,1) AND
CLOSE/OPEN<0.95 AND CLOSE<REF(CLOSE,2);
★射击之星:=MIN(OPEN,CLOSE)=LOW AND HIGH-LOW > 3*(MAX(OPEN,CLOSE)-LOW) AND CLOSE > MA(CLOSE,5);
★倒转锤头:=MIN(OPEN,CLOSE)=LOW AND HIGH-LOW > 3*(MAX(OPEN,CLOSE)-LOW) AND CLOSE < MA(CLOSE,5);
★锤头:=HIGH = MAX(OPEN,CLOSE) AND HIGH-LOW > 3*(HIGH-MIN(OPEN,CLOSE)) AND CLOSE < MA(CLOSE,5);
★吊颈:=HIGH = MAX(OPEN,CLOSE) AND HIGH-LOW > 3*(HIGH-MIN(OPEN,CLOSE)) AND CLOSE>MA(CLOSE,5);
★穿头破脚:=(REF(CLOSE,1)/REF(OPEN,1)>1.03 AND CLOSE/OPEN<0.96 AND CLOSE<REF(OPEN,1) AND OPEN>REF(CLOSE,1))
OR (REF(CLOSE,1)/REF(OPEN,1)<0.97 AND CLOSE/OPEN>1.04 AND CLOSE>REF(OPEN,1) AND OPEN<REF(CLOSE,1));
★乌云盖顶:=REF(CLOSE,1)/REF(OPEN,1)>1.03 AND CLOSE/OPEN<0.97 AND OPEN>REF(CLOSE,1) AND CLOSE<REF(CLOSE,1);
★曙光初现:=REF(CLOSE,1)/REF(OPEN,1)<0.97 AND CLOSE/OPEN>1.03 AND OPEN<REF(CLOSE,1) AND CLOSE>REF(CLOSE,1);
★身怀六甲:=ABS(REF(CLOSE,1)-REF(OPEN,1))/REF(CLOSE,1) > 0.04 AND ABS(CLOSE-OPEN)/CLOSE<0.005 AND
MAX(CLOSE,OPEN) < MAX(REF(CLOSE,1),REF(OPEN,1)) AND MIN(CLOSE,OPEN) > MIN(REF(CLOSE,1),REF(OPEN,1));
★十字胎:=ABS(REF(CLOSE,1)-REF(OPEN,1))/REF(CLOSE,1) > 0.04 AND CLOSE=OPEN AND
CLOSE < MAX(REF(CLOSE,1),REF(OPEN,1)) AND CLOSE > MIN(REF(CLOSE,1),REF(OPEN,1));
★平顶:=ABS(HIGH-REF(HIGH,1))/HIGH<0.001;
★平底:=(ABS(LOW-REF(LOW,1))/LOW<0.001 and abs(ref(low,1)-ref(low,2))/ref(low,1)<=0.001);
★大阳烛:=CLOSE/OPEN>1.05 AND HIGH/LOW < CLOSE/OPEN+0.018;
★红三兵:=REF(CLOSE,2)>REF(OPEN,2) AND REF(CLOSE,1)>REF(OPEN,1) AND CLOSE>OPEN
AND REF(CLOSE,1)>REF(CLOSE,2) AND CLOSE>REF(CLOSE,1);
★双飞乌鸦:=REF(CLOSE,1)<REF(OPEN,1) AND CLOSE<OPEN AND CLOSE/OPEN<0.98;
★孕育线:=REF(CLOSE,2)>REF(OPEN,2) AND (REF(CLOSE,2)-REF(OPEN,2))/REF(OPEN,2)>=2/100 AND REF(OPEN,1)>=REF(CLOSE,1) AND
(REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<=2/100 AND REF(OPEN,1)<=REF(CLOSE,2) AND REF(CLOSE,1)>=REF(OPEN,2) AND C>=OPEN AND
(CLOSE-OPEN)/OPEN>=2/100 AND CLOSE>=REF(OPEN,1) AND OPEN<=REF(CLOSE,1) AND (MAX(CLOSE,REF(C,2))-MIN(CLOSE,REF(CLOSE,2)))/MIN(CLOSE,REF(CLOSE,2))<=1/100;
★多方炮:=REF(CLOSE,2)>REF(OPEN,2) AND REF(CLOSE,1)<REF(OPEN,1) AND CLOSE>OPEN;
★出水芙蓉:=(OPEN<EMA(C,20) OR OPEN<EMA(C,40) OR OPEN<EMA(C,60)) AND (C>MAX(EMA(C,20),MAX(EMA(C,40),EMA(C,60))))
AND (V/MA(V,30)>1.2 AND C/REF(C,1)>1.049);
★上升三部曲:=REF(CLOSE,4)/REF(OPEN,4)>1.03 AND REF(CLOSE,3)<REF(OPEN,3) AND REF(CLOSE,2)<REF(OPEN,2) AND REF(CLOSE,1)<REF(OPEN,1) AND
REF(LOW,4)<REF(LOW,3) AND REF(LOW,4)<REF(LOW,2) AND REF(LOW,4)<REF(LOW,1) AND REF(HIGH,4)>REF(HIGH,3) AND REF(HIGH,4)>REF(HIGH,2) AND
REF(HIGH,4)>REF(HIGH,1) AND CLOSE/OPEN>1.03 AND CLOSE>REF(CLOSE,4);
★下跌三部曲:= REF(CLOSE,4)/REF(OPEN,4)<0.97 AND REF(CLOSE,3)>REF(OPEN,3) AND REF(CLOSE,2)>REF(OPEN,2) AND REF(CLOSE,1)>REF(OPEN,1) AND REF(LOW,4)<REF(LOW,3) AND
REF(LOW,4)<REF(LOW,2) AND REF(LOW,4)<REF(LOW,1) AND REF(HIGH,4)>REF(HIGH,3) AND REF(HIGH,4)>REF(HIGH,2) AND REF(HIGH,4)>REF(HIGH,1) AND CLOSE/OPEN<0.97 AND
CLOSE<REF(CLOSE,4);
★跳空缺口:=HIGH<REF(LOW,1) OR LOW>REF(HIGH,1);
★三只乌鸦:=REF(CLOSE,2)<REF(OPEN,2) AND REF(CLOSE,1)<REF(OPEN,1) AND CLOSE<OPEN AND REF(CLOSE,1)<REF(CLOSE,2) AND CLOSE<REF(CLOSE,1);
★光脚阴线:=LOW=CLOSE AND HIGH<>LOW;
★光头阳线:=HIGH=CLOSE AND HIGH<>LOW;
★分离:=OPEN=REF(OPEN,1) AND (CLOSE-OPEN)*(REF(CLOSE,1)-REF(OPEN,1))<0;
★长下影:=(MIN(CLOSE,OPEN)-LOW)/(HIGH-LOW)>0.667;
★长上影:=(HIGH-MAX(CLOSE,OPEN))/(HIGH-LOW)>0.667;
★十字星:=CLOSE=OPEN AND HIGH<>LOW;
★大阴烛:=OPEN/CLOSE > 1.05 AND HIGH/LOW < OPEN/CLOSE+0.018;
★好友反攻:=(REF(CLOSE,1)<REF(OPEN,1) AND CLOSE>OPEN AND ABS(CLOSE-REF(CLOSE,1))/CLOSE<0.002)
OR (REF(CLOSE,1)>REF(OPEN,1) AND CLOSE<OPEN AND ABS(CLOSE-REF(CLOSE,1))/CLOSE<0.002);
★倾盆大雨:=REF(C,1)/REF(O,1)>=1.03 AND O<REF(C,1) AND O>REF(O,1) AND C<REF(O,1);
EXPLAIN(★倾盆大雨,\'★倾盆大雨★见顶信号;\'),COLORCYAN;
EXPLAIN(★大阴烛,\'★大阴烛★后市向淡,发生逆转;\'),COLORCYAN;
EXPLAIN(★好友反攻,\'★好友反攻★底部反转;\'),COLORRED;
EXPLAIN(★跳空缺口,\'★跳空缺口★注意向上还是向下跳空;\'),COLORWHITE;
EXPLAIN(★光脚阴线,\'★光脚阴线★下跌信号;\'),COLORCYAN;
EXPLAIN(★光头阳线,\'★光头阳线★后市看涨;\'),COLORRED;
EXPLAIN(★三只乌鸦,\'★三只乌鸦★可能见顶回落;\'),COLORCYAN;
EXPLAIN(★分离,\'★分离★注意看涨分离和看跌分离;\'),COLORWHITE;
EXPLAIN(★长下影,\'★长下影★持续下跌后出现,有可能止跌回升;在升势末期出现,须多加留意;\'),COLORRED;
EXPLAIN(★长上影,\'★长上影★表明行情上档压力沉重,升势受阻;\'),COLORCYAN;
EXPLAIN(★下跌三部曲,\'★下跌三部曲★下跌信号;\'),COLORRED;
EXPLAIN(★上升三部曲,\'★上升三部曲★上涨信号;\'),COLORCYAN;
EXPLAIN(★早晨之星,\'★早晨之星★见底回升;\'),COLORRED;
EXPLAIN(★黄昏之星,\'★黄昏之星★见顶回落;\'),COLORCYAN;
EXPLAIN(★十字星,\'★十字星★有转向意味,注意股价位置在顶部还是底部;\'),COLORWHITE;
EXPLAIN(★长十字,\'★长十字★注意在顶部还是底部;\'),COLORWHITE;
EXPLAIN(★垂死十字,\'★垂死十字★下跌信号;\'),COLORCYAN;
EXPLAIN(★早晨十字星,\'★早晨十字星★上涨信号,见底回升;\'),COLORRED;
EXPLAIN(★黄昏十字星,\'★黄昏十字星★下跌信号,见顶回落;\'),COLORCYAN;
EXPLAIN(★射击之星,\'★射击之星★可能见顶回落,可靠性低;\'),COLORCYAN;
EXPLAIN(★倒转锤头,\'★倒转锤头★可能见底回升;\'),COLORRED;
EXPLAIN(★锤头,\'★锤头★可能见底回升,如有量配合,信号强烈;\'),COLORRED;
EXPLAIN(★吊颈,\'★吊颈★上升行情中见顶回落,顶部出现,见顶信号;\'),COLORCYAN;
EXPLAIN(★平顶,\'★平顶★温和的反转;\'),COLORCYAN;
EXPLAIN(★穿头破脚,\'★穿头破脚★顶部出现,见顶回落信号;\'),COLORCYAN;
EXPLAIN(★乌云盖顶,\'★乌云盖顶★见顶回落信号;\'),COLORCYAN;
EXPLAIN(★曙光初现,\'★曙光初现★后市见底回升;\'),COLORRED;
EXPLAIN(★身怀六甲,\'★身怀六甲★出现在底部,是见底回升信号;出现在顶部,是见顶回落信号;\'),COLORRED;
EXPLAIN(★十字胎,\'★十字胎★\'),COLORRED;
EXPLAIN(★平底,\'★平底★温和的反转;\'),COLORRED;
EXPLAIN(★大阳烛,\'★大阳烛★看涨;\'),COLORRED;
EXPLAIN(★红三兵,\'★红三兵★每日收盘价上移,表示可能见底回升;\'),COLORRED;
EXPLAIN(★双飞乌鸦,\'★双飞乌鸦★行情将见顶回落;\'),COLORCYAN;
EXPLAIN(★孕育线,\'★孕育线★注意股价位置;\'),COLORWHITE;
EXPLAIN(★多方炮,\'★多方炮★在底部出现有上涨可能,在中间出现有可能是上涨中继,顶部出现是复合见顶信号;\'),COLORRED;
EXPLAIN(★出水芙蓉,\'★出水芙蓉★见底回升;\'),COLORRED;

复制上述代码粘贴到到公式管理器


 

源码解析:

DRAWBKBMP(收盘价>0,\'A008\')
VAR1赋值:(收盘价+最低价+最高价)/3
VAR2赋值:VAR1的6日指数移动平均
VAR3赋值:VAR2的5日指数移动平均
VAR4赋值:VAR3的12日指数移动平均
VAR5赋值:VAR4的5日指数移动平均
输出生命线:VAR3的30日指数移动平均,画红色,POINTDOT
当满足条件收盘价>=生命线时,在生命线位置画10号图标
当满足条件收盘价<生命线时,在生命线位置画11号图标
A赋值:3日内(最低价+最高价+收盘价)/3的3日简单移动平均的最高值
B赋值:10日内(最低价+最高价+收盘价)/3的3日简单移动平均的最低值
当满足条件收盘价的有效数据周期数=SYSPARAM(1)时,在A和A位置之间画柱状线,宽度为20,0不为0则画空心柱.,画黄色,线宽为3,SHIFT1
当满足条件收盘价的有效数据周期数=SYSPARAM(1)时,在A位置书写数字,SHIFT3,画黄色
当满足条件收盘价的有效数据周期数=SYSPARAM(1)时,在B和B位置之间画柱状线,宽度为20,0不为0则画空心柱.,COLORDB3FDD,线宽为3,SHIFT1
当满足条件收盘价的有效数据周期数=SYSPARAM(1)时,在B位置书写数字,SHIFT3,COLORDB3FDD
当满足条件SYSPARAM(2)=BARPOS时,在收盘价位置书写文字,COLORCCFFCC,ALIGN4
板块A1赋值:获利盘为95%的成本分布
A2赋值:获利盘为5%的成本分布
LY赋值:(A1-A2)*100/(A1+A2)
当满足条件LY>昨日LY时,在最低价*0.98位置画8号图标ALIGN5
N赋值:3
A1赋值:N日前的最高价=2*N+1日内最高价的最高值
B1赋值:A1的N日过滤
C1赋值:若B1则将最近N+1周期置为1
D1赋值:C1的N日过滤
A2赋值:N日前的最低价=2*N+1日内最低价的最低值
B2赋值:A2的N日过滤
C2赋值:若B2则将最近N+1周期置为1
D2赋值:C2的N日过滤
E1赋值:(昨日2*N日内最低价的最低值+昨日2*N日内最高价的最高值)/2
E2赋值:(最高价+最低价)/2
H1赋值:(D1 AND 取反) OR 是否最后一个周期 OR 收盘价的有效数据周期数=1
L1赋值:(D2 AND 取反)
H2赋值:D1 AND 取反
X1赋值:昨日上次H1距今天数+1
F1赋值:若H1ANDCOUNT(L1,X1)>0则将最近X1日内如果L1,返回最低价,否则返回10000距今天数周期置为1
G1赋值:F1>昨日F1
I1赋值:若G1则将最近2周期置为1
LD赋值:I1>昨日I1,线宽为0
L2赋值:LD OR 是否最后一个周期 OR 收盘价的有效数据周期数=1
X2赋值:昨日上次L2距今天数+1
F2赋值:若L2ANDCOUNT(H2,X2)>0则将最近X2日内如果H2,返回最高价,否则返回0距今天数周期置为1
G2赋值:F2>昨日F2
I2赋值:若G2则将最近2周期置为1
HD赋值:I2>昨日I2,线宽为0
HD赋值:"JGB.HD"(N)
LD赋值:"JGB.LD"(N)
R1赋值:若是否最后一个周期则将最近上次HD距今天数+1周期置为1
S1赋值:R1>昨日R1
T1赋值:若是否最后一个周期则将最近上次LD距今天数+1周期置为1
U1赋值:T1>昨日T1
R2赋值:若S1则将最近昨日上次HD距今天数+2周期置为1
S2赋值:R2>昨日R2
T2赋值:若U1则将最近昨日上次LD距今天数+2周期置为1
U2赋值:T2>昨日T2
T3赋值:若U2则将最近昨日上次LD距今天数+2周期置为1
U3赋值:T3>昨日T3
T4赋值:若U3则将最近昨日上次LD距今天数+2周期置为1
U4赋值:T4>昨日T4
R3赋值:若S2则将最近昨日上次HD距今天数+2周期置为1
S3赋值:R3>昨日R3
R4赋值:若S3则将最近昨日上次HD距今天数+2周期置为1
S4赋值:R4>昨日R4
输出 ★压力1:当满足条件S2时,在最高价位置画直线起点,当满足条件S1时,在最高价位置画直线终点,1表示是否延长.,COLOR80FFFF
输出 ★支撑1:当满足条件U2时,在最低价位置画直线起点,当满足条件U1时,在最低价位置画直线终点,1表示是否延长.,POINTDOT,COLOR00FFFF,线宽为2
输出★压力2:当满足条件S3时,在最高价位置画直线起点,当满足条件S2时,在最高价位置画直线终点,1表示是否延长.,COLORFF8000
输出 ★支撑2:当满足条件U3时,在最低价位置画直线起点,当满足条件U2时,在最低价位置画直线终点,1表示是否延长.,POINTDOT,COLORFF8000
输出 ★压力3:当满足条件S4时,在最高价位置画直线起点,当满足条件S3时,在最高价位置画直线终点,1表示是否延长.,COLOR0000FF
输出★支撑3:当满足条件U4时,在最低价位置画直线起点,当满足条件U3时,在最低价位置画直线终点,1表示是否延长.POINTDOT,COLOR0000FF
当满足条件S2时,在最高价*1.01位置画10号图标
当满足条件S3时,在最高价*1.01位置画10号图标
当满足条件S2时,在最高价*1.02位置书写数字,画洋红色
当满足条件S1时,在最高价*1.02位置书写数字,画洋红色
当满足条件S3时,在最高价*1.02位置书写数字,画洋红色
当满足条件U1时,在最低价*0.99位置画11号图标
当满足条件U2时,在最低价*0.99位置画11号图标
当满足条件U3时,在最低价*0.99位置画11号图标
当满足条件U4时,在最低价*0.99位置画11号图标
当满足条件U1时,在最低价*0.98位置书写数字,画青色
当满足条件U2时,在最低价*0.98位置书写数字,画青色
当满足条件U3时,在最低价*0.98位置书写数字,画青色
当满足条件U4时,在最低价*0.98位置书写数字,画青色
当满足条件开盘价>=收盘价时,在收盘价和开盘价位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLOR00FF00
当满足条件开盘价>=收盘价时,在收盘价和开盘价位置之间画柱状线,宽度为8,0不为0则画空心柱.,COLOR008800
当满足条件开盘价>=收盘价时,在收盘价和开盘价位置之间画柱状线,宽度为7,0不为0则画空心柱.,COLOR009900
当满足条件开盘价>=收盘价时,在收盘价和开盘价位置之间画柱状线,宽度为6,0不为0则画空心柱.,COLOR00AA00
当满足条件开盘价>=收盘价时,在收盘价和开盘价位置之间画柱状线,宽度为5,0不为0则画空心柱.,COLOR00BB00
当满足条件开盘价>=收盘价时,在收盘价和开盘价位置之间画柱状线,宽度为4,0不为0则画空心柱.,COLOR00CC00
当满足条件开盘价>=收盘价时,在收盘价和开盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR00DD00
当满足条件开盘价>=收盘价时,在收盘价和开盘价位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR00EE00
当满足条件开盘价>=收盘价时,在收盘价和开盘价位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLOR00FF00
当满足条件收阳线时,在收盘价和开盘价位置之间画柱状线,宽度为0,0不为0则画空心柱. ,COLORFFBBFF
当满足条件收阳线时,在收盘价和开盘价位置之间画柱状线,宽度为8,0不为0则画空心柱. ,COLORFF00FF
当满足条件收阳线时,在收盘价和开盘价位置之间画柱状线,宽度为7,0不为0则画空心柱. ,COLORFF22FF
当满足条件收阳线时,在收盘价和开盘价位置之间画柱状线,宽度为6,0不为0则画空心柱. ,COLORFF44FF
当满足条件收阳线时,在收盘价和开盘价位置之间画柱状线,宽度为5,0不为0则画空心柱. ,COLORFF66FF
当满足条件收阳线时,在收盘价和开盘价位置之间画柱状线,宽度为4,0不为0则画空心柱. ,COLORFF88FF
当满足条件收阳线时,在收盘价和开盘价位置之间画柱状线,宽度为3,0不为0则画空心柱. ,COLORFF99FF
当满足条件收阳线时,在收盘价和开盘价位置之间画柱状线,宽度为2,0不为0则画空心柱. ,COLORFFAAFF
当满足条件收阳线时,在收盘价和开盘价位置之间画柱状线,宽度为1,0不为0则画空心柱. ,COLORFFBBFF
EXPLAIN(收盘价>0 ,\'〓 K 线形态分析 〓 \'),COLORFFFFFF
★早晨之星赋值:2日前的收盘价/2日前的开盘价 < 0.95 AND 昨日开盘价 < 2日前的收盘价 AND 昨日开盘价-昨收的绝对值/昨收<0.03 ANDCLOSE/开盘价>1.05 AND 收盘价>2日前的收盘价
★黄昏之星赋值:2日前的收盘价/2日前的开盘价 > 1.03 AND 昨日开盘价 > 2日前的收盘价 AND 昨日开盘价-昨收的绝对值/昨收<0.02 ANDCLOSE/开盘价<0.97 AND 收盘价<2日前的收盘价
★长十字赋值:平盘ANDSE 最高价/最低价 >1.03
★垂死十字赋值:平盘ANDSE 收盘价=最低价 AND 收盘价<>最高价
★早晨十字星赋值:2日前的收盘价/2日前的开盘价 < 0.95 AND 昨日开盘价 < 2日前的收盘价 AND 昨日开盘价=昨收 ANDCLOSE/开盘价>1.05 AND 收盘价>2日前的收盘价
★黄昏十字星赋值:2日前的收盘价/2日前的开盘价 > 1.05 AND 昨日开盘价 > 2日前的收盘价 AND 昨日开盘价=昨收 ANDCLOSE/开盘价<0.95 AND 收盘价<2日前的收盘价
★射击之星赋值:开盘价和收盘价的较小值=最低价 AND 最高价-最低价 > 3*(开盘价和收盘价的较大值-最低价) AND 收盘价 > 收盘价的5日简单移动平均
★倒转锤头赋值:开盘价和收盘价的较小值=最低价 AND 最高价-最低价 > 3*(开盘价和收盘价的较大值-最低价) AND 收盘价 < 收盘价的5日简单移动平均
★锤头赋值:最高价 = 开盘价和收盘价的较大值 AND 最高价-最低价 > 3*(最高价-开盘价和收盘价的较小值) AND 收盘价 < 收盘价的5日简单移动平均
★吊颈赋值:最高价 = 开盘价和收盘价的较大值 AND 最高价-最低价 > 3*(最高价-开盘价和收盘价的较小值) AND 收盘价>收盘价的5日简单移动平均
★穿头破脚赋值:(昨收/昨日开盘价>1.03 AND 收盘价/开盘价<0.96 AND 收盘价<昨日开盘价 AND 开盘价>昨收)OR (昨收/昨日开盘价<0.97 AND 收盘价/开盘价>1.04 AND 收盘价>昨日开盘价 AND 开盘价<昨收)
★乌云盖顶赋值:昨收/昨日开盘价>1.03 AND 收盘价/开盘价<0.97 AND 开盘价>昨收 AND 收盘价<昨收
★曙光初现赋值:昨收/昨日开盘价<0.97 AND 收盘价/开盘价>1.03 AND 开盘价<昨收 AND 收盘价>昨收
★身怀六甲赋值:昨收-昨日开盘价的绝对值/昨收 > 0.04 AND 收盘价-开盘价的绝对值/收盘价<0.005 ANDMAX(收盘价,开盘价) < 昨收和昨日开盘价的较大值 AND 收盘价和开盘价的较小值 > 昨收和昨日开盘价的较小值
★十字胎赋值:昨收-昨日开盘价的绝对值/昨收 > 0.04 AND 平盘ANDCLOSE < 昨收和昨日开盘价的较大值 AND 收盘价 > 昨收和昨日开盘价的较小值
★平顶赋值:最高价-昨日最高价的绝对值/最高价<0.001
★平底赋值:(最低价-昨日最低价的绝对值/最低价<0.001 AND 昨日最低价-2日前的最低价的绝对值/昨日最低价<=0.001)
★大阳烛赋值:收盘价/开盘价>1.05 AND 最高价/最低价 < 收盘价/开盘价+0.018
★红三兵赋值:2日前的收盘价>2日前的开盘价 AND 昨收>昨日开盘价 AND 收阳线ANDSE 昨收>2日前的收盘价 AND 收盘价>昨收
★双飞乌鸦赋值:昨收<昨日开盘价 AND 收阴线ANDSE 收盘价/开盘价<0.98
★孕育线赋值:2日前的收盘价>2日前的开盘价 AND (2日前的收盘价-2日前的开盘价)/2日前的开盘价>=2/100 AND 昨日开盘价>=昨收 AND (昨日开盘价-昨收)/昨收<=2/100 AND 昨日开盘价<=2日前的收盘价 AND 昨收>=2日前的开盘价 AND 收盘价>=开盘价 AND(收盘价-开盘价)/开盘价>=2/100 AND 收盘价>=昨日开盘价 AND 开盘价<=昨收 AND (收盘价和2日前的收盘价的较大值-收盘价和2日前的收盘价的较小值)/收盘价和2日前的收盘价的较小值<=1/100
★多方炮赋值:2日前的收盘价>2日前的开盘价 AND 昨收<昨日开盘价 AND 收阳线
★出水芙蓉赋值:(开盘价<收盘价的20日指数移动平均 OR 开盘价<收盘价的40日指数移动平均 OR 开盘价<收盘价的60日指数移动平均) AND (收盘价>收盘价的20日指数移动平均和收盘价的40日指数移动平均和收盘价的60日指数移动平均的较大值的较大值)AND (成交量(手)/成交量(手)的30日简单移动平均>1.2 AND 收盘价/昨收>1.049)
★上升三部曲赋值:4日前的收盘价/4日前的开盘价>1.03 AND 3日前的收盘价<3日前的开盘价 AND 2日前的收盘价<2日前的开盘价 AND 昨收<昨日开盘价 ANDREF(最低价,4)<3日前的最低价 AND 4日前的最低价<2日前的最低价 AND 4日前的最低价<昨日最低价 AND 4日前的最高价>3日前的最高价 AND 4日前的最高价>2日前的最高价 ANDREF(最高价,4)>昨日最高价 AND 收盘价/开盘价>1.03 AND 收盘价>4日前的收盘价
★下跌三部曲赋值: 4日前的收盘价/4日前的开盘价<0.97 AND 3日前的收盘价>3日前的开盘价 AND 2日前的收盘价>2日前的开盘价 AND 昨收>昨日开盘价 AND 4日前的最低价<3日前的最低价 ANDREF(最低价,4)<2日前的最低价 AND 4日前的最低价<昨日最低价 AND 4日前的最高价>3日前的最高价 AND 4日前的最高价>2日前的最高价 AND 4日前的最高价>昨日最高价 AND 收盘价/开盘价<0.97 ANDCLOSE<4日前的收盘价
★跳空缺口赋值:最高价<昨日最低价 OR 最低价>昨日最高价
★三只乌鸦赋值:2日前的收盘价<2日前的开盘价 AND 昨收<昨日开盘价 AND 收阴线ANDSE 昨收<2日前的收盘价 AND 收盘价<昨收
★光脚阴线赋值:最低价=收盘价 AND 最高价<>最低价
★光头阳线赋值:最高价=收盘价 AND 最高价<>最低价
★分离赋值:开盘价=昨日开盘价 AND (收盘价-开盘价)*(昨收-昨日开盘价)<0
★长下影赋值:(收盘价和开盘价的较小值-最低价)/(最高价-最低价)>0.667
★长上影赋值:(最高价-收盘价和开盘价的较大值)/(最高价-最低价)>0.667
★十字星赋值:平盘ANDSE 最高价<>最低价
★大阴烛赋值:开盘价/收盘价 > 1.05 AND 最高价/最低价 < 开盘价/收盘价+0.018
★好友反攻赋值:(昨收<昨日开盘价 AND 收阳线ANDSE 收盘价-昨收的绝对值/收盘价<0.002) OR (昨收>昨日开盘价 AND 收阴线ANDSE 收盘价-昨收的绝对值/收盘价<0.002)
★倾盆大雨赋值:昨收/昨日开盘价>=1.03 AND 开盘价<昨收 AND 开盘价>昨日开盘价 AND 收盘价<昨日开盘价
EXPLAIN(★倾盆大雨,\'★倾盆大雨★见顶信号;\'),画青色
EXPLAIN(★大阴烛,\'★大阴烛★后市向淡,发生逆转;\'),画青色
EXPLAIN(★好友反攻,\'★好友反攻★底部反转;\'),画红色
EXPLAIN(★跳空缺口,\'★跳空缺口★注意向上还是向下跳空;\'),画白色
EXPLAIN(★光脚阴线,\'★光脚阴线★下跌信号;\'),画青色
EXPLAIN(★光头阳线,\'★光头阳线★后市看涨;\'),画红色
EXPLAIN(★三只乌鸦,\'★三只乌鸦★可能见顶回落;\'),画青色
EXPLAIN(★分离,\'★分离★注意看涨分离和看跌分离;\'),画白色
EXPLAIN(★长下影,\'★长下影★持续下跌后出现,有可能止跌回升;在升势末期出现,须多加留意;\'),画红色
EXPLAIN(★长上影,\'★长上影★表明行情上档压力沉重,升势受阻;\'),画青色
EXPLAIN(★下跌三部曲,\'★下跌三部曲★下跌信号;\'),画红色
EXPLAIN(★上升三部曲,\'★上升三部曲★上涨信号;\'),画青色
EXPLAIN(★早晨之星,\'★早晨之星★见底回升;\'),画红色
EXPLAIN(★黄昏之星,\'★黄昏之星★见顶回落;\'),画青色
EXPLAIN(★十字星,\'★十字星★有转向意味,注意股价位置在顶部还是底部;\'),画白色
EXPLAIN(★长十字,\'★长十字★注意在顶部还是底部;\'),画白色
EXPLAIN(★垂死十字,\'★垂死十字★下跌信号;\'),画青色
EXPLAIN(★早晨十字星,\'★早晨十字星★上涨信号,见底回升;\'),画红色
EXPLAIN(★黄昏十字星,\'★黄昏十字星★下跌信号,见顶回落;\'),画青色
EXPLAIN(★射击之星,\'★射击之星★可能见顶回落,可靠性低;\'),画青色
EXPLAIN(★倒转锤头,\'★倒转锤头★可能见底回升;\'),画红色
EXPLAIN(★锤头,\'★锤头★可能见底回升,如有量配合,信号强烈;\'),画红色
EXPLAIN(★吊颈,\'★吊颈★上升行情中见顶回落,顶部出现,见顶信号;\'),画青色
EXPLAIN(★平顶,\'★平顶★温和的反转;\'),画青色
EXPLAIN(★穿头破脚,\'★穿头破脚★顶部出现,见顶回落信号;\'),画青色
EXPLAIN(★乌云盖顶,\'★乌云盖顶★见顶回落信号;\'),画青色
EXPLAIN(★曙光初现,\'★曙光初现★后市见底回升;\'),画红色
EXPLAIN(★身怀六甲,\'★身怀六甲★出现在底部,是见底回升信号;出现在顶部,是见顶回落信号;\'),画红色
EXPLAIN(★十字胎,\'★十字胎★\'),画红色
EXPLAIN(★平底,\'★平底★温和的反转;\'),画红色
EXPLAIN(★大阳烛,\'★大阳烛★看涨;\'),画红色
EXPLAIN(★红三兵,\'★红三兵★每日收盘价上移,表示可能见底回升;\'),画红色
EXPLAIN(★双飞乌鸦,\'★双飞乌鸦★行情将见顶回落;\'),画青色
EXPLAIN(★孕育线,\'★孕育线★注意股价位置;\'),画白色
EXPLAIN(★多方炮,\'★多方炮★在底部出现有上涨可能,在中间出现有可能是上涨中继,顶部出现是复合见顶信号;\'),画红色
EXPLAIN(★出水芙蓉,\'★出水芙蓉★见底回升;\'),画红色
 


好股票软件下载网(www.goodgupiao.com)提醒您:股市有风险,投资需谨慎。
相关说明
  • 好股票软件下载网欢迎用户将网页内容和下载地址转发到博客、微博、论坛等。
  • 发布的公式指标绝大部分是来源于各大论坛,谢谢各位老师的原创指标。
  • 判断公式指标好坏,请用户参考用户评论或者软件好评度
  • alg格式股票公式,仅仅可以用飞狐交易师股票软件引入使用;
  • fnc格式股票公式,可以用大智慧新一代高速行情分析系统股票软件使用,少部分可以用分析家股票软件引入使用;
  • exp格式股票公式,仅可以用大智慧经典版股票软件引入使用;
  • tnctni格式股票公式,仅可以用通达信新引入使用,例如可以用通达信股票软件引入使用;
  • tne格式公式,仅可以用通达信公式编辑器5.0版导入,高版本兼容低版本;
  • hxf格式股票公式,仅可以用同花顺股票软件引入使用。
  • 如果引入公式的时候,发现公式名称栏空白,调整电脑时间到1997年,能出现公式名称并正常显示,可能是公式使用期限已过。
  • 如果您发现下载链接错误,请点击报告错误谢谢!